cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Cannot set DNS fields for LAN clients to use. Fields are disabled.

Reply
13 REPLIES 13
bananasareyellow
Popular Poster

Firmware version SG4K10002600t.

 

I can set the DNS servers for the router itself to use, on this page:

 

Screenshot from 2019-07-01 14-26-10.png

 

This works, because the Device Info page now lists those DNS settings:

 

Screenshot from 2019-07-01 14-34-40.png

 

But I can't set the DNS for LAN clients to use, on this page:

 

Screenshot from 2019-07-01 14-29-31.png

 

The fields are disabled. I was able to set these values before the firmware got updated but now I can't.

 

This is the same issue that @trishaxuk and @davidnunn have reported but I was asked by the Community Team to start my own thread.

 

I still have my old HG633 router lying around so I could use that instead, but I'd prefer to use this newer, supposedly faster router. I just want this bug to be fixed in a new firmware version.

 

I could also use the HG633 as a separate DHCP server, as @trishaxuk has suggested here, which should work, but I'm nevertheless reporting this issue so it can be fixed.

David Taylor
KeithFrench
Community Star

By default, they hand out the router (192.168.1.1) as the client's DNS server within the DHCP Offer. Unless you have a DNS server on your local subnet, changing this if you could, would render your DNS operation inefficient. I think this is why they have probably greyed it out.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

bananasareyellow
Popular Poster

That makes sense, but it was enabled before when I set those values. Now I can't even change it back to 192.168.1.1.

David Taylor
KeithFrench
Community Star

I have just had time to check mine & running firmware 2600 mine are not greyed out & I can definitely change them. I would, therefore, recommend that you try a factory default of the hub configuration.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

bananasareyellow
Popular Poster

Interesting. Have you set DNS servers for the router itself?

 

I will experiment. Maybe removing the DNS servers for the router (to default to TalkTalk servers) will enable the DNS server fields for the LAN.

David Taylor
KeithFrench
Community Star

You set the DNS servers that the router uses from the Internet Connectivity section.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Jools912
Conversation Starter

Having setup a Pi-Hole at the weekend I too have discovered that the DNS settings are greyed out.

 

I want all the devices on my network to use the Raspberry Pi for DNS so the ad blocking works network-wide, but now the fields are disabled I can't do that.

 

I wasn't like that before because I have previously changed the DNS to 1.1.1.1 and 1.0.0.1 and those settings are still there, but cannot be changed.

Community Team
Jools912
Conversation Starter

Yes, the Sagem FAST 5364 with firmware SG4K10002600t

Jools912
Conversation Starter
The instructions you provide for changing the DNS at the link below, no longer work as the fields are no longer editable:

https://community.talktalk.co.uk/t5/Articles/Using-3rd-Party-DNS/ta-p/2205279
Community Team

Hi

 

We will feed this back to our device teams.

 

Thanks

 

Karl. 

KeithFrench
Community Star

Hi @Jools912 

 

Have you tried a factory default of the hub's configuration? Mine, running on the same firmware is fine. I can change the DNS servers at will.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Jools912
Conversation Starter

Thanks @KeithFrench that did the trick. In my brief testing all appears to be working again.

 

Cheers!

Community Team