cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

DHCP Pool Ranges Invalid AND Friendly names not saving

ANSWERED
Reply
kndusr19
Popular Poster

This may sound silly, but I had a similar issue on the TalkTalk WIFI hub and what I did was plug the hub just into my PC directly via ethernet (not plugged into anything else like other devices or phone line) and I was able to save changes to DHCP settings. 

skudwise
Popular Poster

Thanks for the suggestion, however I have tested and this trick does not work with this hub/firmware.

falloutphil
First Timer

Brand new fast broadband customer here - and the router gui (hopefully not the router itself, although one wonders!) is absolutely riddled with bugs!

 

I also have the issue of not being able to to assign address ranges, but have found that if you pick the range carefully you can get it to work - for example x.x.x.24 to x.x.x.96 works for subnet 255.255.255.0.  If you try to do x.x.x.20 to x.x.x.100 you'll get the invalid IP address.  I imagine this is because of dodgy error checking based on the subnet mask.  If you read-up on the details of how subnet masks are applied/represented then it's possible to imagine how the code might behave incorrectly in the gui.

 

If you want to reset the actual router IP address - just type it in and then immediately save it without clicking away from focus on the textbox.  This works for me, at least.

 

However I've noticed an even more annoying bug.  Once you've overcome this.

 

@OCE_Karl- I see you confirmed a firmware update was on it's way... but can TalkTalk comment if the below has been fixed in the update or if I need to raise a new thread for it? - to reproduce I include steps below:

 

From the DHCP tab:

 

Change router IP address/subnet mask to 192.168.0.1/255.255.255.0.

Change DHCP internal address range to 192.168.0.24 to 192.168.0.96 (using IPv4 Pool Start/End boxes).

 

This is possible, but fiddly with the current firmware because of the bugs mentioned in this thread.

 

NOW - there is a new bug tho.

 

NEW ISSUE 1 - When a client registers with the router it is *still* given 192.168.1.1 as the DNS address!

 

Hopefully it is immediately obvious why having a router with IP address 192.168.0.1 on subnet 255.255.255.0 can never possibly have it's DNS on 192.168.1.1.  That address is outside the address range of the network the router has setup!

 

So nothing works.

 

The only way around this is to stick with the ranges given, or ditch DHCP in favour of static IP registration.  Neither is really acceptable.

 

If it's not obvious the bug causes all domain name look-ups to fail for the customer - which is basically the same as saying "there is no internet access" for practical/normal use.

 

When will this be fixed so changing the router IP address also changes the default DNS address?

 

Update - this issue can lead to more annoying problems if you WFH.  For example if a member of your household uses a company laptop, it is possible that their system admin have locked down the permissions to give a different IP/DNS (this happened in my household).  Short of begging your company's IT support staff to do a bespoke setup, the only workaround I've found is to create a new NAT from one of your household computers (with a static IP and hardwired ethernet cable connection to the TalkTalk router/NAT) over a completely different address range.  The company laptop can then connect to this NAT, which will then route through to the correct DNS via your household computer's connection to the gateway of the outer NAT.

 

This might sound complicated, but if you have a Mac this is easy to setup, connect the Mac to the router via ethernet cable and setup static IP connection with the correct DNS.  Then, System Preferences -> Sharing -> Internet Sharing, and then setup Wi-Fi Options and tick Wi-Fi.  The Mac's Wi-Fi becomes a second Wi-Fi router which side-steps the TalkTalk router's DNS bug.

 

NEW ISSUE 2 - Also there are similar defaulting issues with the firewall - even if you change the router address is looks like the custom (and perhaps the other rules too) are still all allocated to the internal 192.168.1.x range.  This won't allow or block anything if you've changed the DHCP address range - the firewall is protecting nothing at this point!

 

The workaround here is obvious - just delete all the custom firewall rules and create your own.  My strong advice is not to use the out-the-box medium (to insecure IMHO) or high (potentially suffers from the issue above) default settings.

 

It's a bit surprising dealing with such trivial issues - on products that protect member's security.  How slapdash the programmers and tests must have been - that I can find these issues within less than 10 minutes of opening my new router box?!

 

 

 

 

 

Community Team

Hi

 

The DHCP issues called out are already on the teams radar, but I've sent all the details across to be absolutely sure they have these noted.

 

Thanks

 

Karl. 

falloutphil
First Timer

Thanks for passing this on.

 

The DNS and Firewall issues, although probably related to the DHCP, are potentially their own issues.  It's impossible to say without seeing the code, but they could be hardcoded in isolation rather than driven off the DHCP - which mean they'd need separate fixes. 

 

So passing the details on to the developers should hopefully mean they think about the wider effects of having someone legitimately change their router address.

 

Cheers.

skudwise
Popular Poster

2 months + and no new firmware / info / etc etc.  Time for a new provider..

falloutphil
First Timer

With a lot of patience I was able to eventually change my router IP address.

Basically depending on exactly how you arrive at the correct page in the router website, it may or may not be greyed out!

I have no idea exactly what I did to make it work - nothing logical or sensible.... and I'm not prepared to experiment any further, in case I loose the settings again.

But it is possible to do if you waste your time trying every possible combination of clicks to get to the appropriate setting.

KeithFrench
Community Star

There were bugs prior to V2600 firmware that could prevent IP address changes, but I am not aware of any since this firmware was released. Once again the issue of friendly names is still not fixed, but it is hoped it will be in the next version.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

skudwise
Popular Poster

No, still waiting on a release date.

Keith

version SG4K10002600t

is the version with the issue???

 

In May you said you were waiting for a release date to fix this issue, has it been released????

Thanks

KeithFrench
Community Star

I have never promised a release date for the next firmware, I am after all just a customer. I have no control over TalkTalk.

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
skudwise
Popular Poster

Hi Keith,

 

I am not saying you promised anything, just trying to find out whether this issue will ever be fixed. There was lots of talk in May about it being addressed and nothing. As per your posts, they implied a firmware fix was coming, wondering whats happened to it. Thanks

skudwise
Popular Poster

Looking back on the topic, would be great to get a response from Karl about this.

Community Team

Hi,

 

Just to advise, the new firmware will be going into testing soon and once this has been completed then we should then be provided with a date for this to be fully rolled out.

 

Thanks