cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

DNS settings on DSL-3782

Reply
27 REPLIES 27
Highlighted
Whizz Kid

Hi

 

Anyone know how to set your own choice of Primary and Secondary DNS on the DSL-3782. It's not apparent from the router settings screens.

 

Thanks in advance.

M

Highlighted
Community Star

Have you really got a DSL-3782, if so how did you get it, as it has not been released by TalkTalk?

 

Assuming it is similar to the 3780 this is under:-

 

Advanced > DNS

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Philosopher
Looks like it HAS been released now !
The OP refers to receiving his new DSL-3782 Super Router in another thread.
Martin
Highlighted
Whizz Kid

@martswain wrote:
Looks like it HAS been released now !
The OP refers to receiving his new DSL-3782 Super Router in another thread.

Yes, can only only assume martswain is correct.

 

As to the settings, there's several 'advanced' hyper links under various main settings that expand by screen drop downs for that element (e.g., WLAN, WIFI, etc.,), but none show any DNS options.

 

 

 

M

Highlighted
Community Star

Well we the Community Stars have never seen this router, which makes this very difficult to answer your question. Please can you provide me with some screenshots of the router config to do with the WAN, Internet & IP config areas? Then I will try & help you.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Community Star

I have been able to find out something for you. Apparaently you need to click on the Internet icon which will show the current state, clicking on the IPV4 link top right will show the DNS servers currently in use.

 

Then click the "Go to settings" link bottom right. Then find the Network Advanced settings (no idea how this is displayed), in there you will find some text boxes for primary & secondary DNS server addresses. Now what I cannot be sure is is this just the addresses that you want to hand out with the DHCP requests (it is just below the DHCP settings), or is it the ones you want the router to use.

 

What I would do is set them to say Google's DNS (8.8.8.8. 8.8.4.4), then connect a device & check what addresses have been handed out to this client in respect of DNS (e.g. ipconfig /all for a windows PC). If this is still 192.168.1.1, then all would seem good. Go back to the original Internet icon & check what ones it is using there, hopefully it will be Google's.

 

That is the best I can do, if I had one myself, then I could be more precise. 

 

Please let me know if this works.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Whizz Kid

@KeithFrench wrote:

I have been able to find out something for you. Apparaently you need to click on the Internet icon which will show the current state, clicking on the IPV4 link top right will show the DNS servers currently in use.

 

Then click the "Go to settings" link bottom right. Then find the Network Advanced settings (no idea how this is displayed), in there you will find some text boxes for primary & secondary DNS server addresses. Now what I cannot be sure is is this just the addresses that you want to hand out with the DHCP requests (it is just below the DHCP settings), or is it the ones you want the router to use.

 

What I would do is set them to say Google's DNS (8.8.8.8. 8.8.4.4), then connect a device & check what addresses have been handed out to this client in respect of DNS (e.g. ipconfig /all for a windows PC). If this is still 192.168.1.1, then all would seem good. Go back to the original Internet icon & check what ones it is using there, hopefully it will be Google's.

 

That is the best I can do, if I had one myself, then I could be more precise. 

 

Please let me know if this works.


@KeithFrench - thanks for your detailed reply, much appreciated. When at home and as soon as I get a chance to work through on the router I'll post back with some screen shots. Hoping to set it up ready before the fibre here goes live, which is not until later in the week.

 

Shame that from what's been said and having a look around the forum, that the router doesn't appear to have been offered out for all those dedicated and knowledgeable triallists out there. What's the thinking here TT?!

 

For anyone curious, this may be of interest:

ftp://ftp.dlink.de/dsl/dsl-3782/documentation/DSL-3782_man_reva_Manual_en.pdf

 

M

Highlighted
Community Star

It would appear from what I can find out that you were part of a closed trial. The other thing I have found out is that the DSL-3782 is running a TalkTalk specific firmware, which I assume should make it easy to connect to TT's ADSL or VDSL, it also may mean that the info in my last post is now total garbage.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Whizz Kid
Thanks KF, see edited previous reply.
Highlighted
Community Star

I have just found out that apparently you can't change the DNS servers currently, but this has been fed back to D-Link to find out why?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Whizz Kid

@KeithFrench wrote:

I have just found out that apparently you can't change the DNS servers currently, but this has been fed back to D-Link to find out why?


Ahh...would be interested on the response to that. Curious though that the user manual clearly shows that you should be able to.

 

Screen Shot 2016-11-28 at 12.43.40.png

 

 

Would it have changed by the TT styled firmware? If so why?

 

 

Highlighted
Community Star

Yes that is where I got my original information from, although as I said that may be the DNS address that the DHCP response hands out to the client & if so, that is not the right place anyway.

 

I can't answer if the TT firmware would have changed this, does the user guide screenshot (OK D-Link firmware) match what you have? At least if you can't add them, it has been passed back to D-Link to hopefully get it sorted, before it gets released.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Whizz Kid

@KeithFrench wrote:

I have just found out that apparently you can't change the DNS servers currently, but this has been fed back to D-Link to find out why?


Thanks KF.

 

FWIW, the image shows what is displayed on the network settings page with advanced settings shown, which obviously doesn't match with what's in D-Link's user manual, except bearing in mind it's TTs 1.05t firmware on the router.

Noticed also that the usual BB authentication (u/n, p/w) and other info such as to set 'aways on or not', type info is nowhere to be seen.

Suppose this sort of input/view isn't needed anymore or required for VDSL/fibre.

 

Screen Shot 2016-11-28 at 17.25.25.png

 

 

I'll hold fire now until go live.

M

Highlighted
Philosopher

I can say that the screenshot from the TT version of this router as shown by Montana is also shown on mine. The difference is that the DHCP table on mine is populated with a list of all Active and Deactive (sic) devices. The latter being those that have connected but currently are not connected.

 

It is well observed that this is not the same as the illustration from D-Link's instructions in the same part of the menu system, there is no opportunity to nominate your own DNS addresses.

using 11 years old Dell Inspiron 545, running Windows 10 and a Realtek RTL8811AU Wireless LAN USB Network Adapter with Sagemcom FAST 5364 router.
Highlighted
Community Star

Hi @Montana

 

You can easily enabled always on:-

 

 Go to Settings > Internet > Advanced Settings

 

Connect Mode Selec : Always On

 

Always On.png

 

If you are on fibre though you probably won't get this option, as it is an always on service anyway.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Whizz Kid

Thanks @KeithFrench, not needed to review the ADSL settings but left things as follows with the WAN connection type set to Auto as shown, so how it distinguishes an ADSL or VDSL set up for the advanced settings is not clear:

 

Screen Shot 2016-12-01 at 18.17.06.png

 

 M

 

 

Highlighted
Community Star

Any router (e.g. the HG633) that works on VDSL or ADSL and its connection type is set to Auto tries to train up to one media type & then if unsuccesful, tries the other.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Team Player

Hi ,

I have just received a DSL-3782 with an contract renewal, and I can confirm that there is no option to set your own DNS values. 

This is very sad as I normally use OpenDNS since I have trust issues with vendor provided DNS settings.

I did try to save settings to a local file, editing the DNS settings in the file, and uploading the modified romfile.cfg. This failed miserably with the router becoming unresponsive, and requiring reboot.

After the reboot, the DNS was automatically reset to the 'factory' values, 79.79.79.79 & 79.79.79.80

 

Can anyone suggest a reason why the 3782 is so obtuse about DNS values ?

In the past I have had issues with DNS and it was useful to be able to switch to another service.

 

Highlighted
Community Star

I flagged that up to TalkTalk's product team at the start of the trial. There is new firmware being developed and I am hopeful that it will be in that version when it is released. I put a lot of other requests to them as well & although I have no idea currently what is going to be implemented in the new firmware, I have been told that quite a lot of my recommendations will be in there.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Team Player

Thanks Keith,

I hope that update will be soon. I've had this router for 2 days now, and although it is streets ahead of the 3780 in the interface, I'm having niggly problems like the connections seem sluggish, and my VPN connection to the office no longer works normally, to the point where I think I will need to roll back to the 3780.

Also, the usb config needs attention, but it is no big deal for me at the moment.

(no way to set smb password)

The speed checkers show quite good results (42.6 down, 2.5 up), but the VPN connections are just sluggish, as are my local wireless connections.

Perhaps you could post an ETA for the firmware updates when you get some news about it ?

Cheers