cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

FIBRE SPEED BOOST NOT WORKING

Reply
10 REPLIES 10
Highlighted
album56
Participant

I have superfast fibre, which upgraded from faster fibre a couple of weeks ago by clicking on the offer online but my speed has not changed from 38mbps ?? The speed boost is not working, this seems to be a problem with Talktalk systems. Please can a helpful person at Talktalk sort this out for me, I should be seeing approx 68mbps.

Highlighted
Community Team

Hi album56

 

Apologies for this.

 

If you log into My Account does the fibre speed boost show there?

 

Thanks

 

Debbie

Highlighted
album56
Participant
Hi Debbie
Thankyou for looking into this, in answer to your question, no there is no indication of speedboost on my account.
Highlighted
Community Team

Hi album56

 

Is there an option showing to add this in My Account?

 

Thanks

Highlighted
album56
Participant

Hi Debbie

I cant find an option to add speedboost in my account.

Highlighted
Community Team

Hi @album56

 

I have requested that the speed boost is added, It looks like it was missed off your renewal order. 

 

Your speeds should increase today. 

 

 

Highlighted
album56
Participant

Thankyou for your assistance Debbie & Arne.

Highlighted
Community Team

Hi album56

 

Please let us know how you get on.

 

Thanks

 

Debbie

Highlighted
paulshent
Community Star

Hope your speed increase works

Also if you have problems be aware that your landline will or will not support more than 39Mbs

I had issue after adding the boost then found that my line would not support the extra speed boost.  Just something to think about when boost is added for you to check

Line connection speed can also be seen by logging on to Router Admin account and checking your line connection speed.

 

Highlighted
album56
Participant
My broadband speed has increased from 38 Mbps to 59 Mbps so speed boost successful, many thanks Debbie & Arne.
Highlighted
Community Team

Hi album56

 

That's great, thanks for keeping us updated 🙂

 

Debbie