cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Faster Fibre Issue

Reply
11 REPLIES 11
Highlighted
Chatterbox

Two weeks after “upgrading” to Faster Fibre, it’s still not working - solid amber light on my new WiFi hub.  Have been in touch with TalkTalk via chat, text and phone, but this issue has not been resolved. Latest I was told was that it would be fixed by 27 Feb.  I am somewhat frustrated!

Highlighted
Community Team - TT Staff

Hi Bristolrugby 

 

I'm really sorry to hear this.

 

Please can you update your Community profile to include your name, telephone number and alternative contact number, we can then look into this further (Please do not post this information on this thread)

 

Please bump this thread to confirm once your Community profile has been updated.

 

Thanks

 

Debbie
 

Highlighted
Chatterbox
Thanks for your response. Profile updated
Highlighted
Community Team - TT Staff

Hi Bristolrugby

 

Thanks for updating your Community Profile.

 

I'm just sending you a Private Message to confirm some details.

 

Debbie

Highlighted
Community Team - TT Staff

Hi Bristolrugby 

 

Thanks for the Private Message.

 

Are you currently in the process of leaving TalkTalk?

 

Thanks

 

Debbie

Highlighted
Chatterbox

Good morning.  

Yes. Primarily because of the issues I’ve had with the non existent Faster Fibre! Really did not want to leave but nobody seems able to tell me why it’s not working 

Highlighted
Community Team - TT Staff

Hi Bristolrugby,


I'm really sorry for any inconvenience caused by this issue, have you been given a date when you move to your new provider?

 

Chris

Highlighted
Chatterbox

Hi Chris.

 

Yes - 5 March 

Highlighted
Community Team - TT Staff

Hi BristolRugby,

 

I'm really sorry but I think it's unlikely that we're going to be able to resolve this before you leave as it looks as though you will need an engineer visit, you still appear to be on an ADSL circuit (standard broadband). 

 

Chris

Highlighted
Chatterbox

Hi. Well that’s interesting. Over two weeks of not knowing what’s going on, and I’m now being told that an engineer visit is required!  Not good customer service!

Highlighted

Did you get this resolved? I have exactly the same problem and am getting nowhere with the Chat service.

 

Highlighted
Community Team - TT Staff

Hi ttforummartin,

 

I'm sorry to hear this and I've posted on your thread this morning.

 

Thanks