cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Faster Fibre got worse after 1 month or so

Reply
9 REPLIES 9
Highlighted
First Timer

Faster Fibre that i have signed up for in January was actually pretty good for the start. But after couple of months or so the internet speed has gone down from 70mb/s+ down to barely reaching 50 sometimes even gets down to 40. I would like to know why is is happening. Some help would be appreciated.

Highlighted
Community Star

Hi @Magdusia ,

 

Have you tried switching the router off for over 30 minutes, then when you switch it back on it will start a new 'session', this can sometimes help it reconnect at a better speed.

 

It would be worth going to the Service Centre to do a test on your phone line, this will indicate if there is currently a fault on your line that might be affecting your speed. You can also access this from the ‘My Account’ site.

 

Also, if you have a landline phone can you check to see if that is working normally (i.e. you have a clear dial tone and no noise on the line).

 

For one of the TalkTalk staff on this forum to be able to look into this you will need to update your community profile to include your name, landline telephone number that your TalkTalk service is provided on & an alternative contact number. This will allow them to identify you, and they will then be able to help.

 

Don't post any personal details in this thread, just add them to your community profile.

 

The staff won't be around now until Monday, but they should be able to respond to this post early next week to help.

Highlighted
First Timer

Hi my speed is 16mbps average. I'm getting so unhappy. 

MR PM BEXON
Highlighted
Community Star

Hi @Poulo B ,

 

If you would like some help from the staff here to investigate your speed issues then you will need to start your own topic, the staff here can only help one customer per topic.

Highlighted
First Timer

Looks like I just have to wait. Seems like everything so far is OK yet the speed is still below the estimated. Always an issue with the providers... I'll wait for response from the team 🙂

Highlighted
Community Team - TT Staff

Hi Magdusia,

 

I'm sorry for the delay and I'll take a look now. I've run a test on the line which hasn't detected a fault. Just to confirm, what speeds are you currently receiving at the moment and are you running the speed tests wired or wireless?

 

Thanks

 

Highlighted
First Timer

Wired Connection

 

   Current speed

   Download
   54.6 Mbps
   Upload
   9.2 Mbps
   These are my current speeds where as before I was getting around 70+ 
Highlighted
Community Team - TT Staff

Hi Magdusia,

 

I'm sorry for the delay. Does your master socket have a test socket? If it does then would it be possible to connect the router at the test socket for at least 48hrs so we can see if DLM increases the sync speed? Is the voice service ok with no noise on the line?

 

Thanks

 

Highlighted
First Timer

The line is always clear. The line was tested many multiple times in master socket and the speeds have never improved. The speeds were exactly the same so the router is connected upstairs in other normal socket which never had any issues. I just don't understand how the speed can suddenly drop without any modification or changes to the settings. 

Highlighted
Community Team - TT Staff

Hi Magdusia

 

Does your master socket have a test socket? Your guide to master sockets

 

Thanks