cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

HG635 port forwarding

Reply
11 REPLIES 11
Popular Poster

Hi,

I've set up port forwarding on the HG635 as per the usual instructions: Internet -> port forwarding -> port mapping -> add new port mapping -> add port mapping application -> add etc.

 

However, the port isn't being forwarded.

 

Are talktalk still allowing port forwarding at their end, or do I have to request something?

 

Thanks.

Community Star

Port forwarding is of course allowed, but I cannot help you unless you provide more details.

 

Please tell me which TCP or UDP port you are trying to forward & please include a screenshot of what you have setup in the router. What sort of device are you trying to forward to & what operating system is it running. If a Windows PC, have you added an inbound rule to the firewall?

 

How are you trying to test this?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Popular Poster

Hi,

Port 3000, both TCP and UDP.  Screenshots attached (sorry, it doesn't allow png attachments).

 

Trying to make port 3000 of a Linux (Ubuntu 18.04) server visible to the world.

 

Its not a firewall problem on the server, as its available to other hosts on my LAN/wifi.

 

I've tried with the talktalk router firewall disabled and set to "talktalk".

 

Trying to test by connecting to the port, port scanning, etc (from outside my LAN).

 

Thanks...

Community Star

There is nothing wrong with the port forwarding rule on the router, please re-enable the router's firewall with its default configuration. That is not the issue. The port forwarding rule punches a hole through the firewall for this port. The next steps are as follows:-

 

  1. Port checking sites on the web, will only test TCP port 3000, they are totally incompatible with UDP.
  2. When testing, you cannot check from a locally connected device, out to the internet & back in again. This is classed as loopback traffic & is blocked by TalkTalk routers, because they consider it a security risk.
  3. I assume that you are using the router's current WAN IP address when port scanning from outside of the network, as this is subject to change. Far better is to use a DDNS domain.
  4. Please can you get me a screenshot of the networking configuration of the Ubuntu (I did say in a previous post, you include images via the "Insert Photos" button on the forum editors toolbar, but please make sure that you chose the size option set to large, within it?

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Popular Poster

Hi Keith,

I've changed it to port 22, ssh, using the built in SecureShellServer option.

It is still not working - and I know this isn't a problem with the server (a laptop, which is always ssh accessible on other networks, and on the LAN).

The external IP address as detected by websites (google what is my ip), and as given by the router agree.

I am not testing with loopback - i.e internally.

I cannot ssh from public internet servers which I have access to back to my network.

This is almost certainly a problem either with router settings (which I don't think is the case), or with talktalk blocking port forwarding.

 

Are there any talktalk staff on here who would be able to help?

 

Thanks...

Popular Poster
Community Team - TT Staff

Hi usedToBeagb32

 

Would you like me to send a different router for testing?

 

Thanks

 

Debbie

Popular Poster

Hi Debbie,

No thanks - I don't think its a problem with the router.

 

 

Community Star

Can you run Wireshark on the server?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Community Star

Hi @usedToBeagb32 

 

The link that you put in one of your recent replies refers to a WiFi Hub, which is totally different to an HG635. All routers that I have ever tested work correctly where port forwarding is concerned (OK I have never tested the HG635, because I never had one, the HG633 works fine & is nearly identical). I have certainly helped other people with the HG635 & got their port forwarding working.

 

On my Sagemcom WiFi hub I just tried to forward TCP port 22 for SSH to my PC & it worked first time.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Popular Poster

Hi,

Just got back to checking this, and talktalk have opened up the port their end.

 

For anyone reading this in the future - basically, by default, it seems that talktalk don't allow port forwarding, and that you have to request it, e.g here, and then wait a few days.

 

Thanks, all...

Community Star

Hi @usedToBeagb32 

 

Of course TT allow port forwarding, but it is down to you to configure it properly to meet your requirements.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they?