cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Have to restart router every few days to get promised minimum speed

Reply
17 REPLIES 17
benht
First Timer

Hello,

 

Every few days my download speed drops massively.  Upload remains constant around 8Mbps but download drops from around 20-30Mbps to around 3.2Mbps (the reading from the last test). 

 

Promised speed is 24 Mb - 37Mb and the service centre panel says it measured 40Mb today.

 

Restarting my Huawei HG633 router fixes it for another few days, it's instantly better.

 

So what could be wrong?

 

Notes - I'm testing via wifi but I get the same results when plugged into one of the ethernet sockets on the router.  I've disconnected everything (from wifi and ethernet) and get similarly bad results regardless of what one device I connect just to run the test. I think that must mean there's nothing wrong with the cables, wifi or my equipment since restarting the router fixes the speed (which I'm about to do now).

ferguson
Community Star

Sorry to hear this. Whereabouts do you have your router connected to the incoming line? Are you aware of any issues with your phone service at all?

 

Subject to that the online support team will gladly look into this for you. Make sure that your personal details including TalkTalk landline number are complete on your community profile here so that they can link your forum identity with your account and then wait for them to respond.

 

benht
First Timer

We don't even have the landline plugged in so not aware of any issues there... but if there were line issues, why would they disappear when the router is restarted?

 

The router is connected the same way it's been connected for the last few years, on the end of a CAT5 cable behind the walls and under the floor to the phone socket at the front of the house. Since I restarted the router today, I'm getting a very nice 33.4Mbps download.  In 2 days time, who knows.

ferguson
Community Star

Any landline issues will not "disappear" when the router is restarted, it is just that progressively they will manifest themselves more as any noise increases. It really is worth checking the phoneline for any noticeable noise. And also try connecting the router directly to the master socket, or test socket if you have one. That's what it's there for.

benht
First Timer
Ok will try to find a land line phone and give that a try and get back to you.
benht
First Timer

It's finally done it again (interesting how it's been a while this time)!

 

I'm getting a range of results under 10Mbps download.  Upload remains consistent at about 8Mbps.

 

There is no obvious noise on the line.  It's got a normal amount of background hiss, presumably caused by the cordless phone system I've plugged in rather than the line.

Community Team

Hi benht,

 

Your current sync speed is 39.2Mbps, have you rebooted the router since the problem recurred?

Chris

benht
First Timer

Hi,

 

No I haven't (so any tests needed can be run).

 

8.6Mbps download (8.3 up) though the test started higher, then dipped (not sure if that actually means anything).

 

thanks,

 

Ben

Community Team

OK thanks, what device did you run the test on? Is it connected to your router by Ethernet cable or wi-fi?

Chris

benht
First Timer

Laptop same as always. 

Connected via wifi, speed results are the same if I connect via ethernet cable (de ja vu).

benht
First Timer

It seems to be recovering by itself now (unless you're doing something, in which case, keep doing it!).  Measured 27.8Mbps on my phone and 12.6Mbps on the laptop (which implies there's something happening with the laptop/connection too - but previously rebooting the router fixed the speed as tested from the laptop).

 

benht
First Timer

Scratch that, it's only recovered a little - 11.3 on the phone, 13.4 on the laptop (tests not run at the same time obviously and that's after re-connecting laptop to the wifi).

 

So it's still well below the 18.x minimum it's supposed to do and I know that it'll get 24mbps+ if I restart the router!

Community Team

Hi benht,

 

I'm sorry to hear that the speeds are still varying. Would you like us to send a 3782 router for testing purposes to see how the speeds compare?

 

Thanks

 

benht
First Timer

Hello,

 

Sounds like it's worth a try, yes please.

 

thanks,

Ben

Community Team

Hi benht,

 

I've ordered the router, it should be with you within a couple of days but please allow up to 5 working days for delivery
Thanks

Chris

benht
First Timer

Hello,

 

The new router has been solidly doing about 27Mbps download for a few weeks now so I'd say that's solved it.

 

Thanks all 🙂

 

Old router in the post as directed.

Community Team

Hi benht,

 

I'm glad to hear this and thanks for keeping us updated 🙂

 

Thanks