cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Hub new firware - NAT

Reply
22 REPLIES 22
coastliner
Participant

I have the new firmware, which I tried for a few weeks, but ended up buying a third part router.

 

My understanding is the the new firmware still doesn't allow the option of using a modem only mode. So I have tried the next best thing.

 

I have my second router in the DMZ of the TalkTalk router. It mostly works OK. But ideally I want to disable NAT in the TalkTalk router. There is an option for this, but when trying to switch it off it just says that it can't do it.

 

Am I missing somthing technical that I should be enablling or disbaling before it will allow me to disable NAT?

 

 

KeithFrench
Community Star

No ports can get through the hub without first creating a rule for it under port forwarding. So it is disabled.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

coastliner
Participant

@KeithFrench wrote:

No ports can get through the hub without first creating a rule for it under port forwarding. 


But they do using DMZ. My second router's port forwarding works. I have no ports fowarded on the TalkTalk router.

 


@KeithFrench wrote:

So it is disabled.


Not sure what you mean by this?

KeithFrench
Community Star

Well yes if you have put a device in the DMZ every single port is open, presenting a security risk to that device. If the device is removed from the DMZ and no manual port forwarding rules have been added, then nothing will get through in an inbound direction. Due to security problems it is worth disabling uPnP as well.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

coastliner
Participant

As my second router is in the DMZ and the second router is designed to be open to the internet, how can this present a security risk to the second router?

 

Everything else in my network is connected to the second router. I am just trying to turn the TalkTalk router into a modem only, as much as possible.

 

Nothing is connected to the TalkTalk router apart from the second router. The TalkTalk router points the DMZ to the second router.

 

I have disabled uPnP in the TalkTalk router.

 

I therefore also want to disable NAT in the TalkTalk router (and leave the NAT to the second router).

 

So going back to my orginal question. Why is the TalkTalk router NOT letting me do this? The option is there in the new firmware.

KeithFrench
Community Star

Unless you have a reason to, get rid of the DMZ altogether, you are doing this wrong. 

 

In the new router set its IP address to 192.168.1.2 and put it into bridge mode. Disable the DHCP server in this router as well. Disconnect the two routers routers for the time being.

 

In the TT router leave this at its default configuration, but go into the DHCP server configuration and ensure that the first IP address in the pool is set to at least 192.168.1.3. By default the TT WiFi hub starts st 192.168.1.10, so that is fine.

 

Connect the two routers up via their LAN ports & all should now be OK. All routing is done by the WiFi hub and your new router is just an access point.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

coastliner
Participant

Sorry I think you're misunderstanding what I want to achieve.

 

I do not want to use the TT router for anything other than a modem. I have bought another router due to huge frustrations I have had and many, many wasted hours trying to set up the TT router.

 

My new router does everything I want it to. (other than include a modem). I don't really want the extra expense of another modem as well.

 

My original question and still the question I would like an answer to is how to turn off NAT in the TT router?  When the NAT switch is turned off, it just says "something went wrong". 

KeithFrench
Community Star

The hub, in common with all current TalkTalk routers does not support modem mode. What I have told you is the only way this will work. Of course had you bought the modem/router version of your 3rd party router you wouldn't have this problem.

 

The only other solution would be to buy your own modem.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

coastliner
Participant

@KeithFrench wrote:

The hub, in common with all current TalkTalk routers does not support modem mode. What I have told you is the only way this will work. Of course had you bought the modem/router version of your 3rd party router you wouldn't have this problem.

 


What you have told me is NOT the only way this will work. I have it working my way, as described earlier. I just want to also turn NAT off. A modem/router version of my router does not exist, so this was not an option.


@KeithFrench wrote:

 

The only other solution would be to buy your own router.


This is what I have done, bought my own router! I think you mean I should buy my own modem. This is an option. But it does not address my original question.

 

Just to be clear, I have a sagemcom fast 5364 TalkTalk hub with the new firmware issued a few weeks ago. There is a toggle switch to turn off NAT. When this switch is toggled to "off" it says there is a problem and it reverts back to "on".

 

So my question is (regardless of my setup or reasons why I want to turn this off) How can this be turned off? Is there another setting that needs to be adjusted before it will let me turn NAT off?

 

If the TalkTalk reps could pass my question on to their tech department or firmware development department I would be most grateful. @OCE_Debbie 

 

KeithFrench
Community Star

Yes I did mean buy your own modem, but the forum was playing up yesterday & I could not get back in to edit it.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Community Team

Hi coastliner,

 

I can make a change to your router firmware, not sure if this will resolve the issue but we can give it a try. Do you want to give it a go?

Chris

coastliner
Participant

Hi Chris

 

Worth a try!

 

Just for info I did have a firmware update quite recently.

 

Will a firmware update reset the router back to factory settings? 

 

Community Team

Hi coastliner,

 

It shouldn't change all settings back to factory default but if you've changed any settings you may need to change them again

 

I can't communicate with your router at the moment so could you switch it off for 30 minutes then switch back on and I'll have another try


Chris

coastliner
Participant

Hi Chris

 

I have factory reset the router and then turned it off for at least 30 minutes. 

 

Hopefuly this helps.@OCE_Chris 

 

 

Community Team

OK thanks. I can't update your firmware at the moment due to an issue at our end but I'll have a go later


Chris

Community Team

Hi coastliner,

 

I'm really sorry, still unable to update your firmware due to an issue at our end, I'll try again on Monday.

Chris

Community Team

Hi coastliner,

 

I've just started the firmware update, can you check in 5 minutes to make sure it's gone through OK

Thanks
Chris

coastliner
Participant

Hi Chris

 

I'm currently not at home. I will check tonight.

 

coastliner
Participant

Hi Chris

 

It looks like the firmware has been updated. But NAT still doesn't turn off.

Community Team

OK, sorry it hasn't worked. I've asked our product team if they can help, I'll let you know when I have an update

 

Chris