cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Low router throughput, high CPU occupancy...

Reply
25 REPLIES 25
Highlighted
Popular Poster

Our (new) DG8041W router is running at 60%-90% CPU load with resultant low internet throughput even though there is very good broadband speed (38Mbit/s down, 8Mbit/s up).  Some devices cannot get internet at all and the service is seriously degraded.

 

This is a new router and I have done a factory reset etc to no good effect.

 

When a single devices is connected the internet speed is excellent.

 

I believe that there is a systemic weakness in this router - is this a problem generally?

 

Ian

Highlighted
Community Star

No. I currently have 15 wireless and 1 wired device connected, CPU usage at 5% (from router interface), everything running smoothly.

 

 

Highlighted
Popular Poster

Thats interesting - thanks for the response.

 

I'm of the view that my router is faulty then because the bandwidth being used now is minimal (ie no streaming being done etc) yet it took 10 minutes to re-present this page in order to see your reply!

 

CPU running now at 80%, memory at 20%.  I have changed nothing following the factory reset except the WiFi SSID and password.  We can run up to 35 devices but now only 14 are connected although the router takes several minutes and only reports 4 presently.

 

Ian

Highlighted
Community Star

You may well have a faulty device. Make sure that your personal details including TalkTalk landline number are complete on your community profile (click here) so that the support team can link your forum identity with your account and then wait for them to respond. They should be able to arrange a swap out for testing. Do bear in mind though that they will not be back online until Monday. 

 

 

Highlighted
Popular Poster

Thanks for that suggestion - done that (would not otherwise have bothered).

 

I have a call open with the helpdesk but the best that they could do earlier was to suggest that I call back "in two of three hours" which means I will be calling them in about 15 minutes.  I am not optimistic that the helpdesk will not ask me loads of inane questions but clearly router CPU occupancy should NOT be so high.

 

Something has gone wrong with it because when we first had it the performance was very good.  Not as good as my business mikrotik but there you go.  If I could put it into dumb mode (and trust it) I would just stick a mikrotik on and expect that to stay up for 9-12 months.

 

Perhaps it got hit by a cosmic ray?

 

Ian

Highlighted
Community Star

I cannot see the indicator to show that you have updated your details?

Highlighted
Popular Poster

Pretty sure that I have done so.

 

The second call was not very satisfactory.  Apparently they have decided to perform a software update on their "tools" during the day, which is very strange for a telco, and so I have to web-chat tomorrow (sunday) or call on Monday.

 

Ian

Highlighted
Community Star

You have done now. Feel free to carry on contacting them directly, or wait until the team here pick this up which I suggest is the best way forward. 

Highlighted
Community Team - TT Staff

Hi Ian,

 

Would you like us to send a replacement router for testing purposes to rule this out?

 

Thanks

 

Highlighted
Popular Poster

Yes please.

 

Ian

Highlighted
Popular Poster

Do I have to do anything to get this to happen?

 

The router is now re-booting itself quite frequently when the user downloads individual files (250kb-3mb).

 

Ian

Highlighted
Community Star

Just wait until the support team respond again.

Highlighted
Community Team - TT Staff

Hi

 

Router on the way.

 

Thanks  

 

Karl. 

Check & Report l Our latest Blog l Set Your Preferences l Service Status l Help with your Service l Community Stars

Working From Home Tips


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


WEAR A MASK      -      WASH YOUR HANDS      -      SOCIAL DISTANCE

Highlighted
Popular Poster

Thank you Karl.

 

Let me know the best way to provide feedback etc.

 

Best regards,

 

Ian

Highlighted
Community Team - TT Staff

No Problem 🙂

 

Test when it arrives and just let us know here.

 

Karl 

Check & Report l Our latest Blog l Set Your Preferences l Service Status l Help with your Service l Community Stars

Working From Home Tips


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


WEAR A MASK      -      WASH YOUR HANDS      -      SOCIAL DISTANCE

Highlighted
Popular Poster

New router arrived at lunchtime.  Appears to be more responsive than the original and user devices are connected quickly and so far have not been thrown off (fixed or wired).  DHCP addresses are handed out within seconds rather than up to ten minutes.

 

Given that the previous router also appeared to be ok on arrival I propose a period of a couple of weeks bedding in to be sure - but this does appear to have a much more responsive user interface.  This router does not report CPU load or memory use but for that matter it doesn't give me reason to be concerned either.

 

Ian

Highlighted
Team Player
Out of curiosity, did you get the same Huawei router as a replacement?
Highlighted
Popular Poster

It looks the same but its a Sagem router.

 

So far an altogether better device.

 

Ian

Highlighted
Community Team - TT Staff

Hi Ian

 

Thanks for keeping us updated 🙂

 

This will be the Sagemcom WiFi Hub.

 

Thanks

 

Debbie

Highlighted
Popular Poster

We're taking the view that this replacement router (the Sagemcom) is working just fine and for some reason its predecessor is faulty or just not up to the job.

 

The new router has run faultlessly since its initial installation in stark contrast to the Huawei.

 

What do I need to do to to return the Huawei router?  I have the box etc but will need a postal address etc to return it.

 

Regards,

 

Ian

 

PS - someone might want to note that the telephone helpdesk were completely ineffective in dealing with this issue when I raised it with them (prior to posting here), not being able to get past the part of the script relating to WiFi performance (when even fixed connections were failing).