Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

New wi-fi hub doesnt work

First Timer

Just renewed my broadband with the fibre broadband offer - new hub arrived. Supposed to go live yesterday - up to midnight. Still the box is flashing amber? Plugged in my old router to another socket and that one is still working? When I type in the ip address I can only log in with my old router details and not the new? Tried "chat" several times over several hours to no avail. At a loss what to do … Do I just keep using my old hub? If so what was the point of the new? Any help appreciated before I cancel completely and try and get back to the old contract?

Community Star

I'm not sure what it is you are doing exactly, but if you have your old router plugged into another socket and that is working then have you tried the Hub at that socket? You can only have one router connected to your broadband service.

First Timer

Hi, thanks for the reply. Yeah I took the old router away completely to start and just tried the new one. I then moved the new one to another socket and still no luck - just always flashing amber. So this is when I decided to see if I get any wi-fi at all so I plugged the old one back in (to a new socket) and left the new one in the existing socket and hey presto the old one still works but still not the new. At least I have some wi-fi but only on the old router? Surely this can't be right though? I was expecting the old router to stop and the new one to start?

First Timer

I know I'm probably being really thick but why is the old router still working and the new one not? I thought the old would deactivate and the new activate on the go live date?

Community Star

OK, it could just be faulty. The quickest way to arrange an exchange would be to contact customer services directly and tell them it doesn’t work. If you have any problems with them then post again here.

First Timer

I've already reported the issue several times to several people and even emailed a complaint but I keep getting put round and round and circles and they seem unable to understand the problem unfortunately. There must be a problem in the activation by the sounds of it or the "switch" to the new hub. My Tv is now coming up with an error saying it cant connect to the internet.

Community Star

There is no activation or switch process, it is just plug and play.


I am sorry that you haven’t been able to resolve this, the thing is that the support team here won’t be back online until next week and possibly later than normal because of the Bank Holiday. But I have flagged this up so that they will deal with this for yours soon as they can.


In the meantime I suggest you use your old router,

Community Team - TT Staff

Hi JoM85


I'm really sorry to hear this.


Can you please update your community profile to include your:

  • Name
  • Telephone number
  • Alternative contact number

We'll then look into this further. Please do not post this information on this thread Once you've updated your profile please post in your topic to confirm it's updated.