cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

New wifi hub lost power

Reply
14 REPLIES 14
bevann
Participant

Hi

 

I bought the wifi hub a couple of weeks ago as my previous router had started to misbehave.  I eventually had time to set it up on Fiday, and all was going well until 30 minutes ago.  The light from the front of the router is off and I've lost connection to the internet.  My phone line is fine, I've tried plugging the router into a different socket, etc  all to no avail. Both wired and wifi devices are affected.

 

So yeah, had a great internet connection for a whole 48 hours and now nothing.  I'm assuming this means I need another new hub.  Could this please be sorted asap?  I dread having to reconnect everything to yet another router but I'm paying for fibre so I'd at least like to be able to use it.

Community Team

Hi bevann

 

I'm really sorry to hear this.

 

Have you tried factory resetting the router using the pin hole reset for ten seconds?

 

If you are still experiencing this issue then I can send a replacement router for testing.

 

Thanks

 

Debbie

bevann
Participant

Hi Debbie

 

I've tried everything but there is no power going to the hub at all so nothing is working.  Could you please send a replacement wi-fi hub (not the standard router) asap?  All of my profile details are up to date.

 

kind regards

Bev

bevann
Participant
I forgot to add, could this be sent to my work address rather than my home address?
Community Team

Hi bevann

 

Please can you send me a Private Message with the address you would like the router sent to.

 

Thanks

 

Debbie

Community Team

Hi Bev

 

Thanks for the Private Message.

 

The replacement Wifi Hub is on its way, please allow 24-48hrs for this to arrive.

 

Let us know how the connection compares with this router.

 

Thanks

 

Debbie

bevann
Participant
Hi Debbie

I think a fuse had gone in the plug as the 'old' hub is now working fine with the new plug.

Thanks for your help.
Community Team

Hi Bev

 

That's great, thanks for keeping us updated 🙂

 

Debbie

Browno
First Timer

Hi I have the same problem. I've only had a few months. Brand new from talk talk. Ive rang them only to be told its an issue with my line and a technician need to come and look at my line. I know it's not my line. My phone work fine. I have not light on the hub. I'm even willing to send it back so I can get a replacement. But they having none of it. 

Community Team

Hi @Browno

 

I have posted on your thread.

 

Thanks

 

Debbie

WillC1
First Timer

I am experiencing the same issue within a month. The Sagem wifi hub has lost power and I am unable to switch it on. I have contacted the LiveChat team and the rep ordered me to buy a new router which I found unhelpful. I asked them whether I could get a replacement or whether the Wifi hub could be repaired.

WillC1
First Timer

I have a similar issue. The wifi hub suddenly lost power and I am unable to switch it back on. I have contacted the LiveChat team and had all kinds of comments from checking and testing the connections. I require a new replacement wifi hub as there is clearly an issue with the router.

Community Team

Hi WillC1,

 

If you need assistance can you please start your own thread and we'll be happy to help 🙂

Chris

almar_spug
Chatterbox

It seems that its a common issue for the past few months.

 

Yesterday an engineer installed the WIFI Hub on our place when I came home I checked the WIFI connection and I cant search and even tried connecting via a wired connection and unluckily still the same no connection.

 

Until I realised that there were no status light in the front of the HUB. I even tried to change the power source and still the same no status light or response.

 

I am so disappointed considering I waited for almost 2 weeks to get it installed and this thing happened.

 

It seems that there were issues on the power adapter and the HUB itself.

 

 

Almar
Community Team

Hi @almar_spug

 

Apologies for this.

 

Please let us know if this fault is still present with the replacement router.

 

Thanks

 

Debbie