cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

No Internet. DNS not connecting

Reply
15 REPLIES 15
Highlighted
Popular Poster

I am getting regular issues with suddenly not having internet. Wifi stays connected all the time websites just won't load.

Rebooting the router fixes it as does changing the DHCP server to google and then the next time switching back to obtain DNS automatically.

I think the reboot or switching settings is forcing a reconnection to the DNS but it still happens every day or so. It affects multiple devices laptop, phone etc so definitely router related I think.

 

I have TalkTalk Wi-Fi Hub
version SG4K10002816t

 

Highlighted
Whizz Kid

Hi @guyhh 

 

 

Have you turned the router off 30 mins? see if a new connection helps 

 

Also might be worth testing with a different set of DNS servers :

 

https://community.talktalk.co.uk/t5/Articles/Using-3rd-Party-DNS/ta-p/2205279 

 

Cloudflare, google, quad 9, etc. 

 

 

Highlighted
Community Team - TT Staff

Hi guyhh

 

I'm sorry to hear this.

 

Have you added the correct TalkTalk landline number to your Community Profile? (please do not post the number on this thread)

 

Thanks

 

Debbie

Highlighted
Popular Poster

Thank you.

Yes as I said changing the DNS server does reconnect and fix the problem but it does return and then switching dns servers back again reconects and fixes the problem the next time.

Highlighted
Popular Poster

Hi Debbie

I've updated my profile with the correct landline number. Thanks

Highlighted
Community Team - TT Staff

Hi guyhh

 

Thanks for updating your Community Profile.

 

I've completed a line test which hasn't detected any faults but I can see re connections on the line.

 

Would you like me to send a replacement router for testing?

 

Thanks

 

Debbie

Highlighted
Popular Poster

@OCE_Debbie Ok Thank you I am happy to try that 

 

Highlighted
Community Team - TT Staff

Hi guyhh

 

The replacement router is on its way, please allow 24-48hrs for this to arrive.

 

Let us know how the connection compares with this router.

 

Thanks

 

Debbie

Highlighted
Popular Poster

 

Only got round to setting up the new router yesterday due to work and not having noticed the problem till the day before so was holding off.

 

One day after router change the same issue today. Again changing the DNS server reconnected straight away.

Highlighted
Community Team - TT Staff

Hi guyhh,

 

I'm really sorry to hear this. Can I just confirm, is the replacement router the same make and model as the previous router?

 

Thanks

 

Highlighted
Popular Poster
Yes same router
Highlighted
Community Team - TT Staff

Hi guyhh,

 

Thanks for confirming. Would you like us to send a different make and model of router for testing purposes to rule this out?

 

Thanks

 

Highlighted
Popular Poster

Yes please. I do have a lot of devices and quite heavy use so as long as it can handle that. I had decided buying a different router might be the next thing to try so I'd appreciate that. Happy to return the routers I end up not using.

Highlighted
Community Team - TT Staff

Hi guyhh

 

The replacement router is on its way, please allow 24-48hrs for this to arrive.

 

Let us know how the connection compares with this router.

 

Thanks

 

Debbie

Highlighted
Popular Poster

The Huawei router doesn't seem to have the same problem. I've needed to reboot once due to a loss of WiFi but that seemed to be a one of and different issue.

No DNS server issues that I have noticed.

Thank you for your help. 

Highlighted
Community Team - TT Staff

Hi guyhh,

 

I'm glad to hear this. Just to confirm, has everything been ok since your last post?

 

Thanks