cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Not getting guaranteed broadband speed and missing posts!

Reply
81 REPLIES 81
Highlighted
Participant

This is the third time posting as previous posts have gone missing!. New customer, not receiving guaranteed fast fibre speed 57mbps only receiving 25.3 at best. Broadband is working no problem, just excessively slow. No downloading or gaming (kids have left home) only surfing, media and online shopping. Two iPads and two phones attached. Can someone please help?, thank you

Sebsan
Highlighted
Participant

New to talk talk 29 Jan 20. Purchased faster fibre with a 57mbps guaranteed. Only achieving 25.7 download and 16.1 upload. Despite trying to resolve via live chat (agent decided to cut the chat) and a telephone agent, despite rebooting suggested I call back another day. Problem remains the same. I know I have a 30 day grace period whereby I can leave without any penalty, I’d rather resolve this. To recap, the broadband works, it’s just painfully slow and no where near achieving the guaranteed minimum. We only have two iPads and two phones and our use is low, no downloading or gaming etc (kids have grown up and left). Despite this even the basic news surfing is pa8nfully slow. Can someone please help? Thanks in advance 

Sebsan
Highlighted
Popular Poster

I am having the same problem.  Was promised <73.6 > and <55.6 > Mbps with minimum guaranteed download speed is <50.6 > Mbps

 

But only getting 36.6.

 

Tech team has no idea.

 

I think there is something going on!

Highlighted
Community Star

@Sebsan your previous posts are all visible. As posting multiple times causes issues with threads being answered (Yours and other people waiting for a response, and can be considered spam under community guidelines), these will be moderated or moved.

 

Please note that responses are not in real time and answered in rotation, so please be patient.

 

@Ian771 as each person's problems are different could you please start your own thread. Thank you.

Please remember to mark Solved Posts with Best Answer. Doing so helps others and saves OCE's time to look at unsolved topics. Thanks, Steve.
Highlighted
Participant

Hi @fr8ys, thanks for the response. I totally understand but as you see from the title, my previous posts weren’t visible at all so I assumed them to be missing. They have since cropped up so apologies for any inconvenience. That said, can you please confirm that my issue is being investigated?, thanks so much

Sebsan
Highlighted
Community Team - TT Staff

Hi Sebsan

 

I'm really sorry to hear this.

 

I've completed a line test which hasn't detected any faults and your line is in sync at 74.5mb.

 

Please can you power down your router for a full 30 minutes and then run a speed test following this?

 

Thanks

 

Debbie

Highlighted
Participant

Hi Debbie

 

will do. Thanks for the information but we’re getting no where near that speed on every speed test. Will do as you suggest and then revert to you. We’ll run the talk talk speed test on every device (2x iPad and 2x mobiles)

many thx again

Sebsan

Sebsan
Highlighted
Community Team - TT Staff

Hi Sebsan

 

Thanks for your reply.

 

Please let us know how the speed compares following the 30 minute power down of the router.

 

Debbie

Highlighted
Participant

Hi Debbie

 

these are the results after powering down the hub for 30 mins. Only the actual device was linked to the hub, all other devices were turned off at the time of each test. All tested via the talk talk.help speed test

 

Lenovo P2 Android- 48.4 Download/18.7 Upload 

 

ipad 1- 27.4 download/ 15.4 upload

 

ipad 2- 28.7 download/ 17.2 upload

 

iphone 6- 26.7 download/18.3 upload

 

no applications were open/running on any of these devices and all other devices (smart tv etc) were WiFi disabled. 

 

Appreciate your help with this 

many thanks

Sebsan

 

Sebsan
Highlighted
Community Team - TT Staff

Hi Sebsan

 

Thank you for trying the 30 minutes power down of the router.

 

I think we should send a replacement router for testing, would you like me to arrange this?

 

Thanks

 

Debbie

Highlighted
Participant

Hi Debbie

 

if you think this will help, then yes please

many thanks for all your help

regards

Sebsan

Sebsan
Highlighted
Community Team - TT Staff

Hi Sebsan

 

The replacement router is on its way, please allow 24-48hrs for this to arrive.

 

Please let us know how the speed compares with this router.

 

Thanks

 

Debbie

Highlighted
Participant

Hi Debbie

 

We’ve received the new hub. Before we install it, is there anything that you require us to do?

 

many thx

Sebsan

Sebsan
Highlighted
Popular Poster

a prayer might help you

Highlighted
Community Team - TT Staff

Hi Sebsan,

 

Thanks for the update. No, just connect the replacement router with the new cables and monitor the speeds over the next 24-48hrs to see how the it compares. Please let us know how you get on 🙂

 

Thanks

 

Highlighted
Participant

Will do. It's got to be better surely as it's taken 30 mins just to get to this page!. I'll let you know how we get on

 

Many thanks again for your help

Sebsan

Sebsan
Highlighted
Community Team - TT Staff

Hi Sebsan,

 

Sorry to hear this and please let us know how the connection and performance compares.

 

Thanks

 

Highlighted
Participant

Hi Debbie

New hub installed. So far 45mins of blinking amber only, no sign of any white light as if yet

Regards

Sebsan

 

Sebsan
Highlighted
Community Team - TT Staff

Hi Sebsan,

 

I'll take a look now. I've run a test on the line which hasn't detected a fault and it currently looks like it has connected. Has it now connected since your last post a few minutes ago?

 

Thanks

 

Highlighted
Participant

Hi Debbie

 

Switched it off and reconnected all the wires and it's now working. Initial speed tests vary wildly on the same device. Perhaps we should let it settle 24/48 hours and then conduct speed tests.

Many thanks again for your help

Regards

Sebsan

Sebsan