cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Port forwarding for a game online.

Reply
18 REPLIES 18
Malcolm1944
Popular Poster

TalkTalk Wi-Fi Hub (Sagemcom FAST 5364) is refusing to open some ports for an online hosted game after following the user manual on port forwarding. Have tried it on 2 computers and both the same. Checked online to see if those ports are open but they are all closed. Is this a problem with this model?. Previous router was perfect in port forwarding. Even turned of pc firewall, still no luck.

KeithFrench
Community Star

Which way does the connection get established, from the internet to a games server on your PC, or from your PC to a game server on the internet?

 

Which TCP or UDP ports do you need to forward & I will test them out for you?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Malcolm1944
Popular Poster

Hi, the game is a dedicated server for a game called line of sight vietnam. The ports are all UDP.

From the internet to a games server on the PC

60001 UDP
60002 UDP
60003 UDP
13242 UDP
50000 UDP
50001 UDP

My other PC used to join the game on Virginmedia and other routers with people from all over the world at different times, many thanks if you could get this to work.

KeithFrench
Community Star

So the game server is on your PC.

 

No online port checkers are compatible with UDP ports as they work in a totally different way to TCP. Please can you get me a screenshot of the port forwarding config used on the router, so as I can check this? You will also need an inbound rule added to the PC's firewall for this to work. Never, ever, disable your PC firewall (although I appreciate this was done purely for testing purposes).

 

How are you testing this, by trying to connect from a device out on the internet, or from a local device using the router's public (WAN) IP address as the destination address? If the latter, going out from the router to the internet & back in again is classed as loopback traffic. All TalkTalk routers consider this a security risk & block it. If you want to connect locally to your game server, use its 192.168.1.X address.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Malcolm1944
Popular Poster

Firewall back on. I connect or try to connect using the external ip address 80.42.39.42 which is entered into the game which then joins the game, usually. Same with all people from all over who join the game in coop mode to play together. It's a first person shooter.

Havn't tried the local 192.168 etc'. But if it's only local i won't get anyone join. That is why it's UDP as it is with all the games made by Nfusion.

Should i change the router to get back to normal or is there a way through this so the router will accept UDP.

Malcolm1944
Popular Poster

Sorry, external ip address is 2.96.156.115. Changed since yesterday

ports.jpg

Highlighted
KeithFrench
Community Star

The router obviously accepts UDP in its port forwarding, it is just the port checking websites that are not compatible with UDP, that is all.

 

Once you have added this inbound rule to the firewall, if you then try to connect from a local device to the game server on your PC's 192.168.1.X address, does it connect OK?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Malcolm1944
Popular Poster

Hi, instead of entering the external ip address i tried what you said and entered the internal ip address of the game server and it joined the game and played normally. Did not get anyone else join as it's only local area network but we are half way there, just need for it to connect to the other ip address worldwide

Malcolm1944
Popular Poster

Internal ip worked. Altered ip number just to show example but it did work 🙂

internalip.jpg

KeithFrench
Community Star

That proves the PC's firewall is OK.

 

The port forwarding rules look OK assuming the ports are OK. Next you need to get someone to try it from elsewhere on the internet. Make sure that before you do this, your public IP address has not changed. You really need to consider using a DDNS domain.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Malcolm1944
Popular Poster

Well i have tried everything to get my game hosted from home but the router refuses to let me so all i can think is that TalkTalk are preventing me from hosting by blocking the router from allowing those ports to connect to my external ip address. I put the server in the DMZ and still it refuses to connect so it's not the ports as in the DMZ there are no ports, just like placing the server on the other side of a wall. no need for ports out there. Never happened on any other service provider so they must think i am running some kind of business so they block any kind of home server.

Spoke online about this but they simply referred me back on here and said they are not blocking any ports but never said they are not blocking any servers.

Pointless buying another modem/router if they can simply block my server.

Port 80 opens fine so it's just my server blocked.

List my internal ip address and it works fine because it is only joining my home network.

KeithFrench
Community Star

Are the ports correct & exactly how are you testing this?

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

KeithFrench
Community Star

Hi @Malcolm1944 

 

I have just tested all of your UDP ports from the internet to my PC via my Wi-Fi hub & they all worked first time. The only difference is that I condensed the port forwarding on the hub to just 3 rules by using port ranges:-

 

UDP Port range PF rules.png

 

This proves there is nothing wrong with the TalkTalk network or the Wi-Fi hub.

 

Please confirm as per my previous post that these are the correct ports and the exact method of testing them that you are employing.

 

Thanks.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Malcolm1944
Popular Poster

After a lot of research it seems this hub has NAT disabled to prevent Loop Back as they consider it a security risk. If you have a home server or serve from home for a game or cameras, or a presentation served from home you will never be able to see it but those outside from the internet can. I have looked inside the router to see if i could find the NAT settings and it is disabled. Even if it was not disabled it would have to be open, not medium or off.

Primary DNS Server 79.79.79.79
SecondaryDNSServer 79.79.79.80
ipVersion IPv4/IPv6
NAT DISABLED

So i am stuck and it seems so are hundreds of others who wish to run a game server from home and to be in the game themselves. Tried what you said about the port forwarding and i can only join the game using the internal ip address, not the external one as loop back is turned off inside the router.

No way to enable NAT, it's built into the firmware.

KeithFrench
Community Star

I did tell you about the loopback traffic block, but that does not stop this from working. If you read my previous post earlier this afternoon, I have tested all of your UDP ports from the internet, via the TalkTalk network, through my WiFi hub with the port forwarding rules I included in the post, to my PC. All worked perfectly.

 

I have asked twice before for you to double check the ports required & confirm your exact testing methods, without reply.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Malcolm1944
Popular Poster

I have been to a site which shows my server on or off and it is nowhere to be seen. I can as i said play the game using the internal ip address but that means i am on my own so no point. NAT is disabled on this router and cannot be turned on unless i get another router which has loop back and NAT fully open.

This screen shot is from a site which shows my server on or off and it is not there so it's off.

losv.jpg

KeithFrench
Community Star

On the PC hosting this game, please go to the command prompt & enter:-

 

ipconfig /all

 

Then please copy & paste the results into this thread.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Malcolm1944
Popular Poster

C:\Documents and Settings\server>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : server
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : lan

Ethernet adapter Local Area Connection 2:

Connection-specific DNS Suffix . : lan
Description . . . . . . . . . . . : NVIDIA nForce 10/100 Mbps Ethernet
Physical Address. . . . . . . . . : 00-1F-E2-04-50-10
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.1.50
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.1
Lease Obtained. . . . . . . . . . : 04 August 2019 09:44:52
Lease Expires . . . . . . . . . . : 05 August 2019 09:44:52

KeithFrench
Community Star

Is this IP address manually configured on the PC or obtained via DHCP (that includes a DHCP Reserved one)?

 

You may well have problems with UDP if trying to access from a phone using mobile data. This is because unlike TCP, UDP has no knowledge of sessions, it just sends a packet & doesn't care if it reaches the other end. With mobile data there is a router somewhat similar to your ISP router within the cell mast. You would need to add port forwarding to that mast router for the direction of your game server to the phone. You obviously have no access to that router, so it will fail every time. You will need to use a device with a true internet connection or another broadband with the relevant port forwarding added, for it to work both ways.

 

EDIT: however, that port would be dynamically allocated, making port forwarding on that router impractical. They might be able to use uPnP, but that has security vulnerabilities associated with it. Whilst I have no idea how your game works, from a networking perspective, are you sure that there is not a TCP session involved as well?

 

You seem to have a misunderstanding of what NAT is (Network Address Translation), which translates between the router's public address & your device's private 192.168.1.X address. This is the same as port forwarding. 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they?