Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Re: Sagemcom 5364 DHCP range & DNS handling seems bit messy, was it same in old firmware?

Whizz Kid

I think my firmware might have automatically updated recently (it's version SG4K10002600t now), possibly as part of upgrading to fibre, and I can't alter the DHCP range I set when the Sagecom was new for a trial a few years ago.

Also, worse, the DHCP client devices don't appear to be being sent any DNS info so phones & tablets wifi only work if they have static DNS set on them individually.

Also, the Advanced->Wifi Hub->DNS on/off won't change, is greyed out stuck as OFF with the & ...80 greyed - although the Device Info shows a static value of & that I  set in Advanced->Internet Connectivity.

How is this area supposed to work?

Whizz Kid

Ok, have got DNS working by setting the IPv4 DNS option to 'Obtain DNS Address Automatically' (not 'Manually specify DNS') in Advanced->Internet Connectivity.


With it as '...Automatically', it seems the connecting DHCP clients DO get sent DNS info, and you can choose (as you would expect) to use either the default DNS the router gets from TT (79.79,.79.79 & ...80) or your own as set in Advanced->wifi hub->DNS - which now DOES allow switching static DNS between ON & OFF.

Still can't change DHCP range though.


Presumably I must have inadvertently tried changing to 'Manually specify DNS' in the IPv4 DNS place as part of trying to get the internet working at all after the change to fibre, when only the change actually required was Addressing Type, from blank to DHCP, on that same page.

So that begs a question: what is the 'Manually specify DNS' option on that page for (perhaps for 'STATIC addressing type' of internet connection??).

Team Player

I am having a similar problem.

Phones will not obtain IP address by DHCP they will only connect if I set an address as a DHCP reservation.

All was ok untill last night.

Community Team - TT Staff

Hi andywil,


I'm sorry to hear this. Please can you create your own thread and we can look into this further for you.




Whizz Kid

re andywil's comment - in my case the phones etc WERE being given an IP address from the (unalterable!) DHCP range, but not being given any DNS info unless the DNS setting in
Advanced->Internet ConnectivityIPv4
is 'Obtain DNS Address Automatically' (not 'Manually specify DNS').

To clarify: with the 'Automatically' setting above, the phone gets TT's DNS ( & 80) if the following is set to OFF...
Advanced->wifi hub->DNS

(actually on mine since it's not at
(i.e. the gui page with title 'Static DNS Server configuration' and an Enable option) 

..or the phone gets your own values, for google or for the new one or whatever, if static DNS Enable is set to ON.

Whizz Kid

To repeat the bug fix request: how do we change the DHCP range?

It must have worked when I first got the Sagemcom for its trial, but now if I change it, click Apply, leave that gui page and return to it, the range shows as what it was before I changed it, meaning the alteration & Apply was ineffective.

Community Team - TT Staff

Hi bawdrip,


The issue with the DHCP start/end pool address has been fixed in the latest firmware version that's currently being tested, this should be ready for roll out soon, apologies for any inconvenience