cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Renewed the connection - have we got the right router?

Reply
24 REPLIES 24
Highlighted
Team Player

We upgraded to the 73Mbps service but there have been problems with the boost! We're getting around 37Mbps. The product is faster broadband with a boost.

 

We've got a fault being investigated around adding the boost and have been checking the Service Status. On the 'Your Router' section it says we have a Huawei-HG633 but it's a D-Link DSL-3782 with a firmware version from 2018.

 

Is this the correct router and, if so, when will the router be updated in the 'Your Router' section and does it have the correct firmware?

Highlighted
Community Star

Hi,

 

Have you tried rebooting the router?

 

If that does not work yet a pin reset using the hole in the back of it. I found I had to do this before the boost registered for me.

 

Be aware though that if you have changed your broadband name or password, these will revert to the original router values, and you will need to change them again.

 

You are in the staff's queue for a response though, so an OCE will check your router query


For a quicker reply can you please ensure you have your personal information up to date in your profile. Link here - https://community.talktalk.co.uk/t5/user/myprofilepage/tab/personal-profile:personal-info
If you are unsure of your phone number, you can find this in My Account or dial 17070 from your landline phone and this will confirm the number for you.
Thank you

Please remember to mark Solved Posts with Best Answer. Doing so helps others and saves OCE's time to look at unsolved topics. Thanks, Steve.
Highlighted
Team Player

Thank you - we'll give it a go and see what happens. Watch this space...

Highlighted
Team Player

Alas, that didn't work. We'll see if the tech team can sort the boost and it's good to be in the queue for answers about the router and firmware.

Highlighted
Community Team - TT Staff

Hi annRyan,

 

Sorry for the delay. I've checked and the router currently has the latest version of firmware. Does the boost show as active in your MyAccount?

 

Thanks

 

Highlighted
Team Player

Thank you so much Michelle, please don't apologise for the delay.  The info about the router was showing as correct first thing today. I jumped on and it's still showing 40Mbps as the max download speed.

 

I just tried logging onto My Account but I'm getting an error - 'Sorry due to technical issues we can’t log you in right now. Please try again later.'  I will check later. 

 

Highlighted
Team Player

The boost isn't showing on our account.  I know the Tech Support team were looking at this so fingers crossed it can be added and we can get the faster speeds.  There were issues adding the boost.

 

Highlighted
Community Team - TT Staff

Hi @annRyan

 

There is an error on the account which is stopping us adding the speed boost.  It has been logged to the team responsible for fixing these issues. 

 

If you post back next week, I can check on the progress of the fix.  

 

Sorry for any inconvenience caused 

Highlighted
Team Player

Thank you - we reported this on Tuesday and they said it would be between 3-5 days to resolve. We hope it can be resolved and we'd appreciate an update as soon as you know anything. Thank you for all your efforts.

Highlighted
Team Player

Whilst checking the service centre, we were prompted to run a line test. The results suggested there was a router issue and a new router was to be sent to us. Is this right? We only got a new router last week?  Also, what is the status of adding the boosts to our account? Thank you.

Highlighted
Community Team - TT Staff

Hi annRyan

 

I will run some line tests to see what is being detected. 

Highlighted
Team Player

Thank you Arne, appreciated.

 

Any news on our boosts being applied?

Highlighted
Community Team - TT Staff

Hi @annRyan

 

Line tests where clear, Im not sure how service center gets its information.  I'm guessing you have installed the new router, I think service center is still detecting the old router somehow.

 

Its still under investigation regarding the boosts, There is a known defect which is being looked into, so at this time its not possible. 

 

Sorry

Highlighted
Team Player
Thank you for the updates. We installed the router provided after the renewal of our contract last week. We ran the Service Centre network stability test and it's showing errors and advised it would send us another new router.

We're a little confused and very disappointed. We were looking to leave but the faster connection was the thing that kept us. We've been with TalkTalk for a very long time and the service has been brilliant. The thing that is letting us down is we were told we'd get the faster speed by adding the boosts and now it seems like it can't be done. Very disappointed and we've signed up for another 18 months. Can we escalate and possibly look at solutions or recompense for our issue?
Highlighted
Community Team - TT Staff

Hi annRyan

 

Its with with the development team at the moment, I dont know the technical reasons for the delay all I can ask is for your patience. 

 

When the boost is available I can look into a discount on it.

Highlighted
Team Player

Just checking. We still haven't got the boost and we're now outside our cooling-off period so are we stuck with this for 18 months?

 

Highlighted
Community Team - TT Staff

Hi annRyan

 

Just an update,  The problem is part of wider problem affecting some other customers that is being investigated. At this time we are still unable to add the boost. 

 

Apologies.

Highlighted
Team Player

Hi, Thank you for the update and for trying to resolve this. My issue was that the sales person said we'd get one speed, promised and confirmed this, but we aren't getting it. We only stayed for the faster speed which we aren't getting. The issue with this incident is that there is no proposed solution or end date to work to.  What steps are being taken or is this just bluster to placate those impacted?  I do appreciate that you are trying your best but if this is impacting many others, why isn't this being taken more seriously?

Highlighted
Community Team - TT Staff

Hi annRyan,

 

Unfortunately, this issue is still ongoing. Please be assured we're looking into this, however, we don't currently have an estimated time of fix.We should have an update due tomorrow. Please get back to us then as we'll advise further. 

 

Apologies for the inconvenience.

 

Thanks, 

Jo

Highlighted
Team Player

Hi Jo, 

 

What was the update on 19/08 as above?