cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Sacgecom router WiFi channel hopping broken

Reply
30 REPLIES 30
alecu
Team Player

The "AUTO" channel setting for the 2.4GHz band resets itself after a while (I suspect after the first channel hop occurs, as per the log).

 

The router's info is:

 

version.png

 

After setting the Channel to auto as below:

 

config_orig.png

all looks fine, and devices are able to connect for a while. After a couple of minutes this shows up in the logs:

 

 

logs.png

 

And now the configuration page looks like the channel has been manually set to 1:

 

config_after.png

 

I've done it a couple of times and it's easily reproducible, soon after setting it back to 'auto' it reverts to some random channel and stays there regardless of the channel's quality resulting in all the 802.1g equipment around the house not able to connect.

 

This makes the device unfit for purpuse as a WiFi router in residential areas. When can we expect a fix.

KeithFrench
Community Star

I can't say I have seen this before, however, you cannot rely on the System Log - that has bugs in it. I am currently testing & will get back to you.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

KeithFrench
Community Star

Hi @alecu 

 

You say this happens after only a couple of minutes. I have been testing so far for over 20 mins & although the channel has changed due to hopping, it still remains set to Auto. I have raised this with @OCE_Karl to check your line's configuration within TalkTalk's management system. Currently, he is checking this out for you.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

KeithFrench
Community Star

Mine is still on Auto after about 40 mins.

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Community Team

Hi alecu

 

Can you add your home phone number to your Community Profile so I can take a look at something from this side.

 

Thanks

 

Karl. 

alecu
Team Player

Keith - thanks for checknig. Is it the same FW Rev.? Just double-checking. I'm fairly sure this started happening a couple of weeks ago but unfortunately can't confirm whether there was an update or....

alecu
Team Player
Karl, updated. Let me know if you need any additional info from my side.
Community Team

Hi

 

Your router is on the correct firmware.  I can see some channel changes on the wifi side and some interference.

 

I'll work with @KeithFrench to look at this.

 

Thanks

 

Karl. 

KeithFrench
Community Star

Hi @alecu 

 

Yes, I am running the same f/w as you, V2600. Mine is still on Auto. @OCE_Karl & myself are discussing this.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

KeithFrench
Community Star

Hi @alecu 

 

Please can you retry it now?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
alecu
Team Player
Hi,

I'm not sure what's changed but it's stayed as configured since yesterday. Can you guys provide a bit more detail as to why you think the behaviour should now be different?

The other observation is that I haven't seen any channel hopping in the log since yesterday around 2pm. I see recent log entries for various other things so as far as I can tell the logging itself is fine.
KeithFrench
Community Star

I did say that you cannot rely on the system log,, there are numerous bugs in it. TalkTalk have made changes to your account to give you the control of your router that you want.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

alecu
Team Player
Hi @KeithFrench,

Can you please elaborate on what these changes to my account are? Are you saying that by default I can't control the WiFi channel selection?

Thanks,
Alec.
KeithFrench
Community Star

Hi @alecu 

 

You should have full control of the router's channel allocation since that work was done.

 

You will need to ask TalkTalk about the changes made to your line, I am just a customer, therefore I have no visibility of the line configuration.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

alecu
Team Player
@KeithFrench, thanks.

@OCE_Karl, could you perhaps shed some light into this matter please?
Community Team

Hi alecu

 

Optimisation has been turned off on your line temporarily while testing so that no remote changes are made to your wifi services such as promoting band switching between devices or optimising the channel based on interference patterns. 

 

Your wifi will remain on a channel that you set manually.

 

Thanks

 

Karl. 

alecu
Team Player
Hi Karl,

Thanks for the explanation.

I'm assuming we will be getting a heads up in the future when potentially disruptive remote changes are planned.

Regards,
Alec.
Community Team

Hi

 

The system is learning all the time and looking at the different devices that customers use, so over time this will improve.

 

Thanks

 

Karl. 

alecu
Team Player
Hi,

I'm sorry to have to report that the same issue has now re-appeared. Same symptoms as last time. Can you guys check at your end, it's like the chage that fixed this got reverted.

Thanks,
Alec.
Community Team

Hi Alec,

 

So just to confirm, is your wifi channel auto changing again?

Chris