cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Sagemcom 5364 wifi has slowed down with windows 10 laptop

ANSWERED
Reply
11 REPLIES 11
Highlighted
Team Player

In November 2019 I received a Sagemcom 5364 TalkTalk router after signing up for a new contract. 

 

Using the TalkTalk speed check initially my windows 10 laptop (with a 2.4 Ghz internal wifi) clocked 28.6 MB/s download speed.  However a week ago the wifi download speed was only 5.4MB/s.  Although wifi upload speed is higher at 9.4MB/s.

 

Rebooting PC and Router do not help - download speed on wifi will not go above 5.4MB/s.

 

However, if I plug in the old HG633 router I get between 20MB/s and 25MB/s on wifi.

 

I have tried two different external USB wifi dongles with 2.4GHz and 5Ghz and the windows 10 laptop will not go above 5.4MB/s download with the Sagemcom.

 

According to the admin pages on each router, the phone line is rate is around 39MB/s with the Sagemcom and 37MB/s with the HG633.  If I do a speed check over wired ethernet then I get around 35MB/s and so I conclude that there isn't a problem on the external line.

 

With my mobile phone (in the same location as the PC) I think I got a 35MB/s download wifi connection on 5GHz with the Sagemcom.  I also have an ancient laptop (ex Vista) now running Linux and this is connecting happily with around 25MB/s download speed from either the HG633 or the Sagemcom on 2.4 GHz.

 

The problem is not affected by distance to the router.

 

I welcome any ideas of what might be restricting the windows 10 laptop's wifi download speed to only 5.4MB/s with the Sagemcom.

Highlighted
Community Star

Slow speed, intermittent dropouts, breaks in the signal, or no signal on some or all devices, might be caused by Wi-Fi interference from other local networks, which can also lead to a permanent reduction in speed. No ISP can be responsible for your local environment, this is mainly a by-product of the popularity of Wi-Fi.

However, other factors should be investigated first. When this happens, what are the lights showing on the front of the router? Do you have any wired connections & if so, how do they perform?

The TalkTalk Wi-Fi Hub is a dual-band router & offers both the older 2.4GHz & the newer 5GHz Wi-Fi bands. The problem is these are two different networks (SSIDs), but they share the same name, so you can't tell which one you are connected to. Log into the router (http://192.168.1.1) and enter a username of "admin" and use the unique router password (see the label on the rear of the router at the top).

Go to:-
Dashboard > See Wi-Fi Settings > Manage Advanced Settings > Wi-Fi 5Ghz gear icon > Basic

Append "5G" to the end of the network name of the "SSID" field. Then click "Apply".


This will not fix your issues, but it will make it much easier to identify the band you are connected to. This way you will know which band is causing your problems.

Having said that, there is another approach which can be better, which is to use Band Steering. This will automatically move any 5G compatible device connected to the 2.4G band to the 5GHz band. To use this facility on the Wi-Fi Hub, leave both network names identical.



Generally speaking, the 2.4GHz band suffers much more from interference than the 5GHz band, but the 2.4GHz one can sometimes have a better range, but this all depends on your local area.

You may then wonder what was really the point of this if it won't solve the problem? This is because the whole topic is too complex to be dealt with in one post. The next stage involves sending out a guide to you to help you get me some important diagnostic results, so as I can analyse them for you and recommend changes to your router configuration to solve them.

I only send this out to people who request it.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Team Player

Keith,

 

Thanks for prompt response and sorry it's taken me two days to get back to you.

 

Thanks, yes, please send through the guide and I'll get some diagnostic data.

 

I have already split the names to 2.4GHz and 5GHz and the problem affects both frequencies.

 

A wi-fi scanner suggests that the channels used by neighbours is not the issue.

 

An ethernet to wi-fi adapter (usually plugged in the back of the TV) receives the wi-fi OK - but the Windows 10 PC recognised this device as a wired connection and not wi-fi.

 

Bitdefender suggested the problem could be the firewall, but turning it off didn't help.

 

There has to be explanation to the slow wi-fi, and hopefully with that a solution!

 

Thanks, Pete

Highlighted
Community Star

Please see my attached guide on Wi-Fi interference & initially look at the section called "Are you suffering from interference – prove it first". This section includes full details of Wi-Fi analysers that I recommend for Windows, Windows phone, Android and Apple operating systems. However, I have no way of testing the Apple product. Do not worry about interpreting the results, I will do that for you.

Please post the screenshots that I have requested in my guide (no photos please they can be difficult to read as text can get out of focus when zoomed), from the analyser you are using (also in my attached guide). Please ensure that the analyser window is maximised (if Windows) before taking the screenshots & upload them via the "Insert Photos" button on the post editor's toolbar as large images. If they are too small, I will not be able to read them & although I can enlarge them, this just puts the text out of focus. If you prefer PM them to me. If you do PM me, then please add a link in there to this thread, so as I can find it easily.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Team Player

Screenshots from both phone and the PC in the same location - hopefully in the required format. 

 

This is using the Sagemcom 5364 Router and the PC is connected by a USB TP-Link Archer T2U Nano wireless adapter.  The PC does have an internal wireless that is only 2.4GHz capable, whereas the T2U works on both 2.4GHz and 5GHz.  I tried the Acrylic tool with the PC's internal wireless and didn't notice anything that appeared significantly different, but haven't taken screenshots for this.  The poor wi-fi speed affects the PC using either of the wi-fi options (in Network connections I disable the one that is not in use).  I recently bought the T2U in the hope that the issue was related to the internal wireless card, posts on the internet suggested this might fix the problem - and it didn't!

 

I can re-run the screenshots with HG633 if it would be useful.  Thanks.

 

PC_5_AP.png

 

PC_5_Qual.png

 

PC_5_Stren.png

 

PC_24_AP.png

 

PC_24_Qual.png

 

PC_24_Stren.png

 

Phone_5_Channel.png

 

Phone_24_Channel.png

 

Phone_AP_List.png

 

Phone_Channel_Rating.png

 

Phone_Time_Graph.png

 

Highlighted
Community Star

The signal strength could possibly be improved, but other than that there is no actual interference, so perhaps router/PC placement might need to be considered.

 

This is the best router location, but obviously, this is not always practical & a compromise has to be reached.

 

The general rule is to keep it away from:-

 

  1. Cordless phone (DECT) base stations
  2. TVs
  3. Loudspeakers & any sub-woofers (including those used with a PC)
  4. Computer monitors
  5. Electrical appliances – they often transmit their own signals that can interfere with Wi-Fi signals.
  6. Bluetooth devices – they operate on the same Wi-Fi frequency as your broadband, which can cause signal problems.
  7. Mirrors – they actually reflect Wi-Fi signals, stopping them from passing through walls and reflecting them back into the room.
  8. Anything containing large amounts of water – things like fish tanks and boilers can absorb Wi-Fi signals like a sponge.
  9. Large metal objects – radiators, for instance, will have the same effect on your Wi-Fi as mirrors. If you have a tower PC case with an internal WiFi card, the metal of the case can block signals to & from the antennae if they are located behind the tower case.
  10. If you are using a USB Wi-Fi adapter, use a USB socket on the front of the PC, as there is more open space around it than at the rear. If a USB extension cable is used, try to ensure that it is fairly short, so as the power from the computer is not attenuated. Long extension cables can cause the adapter to not have enough power from the computer to work correctly.

 

As a very general rule, the signal travels best on the same floor as the router and to the floor below. It does not always propagate very well to a floor above the router. However, with more modern routers, if they have a higher specification, they may be able to get the signal upstairs OK, but your ability to receive it also depends on your device's network adapter being of a higher specification, as well as its age.



Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Team Player

Keith, many thanks for trying to help.

 

If I place the Sagemcom 5364 in a different location it makes no difference.  If I move the laptop next to the router (within 30cm) the signal strength improves, but the download throughput remains at 5.4MB/s and the upload at 9.4MB/s.

 

If I then use the HG633 router I'm immediately back to wif-fi speeds of around 25MB/s, as checked by the TalkTalk speed checker.

 

Whilst hiding inside from Storm Dennis I've tried numerous suggestions for Windows 10 problems like this:

 

  1. Uninstalled the built in wireless and let the computer reinstall it.
  2. Tried 3 different wi-fi connections (D-Link USB, TP-Link USB, Internal wi-fi) - all give the same result.
  3. Created a new local admin account on the PC.  That didn't change anything.
  4. Messed around with the PC's MTU size to see if a different size would improve the speed between the Sagemcom and the Computer - it did not change the speed.  (netsh interface ipv4 set subinterface “Local Area Connection” mtu=1458 store=persistent)
  5. Tried lots of other command line instructions:
    netsh int tcp set global autotuninglevel=disabled
    and
    netsh winsock reset - and press Enter.
    netsh int ip reset - and press Enter.
    ipconfig /release - and press Enter.
    ipconfig /renew - and press Enter.
    ipconfig /flushdns - and press Enter
    NETSH winsock reset catalog
    NETSH int ipv4 reset reset.log
    NETSH int ipv6 reset reset.log
    Hit Enter
    Exit the prompt then restart
  6. Investigated Bitdefender - I confirm that VPN is not set up.

Nothing makes any difference.

 

The phone and a Linux laptop all get >20MB/s speeds with the Sagemcom router on wi-fi.  I conclude that there is something about the actual comms between the Windows 10 laptop and the Sagemcom that is causing the problem - but not related to the strength of the signal.

 

When the Sagemcom first arrived I logged a >25MB/s wi-fi speed.

 

Initially it was on firmware SG4K10001400t, and has incremented through SG4K10002600t and now is on SG4K10002808t.  But I can't blame the firmware because last year I recorded a speed >19MB/s with SG4K10002808t.

 

The PC updates itself regularly, so could it be something in the PC?

 

As have had experience with Linux Mint, I decided to see if the Windows 10 laptop would boot into Linux Mint.  I successfully managed to get Linux to boot from USB (which was a challenge), and guess what... the wireless speeds are good.

 

With the Windows 10 laptop running Linux I got 33MB/s on 5GHz and 24MB/s on 2.4GHz.  With upload of 9.3MB/s on both.

 

This points to something in configuration/software of the Windows 10 laptop as being the problem, there  must be a setting/driver/software preventing the router and the laptop from communicating above 5.4MB/s. 

 

It's a Dell Inspiron 7537, running Windows 10 Home, Version 1909. 

 

I'm wondering if there is a registry value that needs tweaking?  Anyone got any ideas?

Highlighted
Team Player
Solution

I found the answer.

 

Apparently a standard driver/service in a Dell Inspiron is something called 'Smartbyte'.  Ironically it is meant to improve the internet experience by prioritising data flow and not make it worse!

 

It is known to cause wi-fi problems for some, see this link: https://www.dell.com/support/article/uk/en/ukdhs1/sln309274/troubleshooting-network-performance-issu...

 

In Control Panel, Programs and Features I discovered that I had an old version of this called 'Smartbyte Drivers  and Services'.  I think it dated from 2018, I didn't take a note of the version number.

 

On the Smartbyte website https://support.smartbytetechnology.com/ I found advice to uninstall it, reboot the computer, and then install the current version.  (The version I downloaded today is 2.5.731.)

 

I did this, then at the end of the driver/service installation it also attempted to install the Smartbyte App from the Microsoft Store, but I got a message to say that this App isn't compatible with my computer.

 

After several reboots I confirm that the TalkTalk speed checker is now showing >30MB/s to the laptop.

 

The Smartbyte software is running in the background and shows as a Process and Service in Task Manager.  It seems OK without the App being installed - so I won't worry about the App.

 

A search of the internet indicates that I'm not the first person to have a Dell wi-fi issue relating to this.  Some comments indicate that a Dell system will re-install this driver/service software if it is removed, so as the newly downloaded version of Smartbyte seems compatible with the Sagemcom I think it is best that I leave it installed.

 

Why the old Smartbyte software had a problem communicating with the Sagemcom 5364 and was OK with the HG633 is a mystery - just happy that it's solved now.

 

Hopefully this post helps someone else with the same problem.

 

Community Star

Glad you got it sorted, but I would have agreed with you that it could have been a hardware problem on the hub.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Popular Poster
That WiFi intereference document seriously needs a TL:DR version. It's more of a college education to the wifi standards than a simple list of things to change to find the best channel etc. (That's all I read in it, just to see your opinion on channel selection, which is barely a consideration in a home environment)
Something like a Flowchart would be better for most customers. "change channel", "transfer a large file between other devices on the network" is usually the most you need to do to find the offending machine.
Highlighted
Community Star

Hi @mysophobe 

 

It is a complex subject covering numerous analysers & most TalkTalk routers. I have only ever had one complaint about it. Sorry you didn't like it.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Popular Poster
Now, I didn't say i didn't like it.