cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Samba Server File Sharing DSL 3782 How To

Reply
13 REPLIES 13
OnlyOneBrownie
First Timer

Hi All,

 

Thought I'd write this up incase any of you guys are having difficulty with viewing your files connected to the USB port of your TalkTalk DSL 3782, like I did.

 

Apologies first if this has already been produced, however I have failed to find a working description.

 

I have a MS Windows 10 laptop and this is how I did it 🙂

 

Click on File Explorer

Click on This PC (the one you are using)

Click Computer near the top (next to file)

Click Add a Network location

Click Next

Ensure Custom network location is selected and click next

Then type "\\192.168.1.1\USB" without the quote marks. To find the name of your USB drive login to your router, click USB and then settings - its the NET BIOS name (USB)

Click enter

This now gives you an option to rename your USB if you wish

Click enter

Click Finish and (fingers crossed I havent missed a step) hey presto - network location added.

 

The network location is now viewable in File Explorer. From here you can create a shortcut (like I have) to appear on your desktop for ease.

 

I hope you found this useful

 

Regards

 

Paul

Community Team

Hi Paul,

 

Welcome to the Community and thanks for the information 🙂

Chris

Highlighted
DeepFatFry
First Timer
Hi Paul
Thanks so much for the info. I've been struggling to get this to work and think I might be missing something.
 
I'm also on Win10 with the DSL-3782. I followed your steps but when I enter "\\192.168.1.1\USB", either as a Custom Nework Location or by mapping a network drive, I'm asked for login credentials. I assumed these would be the admin login for the router, but I get a "The specified network password is not correct" message (pdf of screen grab attached), even though I can log into the router with the same user name and password just fine.
 
Anyone got any ideas?
 
Thanks ever so much, Dave
DeepFatFry
First Timer

...just found te solution - I tried the default admin password printed on the back of the router and this worked. Anyone know if there's a way to change this from the default, as with the router login? I can't see anything under the USB or Samba settings.

 

Thanks

 

Dave

alicephilippa
First Timer
The only way is to use the telnet interface. However it's best just to run with the default password as there is less chance of *@#][!![]'#[@#]!* anything up.
MartynTTHome
Team Player

Annotation 2019-05-02 204054.png

 

Im getting this error when trying to map the drive. 

Sneaker74
First Timer

Hi, 

I'm having the same issue as the last post, windows basically saying the file transfer /share protocol is blocked due to security. 

 

Any one got an update? 

 

My router is running version v1. 10t

 

Cheers

viewer625
Conversation Starter

If you are on W10 SMB1 can be reinstalled there is much about this on tech forums on the net

Community Team

Hi

 

How are you getting on, has viewer625's advice helped?


Chris

MartynTTHome
Team Player

Not installing as it's got know dackdoors to ransomeware and other spyware. That's why it's been superseded by the newer version. 

Ed_Fry
First Timer

When I do this, I get a dialog box saying: "The folder that you entered does not appear to be valid. Please choose another"

 

I'm using \\192.168.1.1\  and the NET BIOS name I can see when logged into the router admin page.

MartynTTHome
Team Player
Any update on this. Please
Sneaker74
First Timer
MartynTTHome
Team Player

For security reasons, Microsoft recommends that you disable SMB1 immediately. Ransomware targets the vulnerabilities of the SMB service of the Windows operating system to propagate. To defend yourself against WannaCrypt ransomware it is imperative that you disable SMB1 as well as install the patches released by Microsoft.