cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Slow Download Speeds (Fibre Plan)

Reply
15 REPLIES 15
sharpinf
Team Player

Hello,

 

Over the past few weeks I've been noticing reducing speeds over my internet particularly over the evenings.

 

I have tried the online troubleshooter and checking cables are connected securely but that doesn't seem to have resolved the issue, though the speed tester did confirm the detection of slow download speeds of <1mb (upload not affected) despite the speed into the router being good (screenshot attached).

 

The speed test was run from a PC with wired connection to the router and without other content heavy things running at the same time.

 

Rebooting the router tends to improve it for a few hours, and turning it off for an hour as suggested in other posts improved it for the next day or so but the speed keeps slowing back down. 

 

The landline quality seems fine so I'm leaning towards it being a router issue, but would appreciate any help - thanks

OCE_Michelle
Community Team - TT Staff

Hi sharpinf,

 

I'm sorry to hear this and I will take a look now. I've run a test on the line which hasn't detected a fault and the connection stats look consistent. Would it be possible to run some wired speed tests using the TalkTalk Speed Tester when your speeds are good and also some more when the speeds drop and we can then pass this straight over to our Network Team for further investigation.

 

Thanks

 

sharpinf
Team Player

Thanks Michelle.

 

I have tried the speed tester after rebooting the router this morning which has given a 43mb download and 13mb upload which I'm happy with.

 

I will update this thread if this evening the speed has reduced back down which often seems to happen around 5/6pm.

 

Thanks

Tanyclochdy
Repeat Guest

I have exactly the same problem! When first installed everything working fine but since a few weeks the speed drops dramatically. I work from home and this is giving me a lot of problems, it is also the reason I notice the speed drop immediately. Connection to the house is fine, but after a few hours the connection in the house drops to the point I have to re boot the router, now twice a day to be able to continue work.

I would think this is a hardware or router software problem, is there any solution to the problem?

OCE_Karl
Community Team - TT Staff

Hi sharpinf

 

If the speeds reduce in the evening, after you run the speed test, can you also run a speed test at Sam Knows Speed Test and compare the results.  It is always good practice to use a different speed test also, just to check the speed tester itself is giving similar results.

 

Thanks  

 

Karl. 

Check & Report l Our latest Blog l Set Your Preferences l Service Status l Help with your Service l Community Stars

Working From Home Tips


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


WEAR A MASK      -      WASH YOUR HANDS      -      SOCIAL DISTANCE

OCE_Karl
Community Team - TT Staff

Hi @Tanyclochdy

 

If you start your own thread (new message), wed love to help.

 

Weve found that posting in someone elses conversation makes it harder to follow when looking for an answer.

 

Its easier and quicker if we can chat with you in a single thread, if you start your own thread, that will keep our community organised and help others with a similar problem.

 

Check your home phone number or account number are also added to your Community Profile as that will really help us to find your details quicker.

 

Thanks

Karl

 

 

Check & Report l Our latest Blog l Set Your Preferences l Service Status l Help with your Service l Community Stars

Working From Home Tips


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


WEAR A MASK      -      WASH YOUR HANDS      -      SOCIAL DISTANCE

sharpinf
Team Player

Hi Michelle ( @OCE_Michelle ) As an update since my previous post the speed generally seemed fine for the couple of days after a router reboot, though from this Sunday (11 April) afternoon it appears to have slowed right back down again back to the same approx. 1mb/s download speed. Both tests I attach were done at 21:00 on 11/04 as before on a wired connection with no other windows open and nothing being done on the wirelessly connected devices.

 

@OCE_Karl - thank you for the recommendation I had not heard of that website. Trying that it seems relatively consistent to the TalkTalk speed checker giving 0.96mb/s download and a normal upload speed. I also tried a different browser as well (MS Edge compared to Google Chrome) and no real change there.

 

Thank you

OCE_Debbie
Community Team - TT Staff

Hi sharpinf

 

Was the speed still ok in the evening following the router reboot?

sharpinf
Team Player

Morning Debbie ( @OCE_Debbie )

 

Apologies I deliberately didn't reboot the router that evening just in case that would make it easier for you to diagnose anything on your end. 

 

As an example running some tests today (9:30am 13/04) - download speed before reboot 6mb/s - after reboot 43mb/s. Tests done within about 5mins of each other immediately before/after reboot. Router page said it had had an uptime of around 4 days before that.

 

Thanks 

OCE_Debbie
Community Team - TT Staff

Hi sharpinf

 

Would you like me to send a different router for testing to see how the connection compares?

 

Thanks

 

Debbie

sharpinf
Team Player

Hi Debbie, Thank you that would be ideal please.

OCE_Debbie
Community Team - TT Staff

Hi sharpinf

 

The router is on its way, please allow 24-48hrs for this to arrive.

 

Let us know how the connection compares with this router.

 

Thanks

 

Debbie 🙂

sharpinf
Team Player

Hi Debbie, Thank you much appreciated I will test and update the post after using it for a bit to see.

OCE_Michelle
Community Team - TT Staff

Hi sharpinf,

 

Great, thank you 🙂

 

Thanks

 

sharpinf
Team Player

As a final update pleased to say that since new router has been up and running internet has been reliable and a good speed even during weekday evenings with rest of the setup identical to before.

Have noticed that streaming/YouTube on automatic quality has gone from 240p in the evenings to 1080p 😄

 

Thank you and will send back the old router in the package you provided  

OCE_Debbie
Community Team - TT Staff

Hi sharpinf

 

That's great news, thanks for keeping us updated 🙂

 

Debbie