cancel
Showing results for 
Search instead for 
Did you mean: 
Need help?

Want to know how to get the most out of our community?

Hey, I'm Michelle and I wanted to tell you about our community and how it's packed full of useful information, answers and has a horde of active members waiting to help or just to say hey! We know forums can be a little daunting at times, so here are some of my useful tips to help you get the most out of the community:

Get Searching

Search is the quickest way to locate the information you're after, use the big red box above. If you don't find what you're after you can always post your own question.

Search now

Get stuck in

Prefer to jump straight into the community? Checkout the yellow "browse" tab over on the left hand side, here you'll find the entire community at your fingertips.

Try now

Join the party!

Had a peek around the community already? If so you'll no doubt want to join us, just hit register below and follow the instructions. Don't worry I'll still be here to help once you've registered.

Register now

Slow broadband speed and caller ID not working

Reply
10 REPLIES
Highlighted
Matt123
Sightseer

Hi

I switched from BT fibre broadband yesterday which gave me a download speed of 17MBs to TalkTalk fibre which gives me a download speed of 1.7MBs. Also caller ID is not working. I phoned technical support and they could not sort it out but told me this speed was within that expected for the line although the minimum speed guarantee was 8.6MBs. The technical support assistant said the slow speed might be due to the distance of my house from the cabinet, however my house is in the same place as it was yesterday when I was connected to BT. I am very disappointed and if it is not fixed I will change back to BT. I am sure there is a solution to this though. I wondered why BT needed separate modem to the router to provide their service. Please help sort this out for me.

Matt123
Sightseer

Hi 

I changed internet provider from BT to TalkTalk yesterday. I was getting 17MB/s speed with BT. Now I am getting 1.7MB/s with TalkTalk speedcheck (although only 0.5MB/s with independent speed checker). I phoned technical support but they couldn't help me. There is clearly a technical problem with the switchover. The upload speed is good at 0.5MB/s. Also my caller ID is not working. I don't want to have to change back to BT as they are rip off but I can't use the broadband as it is. My guaranteed speed was 9.6MB/s and estimated speed 10-18MB/s. Please help.

Thank you.

Gondola
Community Star

Hi @Matt123

 

The TalkTalk supplied router is used in place of the BT router and separate modem as it's fibre-enabled ready for a VDSL fibre to the cabinet service.

 

But I suspect that Openreach haven't connected up your line properly at the street cabinet. It's probably receiving an ADSL standard broadband service.

 

If you log in to your router's maintenance interface 192.168.1.1 and look at the line statistics that'll tell you.

 

I've drawn this topic to the attention of the TalkTalk Community support team of OCE's and they'll respond to you right here to help you.

 

You may have already done this bit but ensure your Community Profile Personal Information (Click here) includes your TalkTalk landline phone number and an alternate number (mobile recommended). Add, then scroll down and save changes. The Community support OCE's will then be able to link this topic to your TalkTalk service account.

 

Leave your router powered and connected to the line until you hear from the OCE's.  They'll check the line performance and the router and will have options to discuss with you including escalation to Networks and Openreach if the service hasn't been properly connected or a fault is present.

Gondola - I'm a PlusTV customer * Security Hub - Stay Safe Online
Community Team

Hi Matt123

 

I've completed a line test which hasn't detected any faults and your line is in sync at 16.3mb.

 

Have you tried powering down your router for 30 minutes and running a speed test following this?

 

Thanks

 

Debbie

Matt123
Sightseer

Hi Debbie. The broadband band speed has increased today so that problem is solved. Thank you. The caller ID doesn't work though. Can this be fixed as well?

Matt

Community Team

Hi Matt

 

I'm glad to hear that the speed has increased. 

 

In regards to the caller display, is anything displayed (any error messages)

 

Please can you test the phone directly at the test socket?

 

Thanks

 

Debbie

Matt123
Sightseer

Hi Debbie

I have tried the phone in the test socket and caller ID does not work still. 

Phone says "call" instead of displaying the number.

Matt

Community Team

Hi Matt

 

Thanks for your reply.

 

Please can you add an alternative contact number to your Community profile, I can then raise this fault over to our Network Team for investigation.

 

Debbie

Matt123
Sightseer
Community Team

Hi Matt

 

Thanks for updating your Community profile. I've raised this fault over to our Network Team for investigation and I will post back on this thread as soon as I receive further information.

 

Debbie

Community Team

Hi Matt

 

I've received the following update from our Network Team:

 

I have removed and re-added the caller display feature, Please allow 30 mins for this order to go through. After this ask the customer to remove the power and out the socket and then re-test.

 

Thanks

 

Debbie