cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Specific devices experiencing massive speed drops and connection loss.

Reply
3 REPLIES 3
Highlighted
Visitor

Hello,

For the past few weeks a few members of my family had been complaining about slow speeds on our Wifi network on their laptops and phones. On my own phone, Laptop and Wired Desktop, my speed was completely fine, so I assumed the problem lied with their own devices, as they came and went randomly.

 

Occasionally they would lose internet access entirely, with the Router not reporting any problems. Strangely the way I found to fix this was to change the DNS server. Even just alternating between GoogleDNS and the default Talktalk one each time immediately solved the problem for them. Once again, my own phone, laptop and desktop were unaffected in these situations.

 

Now today, the problem seems to have changed devices. My sister's phone now has expected speeds, yet mine have dropped significantly. With my phone reading below 1Mbps download on a speed test. Strangely this is also affecting my desktop on Ethernet connection, also registering less than 2Mbps, whilst a few other wireless devices are working at 30Mbps just fine.

 

I've tried changing DNS again, changing the Wifi channel, Band settings (Every wireless device except our printer is on the 5ghz Band) and restarted the Router a few times but nothing has had any effect.

We have around 8-9 devices connected to the router almost constantly, could this be a result of the router being overloaded and prioritizing specific devices?

Highlighted
Community Team - TT Staff

Hi Jacksoon

 

I'm really sorry to hear this.

 

Have you added the correct landline number to your Community Profile? (please do not post the number on this thread)

 

Thanks

 

Debbie

Highlighted
Visitor

Yup, that's correct.

I'd also like to add that overnight we lost connection entirely again. Sister's phone, laptop, and my wired desktop were all completely unable to connect to the internet throughout the night, yet my phone was perfectly fine. Router showed no problems on its status.

Switching to Google DNS in the morning solved the problem instantaneously.

Highlighted
Community Team - TT Staff

Hi Jacksoon,

 

Line test is clear and router is in sync at 21.8Mbps

 

Could you switch your router off and leave it off for 30 minutes then switch back on and retest. Please let us know if there's any improvement

 

Thanks

Chris