cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Speed Boost Doesn't Work

Reply
20 REPLIES 20
Highlighted
Chatterbox

Around two weeks ago, I received an email suggesting I could benefit from an internet that was twice as fast using the Speed Boost option. I agreed by clicking the button in the email, and was told that I would receive a confirmation email within the next 72 hours. Five days later, and with the exact same internet speeds (and no confirmation email), I contacted Customer Services by chat and, after 90 minutes in which I was transferred to someone on the technical team, was told something must have gone wrong, and that my boost would be removed, and I should manually reactivate it. 

I did this five days ago, and have had the exact same result - my internet speed is EXACTLY the same. I would therefore request that someone look into activating this for me at last or that it is removed entirely from my account so I am not charged for it. 

Highlighted
Philosopher

@Matthewcsaunders  Welcome

 

i have seen beofre that the speed boost needs looking at by the oce on here seems to be a system issue some where.

 

 

A bite of info of Forum:
The forum is not real-time 24/7 support, so depending on how busy they are & how many are working at any one time, this can take 24 - 48 hrs (excluding weekends & limited cover on Bank Holidays). Alternatively, you can call the call centre or use online chat. The posts are responded to in time/date order, oldest first. So the fewer entries you make on your thread now, the sooner they will pick it up.

To save yourself time, please make sure that your community profile includes your first & last names, broadband phone number & if possible an alternative contact number. This can be done by clicking on your Avatar picture then click on "My Settings" followed by:- Personal Profile > Personal Information

Otherwise, TalkTalk will not be able to tie up your forum username to your broadband account. Only you & TalkTalk have visibility of your details.

Hope that help Joe
If so then give me a Kudos ( Click the Thumb up Button)
Highlighted
Chatterbox

Just spent an hour talking to multiple people using their chat sytstem, asking each of them to remove the Fibre Speed Boost (which I've now been charged for despite it not working) from my account. Was eventually put through to someone in their Loyalty team who told me her system was down and I'd need to try it all again in two hours time.

 

Wonderful stuff, Talktalk.

Highlighted
Philosopher

@Matthewcsaunders Hi please let the team on here sort that out they are the best thing with this type of thing just let them know what the issue is and they will try to fix asap.

 

as u have found chat is like the call staff not good at any time of the day

Hope that help Joe
If so then give me a Kudos ( Click the Thumb up Button)
Highlighted
Chatterbox

I find myself wishing that the Talktalk Social team was in charge of sorting things out. I put a one star review on Trustpilot about this whole fiasco. Half an hour after writing it, their Social team responded to tell me to "try again". I mean, it didn't help me in any way, but at least it was a response, and a speedy one at that.

Highlighted
Community Team - TT Staff

Hi Matthewcsaunder,

 

I'm sorry about this but it looks as though the speed boost hasn't completed correctly. I've removed it and will try adding it again later. I'll let you know when I've done this

Thanks

Chris

Highlighted
Community Team - TT Staff

Hi Matthewcsaunder,

 

Could you leave this with me as I've done the same with another customer and just want to confirm that it's gone through OK. All being well I'll re-add the speed boost in the morning 


Thanks
Chris

Highlighted
Chatterbox

Okay. I'll keep my fingers crossed this finally works.

 

Thankyou.

Highlighted
Community Team - TT Staff

Hi Matthewcsaunder,

 

I've re-added the speed boost so can you give it an hour then switch your router off for 30 minutes then switch back on and retest. If there's still no speed improvement can you try switching the router off again for 30 minutes later tonight


Chris

Highlighted
Community Team - TT Staff

Hi Matthewcsaunder,

 

How are you getting on? Your router is now showing in sync at 64.3Mbps so hopefully you've seen an improvement at your end

Chris

Highlighted
Chatterbox

That's odd. I left my router off last night and turned it on again today.  Just ran several speed checks and am getting 38 - 40mbs, which is essentially still what I was getting before the boost.  

Highlighted
Community Team - TT Staff

OK thanks. Looks as though the router needs to be switched off again for 30 minutes. Could you give this a try and then run a couple more speed tests - please let me know how you get on


Chris

Highlighted
Chatterbox

Amazing - it finally works! I can't thank you enough, Chris. I'd really given up hope on Talktalk and you've restored my faith. 

 

If there's a survey or anything you need me to fill in, I will gladly give you five stars or whatever for your service here. You've solved my issue when everyone else I spoke to didn't seem to care. 

Highlighted
Philosopher

@Matthewcsaunders  That is why this website was a beta for a while then the ceo team saw what a good job it does and took it on as a whole new site for real.

 

Thats also helps with the community stars are good as well.

Hope that help Joe
If so then give me a Kudos ( Click the Thumb up Button)
Highlighted
Team Player

@OCE_Chris please help me with my woes, I have had nothing but trouble since I joined TalkTalk

 

Please see these threads - https://community.talktalk.co.uk/t5/Fibre-Broadband/Faster-Fibre-with-Speed-Boost-Nightmare-situatio...

 

Please see attached what I signed up for and please see my account what has happened in the last 48 hrs.

 

And this thread - https://community.talktalk.co.uk/t5/Billing-Your-account-MyTalkTalk/4-Increase-for-TV/m-p/2321831#M2...

 

 

Highlighted
Chatterbox

You're going to need to be patient, Alex. I had to wait a day or two for a response. This messageboard doesn't seem to be monitored 24 hours a day.

I'd also advise against piggybacking on other threads. My issue has been solved and so they may not even check this thread anymore. 

Highlighted
Team Player

Thanks @Matthewcsaunders 

Highlighted
Community Team - TT Staff

Hi Matthewcsaunders,

 

That's great news, glad to hear it's now working, happy to have helped 🙂

Chris

Highlighted
Community Team - TT Staff

Hi AshAlex,

 

We should get around to your thread sometime this morning 🙂

Chris

Highlighted
Team Player

@OCE_Chris  Much appreciated, thank you.