cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Talk Talk Wifi Hub - need to change default IP address

Reply
14 REPLIES 14
Highlighted
Fibrepaul73
Chatterbox

I've just setup my Talktalk Wifi Hub to connect over Fibre Broadband.  All is great so far, but the default IP address of 192.168.1.1 doesn't work for my home network.  When I try and change it I get 'Invalid IP address'.  I see other people have reported the same issue but I'm not sure whether the issue is resolved with newer firmware.  It goes without saying that the DHCP pool range would need to change as well.

 

My current firmware revision is SG4K10001400t.  I've tried a router reboot but no newer firmware has been downloaded.

 

Any help would be much appreciated.

Highlighted
KeithFrench
Community Star

I have asked one of TalkTalk's OCEs to pick your thread up and upgrade it to V2600 for you. That should sort the problem.

The forum is not real-time 24/7 support, so depending on how busy they are & how many are working at any one time, this can take 24 - 48 hrs (excluding weekends & limited cover on Bank Holidays). Alternatively, you can call the call centre or use online chat. The posts are responded to in time/date order, oldest first. So the fewer entries you make on your thread now, the sooner they will pick it up.

To save yourself time, please make sure that your community profile includes your first & last names, broadband phone number & if possible an alternative contact number. This can be done by clicking on your Avatar picture then click on "My Settings" followed by:-

Personal Profile > Personal Information

Otherwise, TalkTalk will not be able to tie up your forum username to your broadband account. Only you & TalkTalk have visibility of your details.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Fibrepaul73
Chatterbox

Hi Keith,

 

Thanks for your help.  I'll look out for the following posts regarding subsequent action.  My profile does reflect my Talktalk Broadband account details.

 

Cheers,

 

Highlighted
Community Team

Hi Paul

 

The firmware update is pushing now.  Should be complete is 5 minutes 🙂

 

Thanks

 

Karl. 

Highlighted
Fibrepaul73
Chatterbox

Hi Karl,

 

I can see that I now have the 2600t firmware update - thank you.

 

I can now change the LAN IP setting to get the router onto my 10.0.1.x network.  However when I change the IPv4 pool end address I still get an 'invalid IP address' when I enter 10.0.1.254.  I am able to enter the IPv4 pool start address of 10.0.1.200 with no problems.

 

Is this still a firmware problem or something I've missed?  I hope you can help.

 

Regards,

 

Paul

Highlighted
Community Team

Hi,

 

@KeithFrench - Would you be able to provide any assistance? 🙂

 

Thanks

 

Highlighted
Fibrepaul73
Chatterbox

Just a quick update. I've discovered that even though you can change the IPV4 pool start address and apply the change, when you move off of the page to another setting and then move back to the DHCP setting page, the IPV4 pool address start setting has reverted back to 192.168.1.10.  Even if you change the IPV4 pool start address, apply the changes, then reset the router, the changes still revert back.  Performing a factory reset and trying to perform the changes again makes no difference.

 

When can I expect some future firmware to resolve this problem?

Highlighted
KeithFrench
Community Star

I'll make sure that the TT Products team know about this bug now.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Fibrepaul73
Chatterbox

Right,  I'm now having to make the most of an awkward situation.  In order to use the TalkTalk Wifi Hub with it's issues (firmware version SG4K10002600t - latest as of 8/8/2019) I have to reside myself to using the default 192.168.1.x network set up on the router.  This means changing all the devices on my home network to use the 192.168.1.x network.  Most of these devices now use DHCP reserved IP addresses as at least that part of the Wifi Hub's firmware is working.  My other Wireless Access Point, network printer and NAS all have new static IP addresses.

 

I now have the Hub set up as I'd like.  Pity I had to make so much effort due to some buggy functionality.

Highlighted
Community Team

Hi Fibrepaul73,

 

Apologies, we have fed this back to our Products Team.

 

Thanks

 

Highlighted
soniiic
First Timer

I also have this same issue. Yesterday I had spoken to "technical" support about it and they had no idea what I was talking about and kept on suggesting that the router IP address could not be changed.

 

Please get this resolved ASAP. Here is an image which may help your developers.

 

Image

Highlighted
silverfoxphil
Popular Poster

You are not alone in having to deal with such poor testing of the firmware.

I have only just joined TalkTalk and am not impressed that such a great router has been ruined by stupid management decisions to cripple the firmware under the misguided thinking it will reduce customer issues. Instead they have caused more problems. Why they could not have just left BASIC Router control settings alone I do not know. Looks like I'll be using a old router and bin-ing the pointless paperweight they have created. Not a good introduction to TalkTalk.

Highlighted
tinmac
First Timer

I have just switched (back again) to talk talk & looking forward to a faster service & better router.

 

However, I Just connected the new super router & looking to change the IP start address & im here on this thread finding out that I can't change it.

 

I have a wired home network with devices having been preset with their own IP address. 

Talk talk do you realise that omitting such a basic setting means so much work for people??

 

Also your start address (192.168.1.1) is at odds with the norm, as most routers use 192.168.0.1 and therefore simply swap out without too many issues.

 

Even your old (non super) router had the ability to change the start ip address!

 

You must get this setting back, put it in the advanced settings but please, we need it back.

Highlighted
tinmac
First Timer
Hhmmm after a reset and messing about a bit more I see the settings now.

Apologies for my previous post, i have now set the routers ip to 192.168.0.1

I have to say, I wish it was preset to this as most routers are, would save time and headaches.
Thanks talktalk, im enjoying your service, thumbs up
Highlighted
ferguson
Community Star

Actually “most” routers use 192.168.1.1.