cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

TalkTalk DNS Not Working & Slow Connection When Not Using a VPN

Reply
7 REPLIES 7
Eddie03
First Timer

Hi,

 

My internet connection was set up on Monday. The speed tests are fine, but I am encountering a couple of issues:

 

  • The default DNS servers (79.79.79.79 & 79.79.79.80) provided via DHCP to the router (TalkTalk WiFi Hub SG4K10001400t) will not resolve domain names, although these are pingable. Third party DNS works fine.
  • Pages are very slow to load but I do not encounter this issue when using a VPN

I haven't had much luck so far with support on these issues. I phoned up support but was told they did not have any knowledge article in their database around DNS not working and they were unable to help me. Keen to resolve these issues otherwise I will have to consider switching provider.

 

Thanks,

 

Eddie

KeithFrench
Community Star

First off your hub should update its firmware to V2600 in a day or so, try rebooting it. There are no VPN issues with this router at all, you can change the DNS servers within the Internet Connectivity section to Google or openDNS, but you will not be able to use TalkTalk's HomeSafe facilities then, as they are linked into the TalkTalk DNS servers.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Eddie03
First Timer

Hi Keith,

 

I will see if the firmware update solves anything.

 

I am using the VPN as a workaround to the slow loading of websites, not related to the DNS issues.

 

I am already changing the DNS to Google DNS (8.8.8.8, 8.8.4.4) as a workaround for the TalkTalk DNS servers not working. This is being done on the router.

KeithFrench
Community Star

What is the downstream line rate of the router & what sort of speed test results do you get?

 

Have you tried running a tracert to the slow website, comparing it to one run when you have VPN access up? It does sound like a problem with the route to the destination, as internet access is likely to be different via a VPN, as you use their internet access router.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Eddie03
First Timer

So I've just tried using DNS over TLS (without the VPN) and a third-party DNS provider on my client. I'm no longer getting the slow loading of web pages/resolving host for a long time in Chrome.

 

Which leads me to believe there is some kind of filtering/inspection for third party DNS requests which is slowing down domain name resolution. 

KeithFrench
Community Star

There isn't any problems using 3rd party DNS servers that I am aware of, which is why I think that this is a networking issue and suggested doing some tracerts.

 

I have asked one of TalkTalk's OCEs to pick your thread up and investigate it for you.

The forum is not real-time 24/7 support, so depending on how busy they are & how many are working at any one time, this can take 24 - 48 hrs (excluding weekends & limited cover on Bank Holidays). Alternatively, you can call the call centre or use online chat. The posts are responded to in time/date order, oldest first. So the fewer entries you make on your thread now, the sooner they will pick it up.

To save yourself time, please make sure that your community profile includes your first & last names, broadband phone number & if possible an alternative contact number. This can be done by clicking on your Avatar picture then click on "My Settings" followed by:-

Personal Profile > Personal Information

Otherwise, TalkTalk will not be able to tie up your forum username to your broadband account. Only you & TalkTalk have visibility of your details.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Eddie03
First Timer

Thanks @KeithFrench,  I have filled in these details. The router seems to be blocking ICMP despite the firewall level being set to low.

 

Without VPN:

 

traceroute google.com -T


traceroute to google.com (172.217.169.14), 30 hops max, 60 byte packets
1 _gateway (192.168.0.1) 0.730 ms 0.680 ms 0.737 ms
2 * * *
3 host-78-151-238-213.as13285.net (78.151.238.213) 5.749 ms 6.229 ms 6.338 ms
4 host-78-151-238-208.as13285.net (78.151.238.208) 6.465 ms host-78-151-238-212.as13285.net (78.151.238.212) 7.143 ms host-78-151-238-208.as13285.net (78.151.238.208) 7.080 ms
5 host-78-144-14-108.as13285.net (78.144.14.108) 7.182 ms host-78-144-14-112.as13285.net (78.144.14.112) 13.028 ms host-78-144-14-110.as13285.net (78.144.14.110) 7.498 ms
6 host-78-144-4-33.as13285.net (78.144.4.33) 8.545 ms 8.068 ms host-78-144-4-35.as13285.net (78.144.4.35) 7.942 ms
7 209.85.247.201 (209.85.247.201) 7.788 ms 72.14.232.76 (72.14.232.76) 7.307 ms 108.170.246.161 (108.170.246.161) 5.677 ms
8 209.85.241.95 (209.85.241.95) 6.750 ms 6.606 ms 6.006 ms
9 lhr25s26-in-f14.1e100.net (172.217.169.14) 5.926 ms 6.031 ms 5.573 ms

 

With VPN (which completes a lot quicker)

 

traceroute google.com -T


traceroute to google.com (216.58.210.238), 30 hops max, 60 byte packets
1 10.98.10.1 (10.98.10.1) 6.074 ms 6.034 ms 6.016 ms
2 vlan49.mer-3d2-a2-10g-2.m247.com (89.238.154.161) 7.104 ms 7.121 ms 7.112 ms
3 37.120.128.224 (37.120.128.224) 7.053 ms * *
4 xe-0-1-1-0.core1.lon2.uk.m247.com (77.243.185.216) 7.025 ms 7.429 ms 7.411 ms
5 te-8-5-0.bb1.lon1.uk.m247.com (176.10.82.161) 8.299 ms 8.283 ms te-7-1-0.bb1.lon1.uk.m247.com (193.9.115.142) 8.264 ms
6 google1.lonap.net (5.57.80.136) 16.773 ms 13.539 ms 13.522 ms
7 74.125.242.65 (74.125.242.65) 14.091 ms 74.125.242.97 (74.125.242.97) 16.827 ms 74.125.242.65 (74.125.242.65) 16.086 ms
8 172.253.68.213 (172.253.68.213) 16.089 ms 16.091 ms 172.253.68.215 (172.253.68.215) 16.070 ms
9 lhr48s12-in-f14.1e100.net (216.58.210.238) 9.805 ms 13.450 ms 13.480 ms

 

 

Community Team

Hi Eddie03

 

I've just updated the router firmware, see if this changes anything.

 

Regards,

 

Karl.