cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

TalkTalk Hub problems with DNS and invalid IP addresses

Reply
18 REPLIES 18
dnsnightmare
Chatterbox
Hi there I joined TalkTalk a few days ago and I'm having problems with the hub: Hardware Version FAST5364 3.00 Software Version SG4K10001E00t First problem was that the default IP address is 192.168.1.1, which is in a different subnet than all of the other devices in my home. I thought the industry standard was 192.168.0.1 because this has been the default IP of all routers from every other ISP I've had over the years. So I eventually gained access to the router and tried to change its IP address via the Hub Settings -> DHCP page to 192.168.0.1, and the DHCP pool range to 0.10 > 0.254. But every time I edit an IP address on this page, I'm presented with a validation error "Invalid IP address". This happens no matter whether I type or paste into the field. I don't know how, but somehow I managed to change all the fields eventually and my router now has an IP of 192.168.0.1. This is where the real trouble begins. On the Hub Settings -> DNS tab, the "Primary DNS Server" remains at 192.168.1.1 and there is no way to change this. I can't turn the "Static DNS Server Configuration" OFF - clicking on the toggle switch simply does nothing. This means my devices are being given a default DNS server of 192.168.1.1 and therefore they have no web access. I have tried going to Internet Connectivity > Basic > IPv4 and choosing "Manually Specify DNS" in there, but the changes I make in there do not seem to override the "Static DNS Server Configuration" section I mentioned above, and my devices are still trying to use the now non-existent 192.168.1.1 for DNS. This is really frustrating and I've never had any problems like this from the 7 or 8 other ISPs' routers I've used over the years. Help would be appreciated. Thanks.
dnsnightmare
Chatterbox
P.S. I did format my post with lots of line breaks but the forum has helpfully stripped them out.
Community Team

Hi

 

All our routers have the IP address of 192.168.1.1 

 

This is the most common configuration for routers and not unique to TalkTalk.

 

You can see this with the majority of router models here.

 

If you add your home phone number to your Community Profile I can push the later firmware to your router and see if this helps.

 

Thanks

 

Karl. 

dnsnightmare
Chatterbox
Hi Karl Thanks for your reply. Will the latest firmware allow me to disable the static DNS configuration? I've updated my profile so happy to give that a go. Thanks again
dnsnightmare
Chatterbox
Another update: I've discovered that WiFi calling is also not working on our household's mobile phones (iPhones) with this router. It did work with my previous (PlusNet) router. I suspect this might also be because of the DNS issue since it screws up pretty much everything connected to the network. If its not possible to fix the DNS problem by disabling the static DNS confguration feature on this router, would it be possible to send me a different router model, please? This one is a Sagecom FAST 5364. Thanks
Community Team

Hi dnsnightmare,

 

I'm sorry for the delay. Would you like to try the new firmware first before we send a different make and model of router for testing?

 

Thanks

 

dnsnightmare
Chatterbox
Sure, please go ahead and update and I'll report back. Thanks.
Community Team

Hi dnsnightmare,

 

I've just checked and the firmware has been updated. Please let us know how the connection compares.

 

Thanks

 

dnsnightmare
Chatterbox
Hi Michelle Thank you for your help, but unfortunately the problem remains the same, and I'm still not able to edit or disable the static DNS configuration section in the router. WiFi calling is still also not working. Can you please try sending out a different router and I'll give that a go? Thanks again
Community Team

Hi dnsnightmare

 

Apologies for this.

 

Would you like me to send another Wifi Hub or a different make and model of router for testing?

 

Thanks

 

Debbie

dnsnightmare
Chatterbox
Hi Debbie Please send a different model to try. Thank you.
Community Team

Hi

 

A Huawei router is on the way to you.

 

Thanks

 

Karl. 

Kina_Speed
Popular Poster
Hi,

I have a house with many devices setup with old IP address 10.1.10.x
I received the new router today and I can’t change the IP address to the above, could you please help?

Thanks in advance..
Kina
Community Team

Hi Kina_Speed,

 

I'm sorry to hear this. Please can you create your own thread and we can look into this further for you.

 

Thanks

 

topgadgey
Newbie

I also cannot change my IP address to 192.168.0.1 is there any solution for this?

Community Team

Hi topgadgey,

 

You can't change the IP of the router but can change the DHCP range issued by the router.

 

Thanks

 

topgadgey
Newbie

Ok I am trying to change the up of my router from 192.169.1.1 to 192.168.0.1

 

this is so I can use my existing network for my cctv system. Everything worked flawlessly with my previous provider sky.

 

i have had to use a aftermarket router in the meantime that lets me use the ip address 192.168.0.1 but my internet speed seems to be throttled with this router.

 

i would like to use my TalkTalk router but every time I try to change the IP address to 192.168.0.1 I get a invalid IP address error.

 

i have seen that a firmware update has fixed other people issues, can you forward me a newer firmware?

 

my current firmware is SG4K10002600t

 

At present my download speed is 5.0mbps which is also unacceptable considering I paid for the faster fibre broadband package.

 

if I cannot get these issues fixed I shall have to change my provider to a isp that can.

topgadgey
Newbie
Community Team

Hi topgadgey,

 

2600 is the most recent firmware at the moment for the wifi hub. Could you create a new thread and we can look into this further and also the speed issue.

 

Thanks