cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Unable to access my QNAP NAS via [name].myqnapcloud.com

Reply
Highlighted
Team Player

@ahabibWhen you say "it always loads my local WAN IP" do you mean you see the router login screen?

 

EDIT: NVM, if it worked with a previous router it shows this one is simply blocking the ports the NAS needs.

 

EDIT 2: There is another way to make NASname.myqnapcloud.com work that may well work with your router, but when you want to access QTS you have to put the full address and a forwarded port into a browser i.e. http://NASname.myqnapcloud.com:9080 or for a secure connection https://NASname.myqnapcloud.com:9080. If you omit the protocol (http:// or https://) or mapped port it won't work. Admittedly it's not as convenient as simply typing in the hostname. If that's acceptable to you I can give more detail.

Piethorne
Highlighted
Popular Poster

@Piethorne Partial success

 

I finally got it to work (somewhat) by remapping the NAS and router to a different port. Unfortunately this only works if I am coming back to the NAS via VPN. This is the address used: https://[name].myqnapcloud.com:xxxx/cgi-bin/

 

If I switch off the VPN, it doesn't work anymore.

Highlighted
Team Player

Hmmmm, I don't use VPN so don't can't say, but at least you're getting somewhere. My own setup is pretty straightforward, with the system and webserver ports at their defaults of (system) 8080 and 443, (webserver ) 80 and 8081.

 

The rest is down to port forwarding at the router i.e. port 8080 is forwarded to 9086, 443 to 9087, 80 to 9088, 8081 to 9089 etc.

 

For example

pforwarding.gif

 

To access QTS remotely I just use http://NASname.myqnapcloud.com:9086 or https://NASname.myqnapcloud.com:9087

 

The web server's a similar story, with the host name http IP being redirected to the non-standard port 9088 by my DDNS provider. (I don't use the https protocol ATM)

 

(Both of my Qnaps are setup similarly)

 

I've seen "cannot connect" complaints on here regarding routers and VPN, but have no experience of this.

Piethorne
Highlighted
Popular Poster

I understand what you are saying @Piethorne , but I am unable to manually allocate ports on my Sagecom router ever since the firmware was upgraded.

 

I am still unable to access https://[name].myqnapcloud.com:7002 without first setting up a VPN connection, which seems odd. This indicates to me that the NAS is visible on the internet, except that I can't access it in that way from my home. I can connect directly to the NAS QTS Desktop by https://192.168.1.xxx:7002.

 

I wouldn't mind if you want to try to reach it from where you are via [name].myqnapcloud.com, since you already know the name of my NAS 🙂 and let me know if you can. Thanks for your time and assistance.

Highlighted
Team Player

@ahabib  No problem accessing your NAS QTS 4.4.3   *******F9 login page form here 😁

 

I reckon NAT Loopback isn't enabled on your router, which is why you can access QTS with the local IP, but not by using [name].myqnapcloud.com.

 

This also ties in with being able to access it via VPN - i.e. you're accessing it from outside the "local internal network". The same is true of Qnap's smartlink, which is almost certainly a VPN on their own servers.

 

You should be able to use https://[name].myqnapcloud.com:7002 with a mobile phone, even inside your own home - BUT you'll have to turn off the phones WiFi connection first to stop it connecting to your router (or NAS if it has WiFi) i.e. the connection MUST come from outside of the local internal network.- Let me know if that works...

 

Piethorne
Highlighted
Community Star

Which is exactly what I suggested way back in post #4.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Popular Poster

Thanks @KeithFrench . Your comments duly noted.