cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Upgrade SMB v1.0 to SMB v2.0

Reply
5 REPLIES 5
mgee1
First Timer

Hello,

 

Due to serious security vulnerabilities SMB v1.0 has been disabled in Windows 10 Proffesional.

This protocol seems to be in use in Huawei HG633 routers to share files from hard drive connected to USB port.

 

With SMB v1.0 turned off in WIndow 10 I am not able to map my hard drive as network drive. 

 

Is it possible to upgrade firmware in those routers so users can use patched up version of SMB protocol?

KeithFrench
Community Star

No is the simple answer. You could still map a drive between two or more PCs or use a NAS.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

mgee1
First Timer

Huawei dropped support for those routers?

martswain
Philosopher

I recently changed from an 18 month old Acer laptop with Windows 10 Home that COULD see the drive connected to the USB port on a HG633 to a Lenovo laptop running the latest version of Windows 10 Home that, despite enabling Samba 1.0 in Windows Components will NOT see the drive at all.

 

The drive is still visible and accessible to my last-resort XP computers and I can read/write files from these computers without issue.

 

Over the last 2 weeks I have tried just about every "suggestion" I have found on the net, with no success.

 

It all points to a Windows 10 issue, the only place I haven't and won't go is the Registry, too advanced for me.

Martin
mgee1
First Timer

Login to router and try to delete all users allowed to access hard drive and add them again with different passwords.

martswain
Philosopher
The drive will not show in THIS PC or NETWORK on my new W10 laptop, it has never appeared on my new laptop.

I have tried all combinations of SMB 1.0 on the Windows Components box.

Nothing I do in the router interface makes any difference.

"Anonymous users" worked with my previous W10 laptop but as it is completely dead I am not able to see the configuration it had.
Martin