cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

VPN not working

Reply
14 REPLIES 14
petruccs
Repeat Guest

Dear TalkTalk,

I am trying to use OpenVPN from my flat with TalkTalk broadband but it doesn't work.

I can connect to the VPN with no errors.

The issue is that, once i connect to the VPN, I cannot reach any website.

I can only ping 8.8.8.8, not even google.com or an internal ip such as 192.168.1.100 (or similar).

 

Few more details:

  • I started my contract middle December 2019
  • I am using the D-Link model DSL-3782 (the default one)
  • I am using the config file generated by OpenVPN
  • The same config file works in different networks
  • Using the same config file with the official OpenVPN app from Android doesn't work. As soon as I disconnect my phone from the Wifi (without disconnecting the VPN), the connection works (using mobile data, of course)
  • I can connect to the VPN (log files say "connected")
  • I tried with two different computers and a phone obtaining the same result
  • I am only using Wifi (ethernet cable is too far)

 

Thank you for the help.

Divsec
Community Star

Hi @petruccs welcome to the community your post has been flagged for assistance and you should hear during tomorrow in the meantime please check your community profile and add your landline phone number if necessary it is used to identify your account. I suspect you may need a firmware update and this cannot happen until your account is identified.

Please don't post personal details here.

Regards Divsec, I don't work here, know little, and have too many opinions.
Community Team

Hi petruccs,

 

Can you please update your community profile to include your:

  • Name
  • Telephone number
  • Alternative contact number

We'll then look into this further. Please do not post this information on this thread Once you've updated your profile please post in your topic to confirm it's updated. 

 

Thanks

 

petruccs
Repeat Guest

Hi @OCE_Michelle

Thank you for the quick reply.

I have update my profile information.

 

 

Thank you again!

Community Team

Hi petruccs,

 

Thank you. I've checked and the router has the latest version of firmware which should work ok with VPN. Would you like us to send a HG633 router for testing purposes?

 

Thanks

 

petruccs
Repeat Guest

Hi @OCE_Michelle,

It would be great!

I really appreciate it.

 

Thank you a lot

Community Team

Hi

 

A new router is on the way for testing.

 

This should arrive in the next 24-48 working hours.

 

Thanks

 

Karl. 

petruccs
Repeat Guest

Thank you a lot!
I will keep you updated.

Community Team
petruccs
Repeat Guest

Hi everyone,

Here the update.

I just received the router, I plugged it and VPN worked perfecty.

I tried to plug the previous router but VPN stopped working.

I am using the same computer, same OpenVPN config file and same Network Manager settings for the two tests.

 

Community Team

Hi petruccs

 

Just to confirm, is this now working ok with the replacement router?

 

Thanks

 

Debbie

petruccs
Repeat Guest

Hi @OCE_Debbie,

I confirm that it works with the replacement router.

 

Cheers

Community Team
Galaxyway
Participant

Hi,

 

Sorry to Just jump into this thread, but I have a similar issue. I cannot access my PIA VPN service. I can access my VPN everywhere else but my home using TalkTalk Wifi. Is it possible for me to change my router also?

Community Team

Hi @Galaxyway

 

Please can you create a new thread, we can then look into this further.

 

Thanks

 

Debbie