cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Very poor internet speeds

Reply
6 REPLIES 6
Davi118
Chatterbox

I have just re-joined TalkTalk, and I'm very disappointed in the internet speeds I'm getting.

From my previous supplier was getting speeds of over 50 Mb/s. With TalkTalk fiber I'm only getting average speeds of 27.00 Mb/s and have had it drop to below 18 Mb/s on one occasion.

Their technical department isn't up to the job and can not give me a proper answer in why one supplier can get the speeds and they cant.

I asked to be put on the Fiber 35 as this is cheaper tariff but their answer was it would cost me £30.00 to change to the lower tariff, which was extremely distasteful. I have wasted a good few hours or so with them and still receiving a poor slow service.

 

So my question still is why cant TalkTalk get the speeds that other suppliers can give and have already received? 

David Cornish
Divsec
Community Star

Hi @Davi118  have you tried a 30 minute router reboot this often improves things.

Your post has been flagged for assistance and you should hear soon but please remember that the staff here work office hours.

I don't work here and all my opinions are my own.
Davi118
Chatterbox

Yes have already done this, but no difference. I have had talktalk technical run other checks I hope they do not ask to go through these again as been done twice before.

Just done another speed test 23.8 Mbps.

I did get 31 Mbps once but that might be just luck......

 

Dave.

 

 

David Cornish
Gliwmaeden2
Community Star

Your original thread has a reply from TT staff, @Davi118.

 

It is here:

 

https://community.talktalk.co.uk/t5/Fibre-Broadband/Slow-internet-speeds/m-p/2707807

 

 

 

Duplicate thread 

Gliwmaeden2, a fellow customer.
OCE_Debbie
Community Team - TT Staff

Hi Davi118

 

I can see that OCE_Jo has posted on your other topic on the Community.

 

Thanks

 

Debbie

OCE_Chris
Community Team - TT Staff

Hi Davi118,

 

Line test is passing and router is in sync at 32.9Mbps. How many telephone sockets do you have? Do you have anything connected to your telephone socket(s) in addition to your router?

 

Are you experiencing any problems with your telephone service, any noise on the line?


Chris