Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

WIN 10 5GHz Connectivity Problems

Conversation Starter

Hi,  Appreciate there are some historical posts around this topic but the following may be of interest.  Apologies in advance for length of post.


Bought three laptops in succession in last month, two Lenovo Ideapad 330S with Intel Optane memory module plus 1Tb HDD and latest is Dell Inspiron 15 3000 with 256Gb SSD.


Fibre broadband access to the Internet provided by TalkTalk Fibre Broadband using Huawei HG633 router. Wifi/Broadband average speed check stats: Ping 10ms, Jitter 1 -2ms, Upload 10Mb/s, Download 25Mb/s.


Each of Lenovo machines returned after failing to setup reliably including erratic wifi connectivity/update problems when trying to access Microsoft services (updates, MS Store, MS Cloud, Sign In using MS account)


Second Lenovo was subject of 7 hours of remote investigation by Microsoft technical support without being resolved. Symptoms included failure to connect with error messages stating that the device was not connected to the Internet, but Edge browser and other Internet access worked OK.   Connectivity was via Wifi only as no Ethernet port was provided on these models. Other wifi devices in house did not exhibit any issues.


Dell Inspiron purchased as replacement for Lenovo machines. Setup completed using Ethernet connection. Once complete decided to test wifi only connectivity, machine has dual band capability. Found same problems as with previous Lenovo machines and noticed wifi driver was same for all machines!


Checked Qualcomm QCA9377 802.11ac network driver and reset router without change, and Windows Troubleshooter did not report any problems. With failing MS Cloud sign in or “Check for Updates”, as soon as Ethernet cable re-atttached then sign in was immediate.

Investigated Ethernet and Qualcomm driver settings with following results:


  • Ethernet – 100% reliable when connected or re-connected, no failures
  • Qualcomm>Advanced> Prefered Band – No preference; Erratic connectivity with multiple failures.
  • Qualcomm>Advanced> Prefered Band - 2.4 GHz; 100% connections with no failures.
  • Qualcomm>Advanced> Prefered Band - 5GHz;  100% failures.


Not an expert but results suggest either the router, laptop hardware/driver or Windows 10 has problems using the 5GHz band. If it was the laptop (both Lenovo and Dell) or Windows 10 I would have expected to see many more current issues being reported on the various manufacturer and community blogs. So at the moment I am suspicious of the performance of the router.  Current solution is to leave driver set at 2.4GHz Prefered


Has anyone else experience similar problems trying to use the 5GHz band with the HG633 router or other hardware and have any more insights or solutions?



Community Star

Not all 5GHz adapters will work with the various permutations of the router's WiFi configuration. Please make sure that the router is using a 5GHz channel between 36 & 48 and the bandwidth is reduced from 80 to 40MHz, as this offers the most compatibility.


Let me know how things go like that & I will try & help further if required.

I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 


My HG633 is on Ch 44, 80 Mhz bandwidth and a WiFi analyser does not show any nearby SSIDs, sync speed is 31/5


6 month old Lenovo Ideapad 330S, Windows 10, AMD Ryzen 5 and 256 Gb SSD but with a Realtek WiFi adapter.


5 Ghz connection is rock solid with a link speed of between 290 and 390 Mbps, speed tests give a consistent 29/5


My cheap Chinese Smartphone (Ulefone Power 3S) also lives on 5 Ghz, link speed is always 135 Mbps and speed tests also give 29/5


It looks like the Qualcomm adapter is the common issue.

Conversation Starter

Keith and Martin - Thx for quick replies.


Following Keith's suggestion I have changed the router's 5GHz bandwidth to 20/40MHz option, was set at 80MHz.  Interesting that this was the option already set for the 2.4GHz band.


Tested laptop by setting Qualcomm driver "Prefered Band" to both <No preference> and also to <5GHz> only.  After resetting laptop each time following changes no problems experienced connecting into One Drive or Updates.  Looks like the Band/Bandwidth to Qualcomm adapter/driver setting was cause of the problems I was getting, so you were both right.


Pity neither Lenovo or Microsoft "senior" advocate thought of investigating this even though they knew the same problem had shown up on two identical laptops and were told which router etc I was connecting with.


Many thanks to both of you




Hi @jerryf  and @KeithFrench 


Just for info, I have tried a small experiment changing the bandwidth on 5 Ghz with my two devices connected, both sitting still on a table.


Link speeds quoted for each bandwidth setting, phone followed by laptop.


20 Mhz = 65 Mbps 78 Mbps


20/40 Mhz = 135 Mbps 180 Mbps


80 Mhz = 135 Mbps 390 Mbps


Seems that the 802.11ac adapter in the laptop likes lots of bandwidth for a good link speed.


However, changing the router bandwidth made absolutely no difference to speed test results using the TT approved tester, but then again I only have a sync speed of 31 Mbp


The variation was only from 29.1 to 29.4 over several tests on each bandwidth, no obvious correlation between speed and bandwidth, just random fluctuations.



Conversation Starter

Hi again Keith and Martin


As Martin has observed from his tests there is a direct correlation between bandwidth and max throughput/data transfer rate.  Seem to remember that there is some formula that calculates what the values are - Nyquist?


Setting the router bandwidth to 20/40 MHz on my own system here halves the wifi max data rate to 180Mb/s.


Have done a bit of testing myself changing router settings and it would seem that changing the default autoselect channel for 5GHz band from the usual 36 to 40 or 44 and setting the bandwidth to 80MHz allows successful connection to OneDrive and Microsoft Store downloads approx. 75% of the time but does still fail/goes inactive for the other 25%.  Setting the bandwidth back to 20/40MHz gives 100% success rate on any setting but at half the max data rate 180Mb/s.


So it would appear that the Qualcomm QCA9377 adapter/driver does not like the higher bandwidth setting on any channel.  Will contact Dell (possibly Qualcomm) to query this as being unable to utilise maximum bandwidth is a bit annoying.


As an aside Martin, which wifi analyser have you used when testing?  Some of the ones I have seen only give details of surrounding networks but no real technical info about the connection itself.


Regards - Jerry


Hi @jerryf 


On W10 I use a WiFi analyser from the Microsoft Store, Matt Hafner is the developer, that gives me the signal strength, channel and protocol but not the actual bandwidth unfortunately.


Bandwidth settings I mentioned are those set in the router interface.


To get the link speed I just use Control Panel > Network and Sharing Center > View network status and tasks, then clicking on the blue Wi-Fi link 



Conversation Starter

@martswain @KeithFrench 


Bit of an update on the connectivity problems I have found using 5GHz WiFi for the benefit of others who may have similar issues..


After more tests the problem in connecting to Microsoft services at maximum connection speed on the router is variable and at times the failure rate can be 100%.  Throttling the bandwidth back to 40MHz on the router always fixes the problem.


So have now done further repeated tests using friends broadband WiFi networks in the local area using the same exchange, one BT and one Vodafone.


In both cases WiFi connection speed was steady 433Mb/s which I think is the maximum the Qualcomm adapter can handle and faster than the maximum 390Mb/s achieved using TalkTalk's HG633.  In all tests Windows Update, MS Store Download Updates and OneDrive sign in worked seamlessly without any issues at all.


So given these latest results and Martin's tests that worked perfectly at 80MHz bandwidth I suspect the problem is not the Dell Qualcomm adapter/driver but the HG633 router.  Not sure what exactly the problem is as only some services appear to be affected but the evidence points to the router being the problem.  Further supported by having returned two Lenovo laptops which exhibited similar problems.


Having fully reset the router twice and checked it has the latest firmware version I think the next step is to get TalkTalk to send me a replacement router although I am not sure how to go about that without going through an unnecessary and time consuming set of support calls.


I believe the new Sagemcom router is supposed to have significantly improved WiFi performance so fingers crossed.