cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Web Browsers Not Connecting to Internet - DNS Problem?

Reply
40 REPLIES 40
Highlighted
Team Player

Hello,

 

I have been experiencing a problem over the last couple of days with accessing

websites through my web browsers. I am using Opera (vers.36, Windows Vista)

and it has suddenly stopped accessing websites. It shows an error message

whatever site I try to connect to - "DNS address could not be found". It had been

working fine before this. I tried Firefox 52.9 as an alternative but that also cannot

connect to any sites - "Firefox can't find the server". I hadn't made any changes

to connection or DNS settings before this.

 

I tried looking through the browers' settings to see whether there were any that

might affect this but couldn't find anything to change. I then looked through the

Network settings and found a place where DNS settings could be altered

(Networking/IPv4 Properties). It was showing "Obtain DNS Server Address

Automatically". I changed this to the OpenDNS settings (and later the Google

DNS settings) and tried the browsers again but it made no difference.

 

I also have the K-Meleon browser installed so I tried that and found it worked

without any trouble in accessing any website, and whatever the Networking

DNS settings were. I can't understand why one browser works but the other

two don't.

 

My connection is via ethernet cable to a TalkTalk HG633 router. Is it

possible there is some problem with the router's settings? Any help

or insight appreciated. Thanks.

 

GeorgeTT

Highlighted
Community Star

For firefox

Under Options and Network settings ensure that the only item selected is

Use system Proxy settings

Everything should be blank apart from v5_socks

Also ensure that whatever firewall / virus checker you use that firefox or other items are not blocked

If the Meleon browser works the Opera and firefox should work.

The standard microsoft browser should also work.

You can also try a factory reset on the HG633 modem/router to see if that is the issue

 

Highlighted
Team Player

Hello Paulshent,

 

Thanks for the quick reply. I changed Firefox to use System Proxy Settings (it was on No Proxy, as I presume it has been when using it before; everything else is blank) but no difference. Forgot to mention that I did look into firewall and virus checker settings before and couldn't find anything amiss. However, tried disabling them momentarily and used both Firefox and Opera to see whether they would work now but still made no difference.

 

Tried Internet Explorer (Vers.7) and yes it does work. Does it make any sense as to why some browsers work and other do not?

 

I did, before, try turning off the router for a few minutes and then back on but, again, no difference. Was that the same as a factory reset? If not, how do I do that? Grateful for any further advice.

 

GeorgeTT

Highlighted
Community Star

The factory reset is done by pressing the reset switch via the pin hole an rear of router.

That resets it back to factory settings. May not cure your issue but worth a try.

Will do some head scratching with the browser issues.  Have seen it before but just not managed to dig deep enough in to my grey matter to remember how it got resolved.

 

Highlighted
Community Star

Try the following link only after you have tried a pinhole reset on router and still have same issue with firefox

https://windowsreport.com/firefox-server-not-found/

 

Out of interest. What version of OS ?  (Think u said Vista)

What type of virus checker.?

 

Highlighted
Team Player

Hello Paulshent,

[Just composed this as you were sending me further advice. I haven't tried the pinhole reset yet, as explained below. I am using Vista Home Premium, Outpost Security Suite 7.1, Avast Free Antivirus current version.]

 

Regarding your suggestion re factory resetting the modem, I have now looked into the modem settings and have found there are Reboot and Factory Restore options. Presumably, the Factory Restore option is the one you are referring to. There is also a Backup or Restore Settings option which, I guess, would be a good idea to use before resetting the modem.

 

However, I also found there is a System Log file which I had a look at and didn't like what I saw. It only seems to cover today's events but shows that every 10 minutes there has been a "Security Warning of an Intrusion" along with some data which would need someone technical to decipher. It may be that this is in fact simply some normal traffic between TalkTalk and the modem (maybe every 10 minutes checking that the connection is live?). There are also entries about FTP and SAMBA requests. I don't know whether this is an indication of someone trying to hack the modem or something quite innocent!

 

I didn't reset the modem as I thought it best to find out first what is going on. Could this have anything to do with my browsers problem?

 

I hope you or someone else as knowledgeable can offer some explanation. Thanks.

 

GeorgeTT

Highlighted
Community Star

Do you have any other devices you can check with? Windows Vista has long since stopped being supported. 

Highlighted
Problem Solver

I can see @paulshent is helping and so its probably best to let him run through his checks but personally I'd try flushing the DNS and reseting everything.

 

If all else fails and you want to try this just let me know.


Fritz

Highlighted
Community Star

I have been talking to a few guys about Vista (Not supported).

They say Avast is a good piece of software but an absolute ass for causing problems

What is recommended for you to do by MS is

A) Backup your router profile for safety

B) Via the pin hole at rear hold button down for 10 seconds to reset router

C) Allow to reboot and come online

D) Check if Browser now working

If not then unload Avast. Reboot Vista and try again.

 

Please be aware that some protection suites can still cause blocking issues even when turned off.  

 

Highlighted
Team Player

Hello ferguson and FritzCT,

 

Thanks for your responses.

 

ferguson - I'm don't have another laptop with the relevant browsers to check it out. It may be something particular to the settings on my current laptop so I'm not sure it would help anyway. I know Vista is no longer supported but it does what I want it to do and don't feel the need and expense of upgrading OS or laptop is warranted.

 

FritzCT - I'm hoping paulshent can come up with the solution to this problem but, in the meantime, it might be worth trying your suggestion about flushing the DNS in case that solves it. I've heard of this before but don't know how to do it. Could you give me some instruction? What other resetting would I need to do?

 

I don't know whether either of you saw my last message about the modem/router log? Do you think there is some connection between those warnings of "Intrusion" entries and this problem?

 

GeorgeTT

Highlighted
Community Star

Don't worry about the router logs. I don't think you have been hacked.

Please reset the router via pin hole

Suspect that since 1 x browser worked that it may not be router but you have to go down the list of things to prove.  I suspect that it may be one of your security software packages causing issues on the laptop. But must prove router is ok.

Here is how to flush DNS

The first step to flushing your DNS is to open your “Windows Command” prompt. WinXP: Start, Run and then type “cmd” and press Enter. Vista, Window 7 and Windows 8: Click “Start” and type the word “Command” in the Start search field. In the open prompt, type “ipconfig /flushdns” (without the quotes).

 

Highlighted
Problem Solver

The thing about flushing the DNS and refreshing the network settings is it won't make anything worse and I've used it to fix a whole load of network issues in the past. It might not help but it's worth a try before factory resetting hardware.

 

So I've not used Vista for ages but you need to get to the "Run" dialogue box which is probably click "start" and look for a Run option or a box you type in.

 

Everything below should be typed without the "  ".

 

In the Run dialogue box type "CMD". You should see it find an app called CMD, it'll basically have  black icon.

 

Right click on it and select Run as Administrator. This is very important.

 

In the window that opens type the following, hit enter and wait for the commands to execute. It may prompt you to restart for the change to take effect but don't do that until after the last command.

 

"ipconfig/flushdns"

 

"ipconfig/renew"

 

"nbtstat -R"

 

"nbtstat -RR"

 

"netsh int ip reset c:\resetlog.txt"

 

"netsh winsock reset"

 

At this point re-start the laptop.

 

When it's booted up hold the windows key and press R.

 

In the box that appears type

 

"ncpa.cpl"

 

In the window that appears right click your Network Adapter and click disable.

 

Right click it again and select Enable.

 

Re-start the laptop and see if the browsers now connect correctly.

 

Fritz

 

 

Highlighted
Team Player

Hello paulshent and FritzCT,


Many thanks for the further advice.


paulshent - I reset the router via the pinhole and waited for it to reboot but it didn't fix the

problem. Then I tried the "ipconfig /flushdns" option. [Just for information, in Vista you need to go to

Start/Programs/Accessories/ select Command Prompt while right-clicking and choosing Run as administrator

- it doesn't appear to work from the Start/Run box or if you don't open the Command Prompt window as an

administrator]. This didn't make any difference either. I then saw FritzCT's message, so decided to try

that next.


FritzCT - I typed into the Command Prompt window all the commands (executing them one by one), and

rebooted as required. Then I entered the ncpa.cpl into the Start/Run box but nothing happened. I assumed

this was the Networking option in the Control Panel so I went there and found the adapter, disabled and

then enabled it, and rebooted. Loaded up Opera and was very pleased that all the effort had paid off -

pages now load OK. However, in Firefox there was still the same problem but, after a moment of

disappointment, I remembered paulshent had suggested changing the Network setting to System Proxy

Settings. It had been on No Proxy (and was presumably working previously like that) but when I put it

back to NP it still didn't work, so I changed it to Auto Detect Proxy Settings+ Proxy DNS when using

SOCKS v5 which has fixed the problem for Firefox. Phew! What an effort. I wonder what messed it all up

in the first place?


I never did get around to unloading Avast so I guess it was not the culprit. Many, many thanks to

paulshent, ferguson and FritzCT for all your help and for responding so quickly. I would never had

figured it out by myself! Thank you.


On the point of the router log, I take some reassurance from paulshent about not being hacked but I'm

still rather concerned about the entries. An "Intrusion" is still happening every10 minutes and it

appears to be coming from a different IP address each time. There is also an entry about a failed WiFi

connection but I haven't had any active WiFi devices on today; plus numerous other odd looking entries.

My concern is heightened because a few months ago I had what appears to be someone accessing my WiFi and

displaying a message on my TV screen through a Roku device (I did post about it here at the time).

Perhaps I should open a new thread about it as it is rather a different matter to the browser problem. I

don't want to ignore it in case there is something serious going on.


GeorgeTT

Highlighted
Community Star

I would now open a new thread to cover the suspected security issues

 

 

Highlighted
Team Player

Hello,

 

Oh dear! Spoke too soon yesterday. The problem is back. I had been using Opera for about an hour this morning when it crashed while viewing an eBay page. When I reloaded it I couldn't get any pages to load - " DNS address could not be found". I then tried Firefox which now has the same problem again. The K-Meleon browser is still working, as you can see.

 

I think I will try unloading Avast, as suggested by paulshent, to see whether that is in fact the cause of the problem. If that doesn't fix it, I'll try FritzCT's DNS repair again, which hopefully will restore Opera+Firefox to working order, but for how long?

 

If anyone has any further ideas of what is causing this, I would be grateful for that advice. I'll get back to the Forum once I have completed the above steps. Thanks.

 

GeorgeTT

Highlighted
Community Star

Anything is worth a try.

Out of interest what version firmware is the hg633 running.

Suspect this may be the latest V2.00

 

Also for security i would change the router admin password, also the one required to allow wifi and ethernet systems to logon to router. At the very least you may also want to rename the wifi, in case the displayed name has been targeted.

 

Might even be worth trying to get them send you another router. 

Try and get them to send you a DG8041W router and not a Sagemcom

By standards the HG633 is now old and outdated.  Still workable but old like me.

 

 

Highlighted
Problem Solver

Do a full system scan including Root Kit & Boot Time scans.

 

Also scan phones that connect to the network particulary if they are Android but not so important if IPhones unless they are jail broken or they have apps side loaded onto them.

 

Once you know your network is clean change the password to log into the router and also the wi-fi password. Make them VERY long and use upper/ lower case, numbers and special characters. Do not use real words or phrases.

 

Also turn off WPS it can be a major security risk on older equipment.

 

TBH I wouldn't be overly concerned about hiding the SSID name as it can be found in a heart beat even if hidden. It certainly wouldn't do any harm to hide it though.

 

You could always do a WHOIS look up on some of the IP addresses to see who they are.

Fritz

Highlighted
Team Player

Hello paulshent and FritzCT,


Thanks for the latest advice. I've been struggling with problem again this afternoon.


As I said this morning, I uninstalled Avast and rebooted to complete the job and found that Firefox

would now load pages but Opera still would not, even after again rebooting! I contemplated re-installing

Avast, just in case that made a difference and because I didn't want to be online without anti-virus

protection, but decided to try another AV - so, I installed AVG instead. After it had finished

installing, I could find no sign of it in the Start menu, desktop, or system tray. After another reboot,

it suddenly re-appeared and finished installing. Maybe I missed an onscreen message?! It is working now,

and so is Opera but Firefox has reverted to not loading pages. Does this make sense? As I normally only

use Opera, I think I can live with the situation for now and hope I don't tomorrow find myself back in

the position I was this morning. If the worst comes to the worst, I can try the DNS repair again and

hope that works. However, if you can find some definitive solution from all the information I've given

then that would be ideal, though I fancy it will be a matter of having to try various alternatives.


To answer the questions from this morning - HG633 Hardware version H1.01, software v.2.00t. I have

changed the Router admin and wi-fi passwords today (resetting the router yesterday put the passwords

back to the original ones, so it was necessary anyway); I had already changed these passwords back in

May when I had that odd display on my TV.


I did a rootkit and boot time scan with Avast at the weekend when all this trouble started - it found

nothing amiss. On WPS, there is a setting in the router - Wireless Network Protected Setup - which has

it switched on, "WPS by push button (PBC). Should I switch this off; if I do, will it cause me more

problems! I'll see about renaming the wifi and SSID.


As suggested, I'll start up another thread about the Router logs, what the entries mean and whether I

should be worried about what they appear to indicate is going on.


Thanks again for all your time and effort. Hopefully, I won't be revisiting this DNS problem again too

soon.


GeorgeTT

Highlighted
Problem Solver

Hi George

 

Yes, turn off WPS. You can always turn it on if you need it (and then turn it off again).

 

It may or may not be related to any issues you have but it isn't wise to leave WPS always activated.

 

I'll look out for your new thread.

 

Fritz

 

EDIT: Just to clarify these intrusion alerts are kind of secondary as @paulshent  suggested and may well be a symptom of the networking issues. The scans/WPS/ etc. are purely precautionary because the intrusion alert means that the intrusion was blocked. I'm not convinced the DNS issue is resolved so post back if it returns.

Highlighted
Community Star

I shall also keep eye on your thread.

In mean time i will have a word with my son who is a Windows / Unix security analyst.

Hope all keeps working ok.