cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Wi-Fi Hub - devices can't connect

Reply
4 REPLIES 4
Team Player

I upgraded to Faster Fibre earlier this week, which is working nicely, apart from the fact that the new Wi-Fi Hub is very tricky to stay connected to for iPhone and iPad. Both of which running the latest iOS.

 

The signal strength is full, and the password correct, but most of the time the device won't connect to wi-fi at all, and eventually when it does, it drops off after a short time.

 

Can this be solved by a change to the firmware?

 

Currently running version SG4K10002600t.

 

Wi-fi to the iMac by the way is performing perfectly (and is much further away from the hub). Just the phones / tablets that are the problem.

 

Many thanks in advance for any help.

Community Star

Hi richtea your. Post has been flagged for assistance and you should hear back on Monday. In the meantime have you split your WiFi into 2.4 and 5 GHz Split your router's SSID (wireless network name) ?

I don't work here and all my opinions are my own.
Community Star

You are running the latest firmware. Issues such as these are normally caused by some devices connecting to the router's 2.4GHz band, which can suffer tremendously from WiFi interference.

 

Before getting deeper involved in this (which I can help a lot with), you really need to find out which band (2.4GHz or 5GHz) each device is connected to. You cannot rely on the hub's device list, due to there are bugs in this causing it to misreport which band they are connected to. I do not have any experience of any Apple products so cannot tell you how to find this out. You may need to Google it. It may be simpler than that if your devices do not support the 5Ghz band.

 

Another way is to rename the 5GHz network name (SSID) on the router, by say appending 5G on the end of it. This can be done by logging into the router & going to:-

 

Dashboard > See Wi-Fi Settings > Manage Advanced Settings > Wi-Fi 5Ghz gear icon > Basic

 

Once you have established this, I can help a lot more on this issue, if you want it.

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Team Player

Thanks both. On looking into the advanced settings, I realised the 5GHz and 2.4GHz passwords were different! A slight oversight from here 🙄

 

It's working fine now. I did tweak a couple of settings as per this article too, since we're using Apple devices... but the mismatching passwords were causing the connectivity issue.

 

https://support.apple.com/en-gb/HT202068

 

Thanks again, all seems to be working fine now.

Community Team - TT Staff

Hi richtea

 

Thanks for keeping us updated. Please let us know if you do experience any further issues.

 

Debbie 🙂