cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

WiFi Hub - static IP addresses

Reply
92 REPLIES 92
CD174
Popular Poster

Just configuring the new Wi-Fi Hub. I need to assign static IP addresses to certain devices. Can't find anything obvious in the menu settings. I could do this on the old HG635. Hope you can help. Thanks.

KeithFrench
Community Star

You can't use DHCP reserved IP addresses at all. I have passed this to the developers, but I did not get a very favourable response. The only thing you can do is to assign static IP addresses on the devices themselves, which is the only way to configure a true static IP address anyway, as what most people want to do, still relies on the DHCP server.

 

You must configure:-

 

IP address, typically: 192.168.1.x

Subnet mask: 255.255.255.0

Default gateway: 192.168.1.1
DNS server: 192.168.1.1

 

Then you must exclude your chosen address(es) from the DHCP IPv4 pool start & end range. This is done at:-

 

Dashboard > See Wi-Fi Settings > Manage Advanced Settings > TalkTalk WiFi hub > DHCP

 

I will raise this with the developers again.

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
CD174
Popular Poster

Thanks Keith for your reply.

TechGuy
Popular Poster

+1 for this.

This is an essential feature that TalkTalk needs to add/restore.

Sagemcom routers normally have this option, so I guess TalkTalk either hidden or removed it. It's a rather silly idea though as you're supposed to assign a static IP address before you start port forwarding. And before someone says "assign a static IP address in Windows", that's simply not a viable solution when you use a laptop in multiple locations. You'll run into all kinds of networking issues e.g. the gateway is different or the IP address is already in use.

 

I know that TalkTalk wants to simplify the router, but when I view the "advanced settings" I expect to see the advanced settings. Like where's the option to set the DHCP lease time, the IGMP snooping options or the tab to view the firewalls log? These are normally standard features.


While I'm here I'll also mention that if you bother to set device icons then you'll notice that some of them are white instead of black. It's a minor bug, but it's a bug all the same.

TechGuy
Popular Poster

I went looking for a Sagemcom device with a similar firmware and I ended up finding the Sunrise Internet Box. It confirms that TalkTalk have dumbed down the router and removed a few necessary options.

 

  • Removed the option to assign a static IP address to a device
  • Removed the option to view DHCP leases
  • Removed the option to set the DHCP lease time
  • Removed per-device bandwidth monitoring
  • Removed all parental control options
  • Removed the tab to view the wireless environment graph
  • Removed WiFi scheduling
  • Hidden the option to restore all DHCP related changes to default
  • Hidden the option to set the LAN/DHCP network range
  • Hidden LED auto-dimming
  • Hidden Internet Utilities (ping, traceroute, DNS query)
  • Hidden TR-069 client configuration options
  • Hidden NAT mapping
  • Hidden the walled garden toggle
  • Locked the DNS server to "192.168.1.1" when it should be editable

 

There's probably a lot more that was removed or hidden, but I can't be bothered digging any further. I just hope that TalkTalk restores most of these options in a future firmware update as it'd make the hub a truly amazing piece of kit.

 

I know that most of these options existed in the TalkTalk firmware at some point in time because some of the options can still be accessed and the HTML & CSS also exposes some of the unused code.

Xmantium
First Timer

This is ridiculous that this simple feature (that ALL routers have) is not included.

If TalkTalk is reading this please bring Static IP reservation for devices!

 

I have forwarded some ports on a particular device (NAS server). Does that mean if the router changes the IP address of the device after a restart, do i to re-assign the port fowarding again?

 

 

yatznet
Team Player

i second this. static ip reservation via DCHP is important for anyone with multiple devices that uses one to access the other. if they keep jumping round the network it makes it differcult for the devices to find eachother. for example i have to mess around re-adding my printer every time my printer gets a new IP address on the network cos my laptop simply cant find it where it previously was. the same applies for the network drive stored on my secondary computer i cant access it from my primary without messing about when it changes IP. so yeah this feature is important and should be brought to the wifi hub as soon as possible.

Yatznet
KeithFrench
Community Star

I have already requested this from the developers and it has now got OCE backing, so please be patient & wait for the firmware updates when they become available.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

benny55
Wizz Kid

@yatznet wrote:

i second this. static ip reservation via DCHP is important for anyone with multiple devices that uses one to access the other. if they keep jumping round the network it makes it differcult for the devices to find eachother. for example i have to mess around re-adding my printer every time my printer gets a new IP address on the network cos my laptop simply cant find it where it previously was. the same applies for the network drive stored on my secondary computer i cant access it from my primary without messing about when it changes IP. so yeah this feature is important and should be brought to the wifi hub as soon as possible.

 

Since I installed one of these I’m having problems matching my laptop to my printer. With the DL3782 I had no problems. For now I’ve set it up as wired option.

 

Benny.


 

KeithFrench
Community Star

Hi @benny55

 

If you want help getting it back on wi-fi, I am sure I can help you. However, you will need to create your own thread & give me the address of it.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

benny55
Wizz Kid

@KeithFrench wrote:

Hi @benny55

 

If you want help getting it back on wi-fi, I am sure I can help you. However, you will need to create your own thread & give me the address of it.


Hi Keith,

 

Really appreciate your input.

As I’m a bit preoccupied with other things right now I will leave my set-up as it is. I can tolerate plugging in to my printer for what little printing I currently produce. I plan to get it resolved later and will post as a new thread on the forum where your assistance would be welcomed.   

 

As for the new Hub, I find speeds are on a par with the DL but with a superior wireless range. The only negative being the Printer Wi-Fi issue.

 

Regards,

Benny.

KeithFrench
Community Star

No problem, just drop me a PM with the address of your new thread when you create it.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

EdCorteen
First Timer

As others have said we need static IP enabling!

 

If you look at the DHCP table this starts at .10 so .2 to .9 are available to set as fixed (without changing anything)  if you can do a manual setup from your device, I set up my printer manually to be on .2

 

The only issue with this currently is that any device setup manually does not appear in the WiFi connection list!

EdCorteen
First Timer

As others have said we need static IP addresses!

 

If you look at the DHCP table, as standard, it starts at .10 so .2 to .9 adresses are available without changing anything.

 

I have manually setup my printer to be .2, the only issue with this is that my printer no longer appears in the list of connected devices.

 

So until this is fixed by new firmware all you can do is manually setup your device this cannot be done from the router.

Savas
Chatterbox

Ended up at this thread searching online in case I missed the config somewhere, but I'm surprised to find that this feature has been removed from the router.. What were they thinking....

 

It's stated that this router is worth or valued at £120.. I can already imagine the reviews on a router priced that high that doesn't even allow you to assign IP's to devices..

g1gop
Chat Champion

After reading this thread and being VERY surprised that I can't set static addresses, I went to alter the range of DHCP so I could have enough range of IP's for my servers. If I go to the DHCP page and not even alter any settings then hit apply, I get 'invalid ip address'  for the router, start address and end address!

It doesn't even like its own settings!

On Version

SG4K10001400t

So if I can't alter the range and can't set static, How do I do it?

Those who do not learn from Dilbert are doomed to repeat it
KeithFrench
Community Star

This sounds like a bug to me, try a factory default for now & I will raise this with the developers. I have already requested that the DHCP Reserved IP address facilty should be added in a future firmware release.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

mcazjoe
Conversation Starter

I also have the same problem as g1 gop with dhcp saying invalid ip address without adjusting anything, also it won't let me adjust it.

 

Is there a fix for it? 

 

I have done a factory reset but doesn't make a difference. 

KeithFrench
Community Star

I have now raised this as a bug & it has been passed over to the devices team of TalkTalk, who will deal with this.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Community Team

Hi @mcazjoe / @g1gop

 

Are you able to post or pm a screenshot to me so I can pass this along.

 

Thanks

 

Karl.