cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Wifi Hub DDNS not updating

Reply
13 REPLIES 13
ricostuart
Conversation Starter

Hi,

 

Just got the new router installed, and have put in all my noip.com ddns details into the router. It says that it is enabled, but so far it hasn't actually updated the ip. Can anyone help? Is there a way of accessing the router via ssh to test for errors?

 

Thanks,

ricostuart
Conversation Starter

Ok, so signed up to the dns-o-matic service, and set it up from there - eventually got it to work.

 

Now, I have setup upnp on the router so my server will create all the port rules as required. The server has a static IP setup on it (as the router cant yet for some reason!). But even though the ports are showing as open (using portchecker), it wont forward the ports at all (ftp, transmission, etc etc). None are working - even though TCP and UDP rules are set as required. 

 

Can anyone help?

Highlighted
Community Team

Hi,

 

@KeithFrench - Would you be able to offer any advice?

 

Thanks

 

KeithFrench
Community Star

I am confused as to high part or both you want help with. Let's assume it s the DDNS asper your subject title. Dns-o-matic is a DNS proxy, so have you configure it to use a DDNS provider on the other side of it?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

ricostuart
Conversation Starter
I got the ddns sorted by using the dns-o-matic service (rather than the noip directly that i normally use). But even with it updating my ip address, the links still wont work.

For example, I have a media server running on the network with ftp access using a specific port. This port (using portchecker) is showing up as open. the server has set the requirements to the router using upnp to which ports are needed, but I still cant access the network. I tried manually specifiying the ports on the router, but still no sucess. Finally I even tried putting the server in the DMZ but still no sucess.

The server has been configured correctly (its been running for a couple of years) and has been fully accessible via my old router.
KeithFrench
Community Star

It was confusing when you said in your subject title that the DDNS was not updating.

 

OK, in that case, the problem is most likely that you are trying to access the media server from a device locally connected to your router. The destination address you are using is the No-Ip domain or the router's WAN IP address. This causes the packet to be sent out to the internet & back into your router. This is classed as loopback traffic & all TalkTalk routers consider this a security risk & block it.

 

Try using mobile data rather than WiFi on a smartphone & it will probably work. To access the media server locally, use its 192.168.1.x address.

 

There is a lot of security issues associated with uPnP, I would always, therefore, recommend using Port Forwarding.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

ricostuart
Conversation Starter
Thanks for the reply. Unfortunatly I did try using an external network (4G as well as a seperate WiFi link) and still didnt work.
KeithFrench
Community Star

Was that using the router's WAN IP address or the No-IP domain?

 

Can you access it locally via the 192.168.1.x address?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

ricostuart
Conversation Starter

using local ip works ok, but using ddns fails using a seperate net connection

KeithFrench
Community Star

but what happens if you use the current WAN (public) IP address of the router, rather thane the DDNS domain?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

ricostuart
Conversation Starter
sorry misunderstood there - tried the wan IP too, and still fails.
KeithFrench
Community Star

OK time to put guess work out of the way & deal in facts.

 

Please can you send me screenshots of the router's port forwarding configuration that you have tried, so as I can validate that?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

ricostuart
Conversation Starter
As soon as I get home I'll get the screenshots for you. Thank you!
KeithFrench
Community Star

No rush, I probably won't have any spare time until tomorrow afternoon anyway.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they?