cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Wifi Hub not working properly

Reply
19 REPLIES 19
Mo1234
Team Player

Hi,

 

I recently upgraded from Broadband to Fibre and was sent a new Wifi Hub (Sagecom). When I set up the new router the Wifi seems to be working fine but my computer upstairs which is connected by a powerline adapter won't work at all. I can't even ping the router and Windows is saying it hasn't got a valid IP configuration. However, when I change back to my old router my computer upstairs works fine.

 

Furthermore, since switching to fibre I don't seem to be getting faster speeds than I was previously!

 

Regards

Mo1234
Team Player

I just wanted to add that I've also had several long calls with the talktalk call centre to no avail.

Sabbia
First Timer

I have been reading on this thread and I think the problem is with the router. Talktalk have not been much help at all and I logged this issue with them two days a go. They keep saying we are working with this issue but it doesn’t take this long.

Sabzi
Mo1234
Team Player

Hi Sabzi,

 

Thanks for your reply. So are many people having the same issue?

Sabbia
First Timer
Yes appears so
Sabzi
Mo1234
Team Player

Have you managed to get a response from them yet? Do you think its something to do with the firmware? I think I am on 2600t but I think that is the latest one.

Community Team

Hi

 

Are the powerline adapters the wired type or the wifi extender type ?

 

Have you tried resetting the adapters and connecting them to the new router ?

 

Thanks

 

Karl. 

Mo1234
Team Player

Thank you for your response.

 

The Adapters are the Ethernet type and I have rest the multiple times. As I said previously whenever I connect the old router it all works fine but the new router seems to be the weak link. Maybe there needs to be a firmware update or something?

Community Team

Hi

 

Have you tried the other ethernet ports on the back of the router ?

 

I can understand a poor wifi signal with the wifi type adapters but with a cabled connection, these should see the connection as any other wired device.

 

Thanks

 

Karl. 

Mo1234
Team Player

The other Ethernet port makes no difference either.

Mannh
Conversation Starter

I had to connect mine directly to my laptop and st it up from there. Have a look on the extenders website. 

Mo1234
Team Player

Thanks @Mannh . I tried that but no luck still unfortunately.

Mannh
Conversation Starter

Oh well, worth a shot. 

Community Team

Hi Mo1234

 

I can send a replacement router for testing, would you like me to arrange this?

 

Thanks

 

Debbie

Mo1234
Team Player

Hi Debbie,

 

Thanks for the offer, but I'm not sure if a new router sill solve the problem. Would it be possible to send powerline adapters for testing instead?

Community Team

Hi Mo1234

 

Did you purchase the power line adapters from TalkTalk previously?

 

Thanks

 

Debbie

Mo1234
Team Player

The ones I am currently using do not have any talktalk branding on them.

Community Team

Hi Mo1234

 

If they were not sent by TalkTalk then we would be unable to replace this.

 

Did you order them from our online store?

 

Thanks

 

Debbie

Mo1234
Team Player

I don't think they were from the online store.

Community Team

Hi Mo1234

 

If they were not sent by TalkTalk then we would be unable to replace this.

 

Thanks

 

Debbie