cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Wifi speed drop, hanging and loosing connection to devices

Reply
24 REPLIES 24
bootgaz231080
Participant

For a period of time we have been having a mixture of problems outlined below.

 

1 - Random internet disconnections with the white light turning orange and then taking a long time to connect. 

2 - Random episodes where the internet appears to be connected (white light on) but for some reason the internet doesn’t work and seems to hang and slow down.

 

3 - Devices being kicked off the wifi and then being asked for the password again even though they were just on the wifi.

 

The hanging of the internet seems for be for both wired and wifi. Today I did a speed test using an app and we were over 46mb which is great. At around 10:15pm this evening the internet seem to hang, I ran a speed test and we were down to something like 5mb. This is incredibly frustrating as nothing has changed.

 

we are currently using a mesh system with this acting as a bridge and the wifi turned off on the talk talk router, however we were having these issues prior to getting a mesh system.

 

I also have a switch connected with numerous wired devices. 

any help would be appreciated in trying to solve some of these issues.

bootgaz231080
Participant

Woke up this morning and speeds all over the place. 16mb, then 9mb, 2mb,7mb, 8mb and then back up to 42mb. These are all download speeds. 

what on Earth is going on, extremely frustrating.

Skynet_TX
Community Star

Hi @bootgaz231080,

 

For one of the TalkTalk staff on this community to be able to look into this you will need to update your community profile to include your name, landline telephone number that your TalkTalk service is provided on & an alternative contact number. This will allow them to identify you, and they will then be able to help.

 

Don't post any personal details in this thread, just add them to your community profile.

 

Then they will hopefully be able to respond to this post within a working day or two.

bootgaz231080
Participant
Thanks now added details
OCE_Michelle
Community Team - TT Staff

Morning,

 

I'm sorry to hear this. I've completed a line test now which hasn't detected a fault, however I can see re-connections on the line. Do you have an alternative router that you can test with?

 

Thanks

 

bootgaz231080
Participant

Hi

 

no we don’t have an alternative router.

OCE_Debbie
Community Team - TT Staff

Hi bootgaz231080

 

I have ordered a different router for testing, please allow 24-48hrs for this to arrive.

 

Let us know how the connection compares with this router.

 

Thanks

 

Debbie

bootgaz231080
Participant

Many thanks will test it when it arrives.

OCE_Debbie
Community Team - TT Staff
bootgaz231080
Participant

Router plugged in and wifi speeds still seem a bit slow and up and down. Is the router yous ent me the latest and fastest one. The model seems different to our previous one which states fast on the back.

Skynet_TX
Community Star

There are two different makes of router that physically look very similar, the Sagemcom (which has the bronze colour behind the holes on the front) and the Huawei (that is all black), both routers are the 'latest' hubs, and both are capable of the same speeds.

 

If you are switching between different models of router it would be advisable to switch the router off for over 30 minutes, then when you switch it on it will start a new session in the street cabinet. This will ensure your new router creates a new session that is appropriate for its configuration, rather than trying to reuse a old session that was created by a different model of router.

OCE_Michelle
Community Team - TT Staff

Hi,

 

What speeds are you currently seeing at the moment?

 

Thanks

 

bootgaz231080
Participant
Just run a test and it’s around 15 download, and 8 upload. Although when I login into the hub it says 56mb download. It just seems throughout the day the speeds can be erratic and also it feels like the internet doesn’t disconnect but hangs sometimes.
OCE_Michelle
Community Team - TT Staff

Morning,

 

Thanks for confirming. I've re-checked the connection stats now and the sync speed now looks consistent. Can I just confirm, were the recent speed tests wired or wireless?

 

Thanks

 

bootgaz231080
Participant
Recent speed test was using an app called Speedtest via my phone.
OCE_Michelle
Community Team - TT Staff

Hi,

 

Ok thanks for confirming. Would it be possible to run a few wired speed tests using the TalkTalk Speed Tester so we can confirm if this is related to the wireless connection? We can then offer more advice following this.

 

Thanks

 

bootgaz231080
Participant
I have tried some wired tests and speeds seem consistent at over 40mb download and 8.5 upload. This suggests to me that the router is just pretty poor at keeping wifi speeds consistent. I don’t have a big house and don’t see why I should have to buy a better third party router.
OCE_Michelle
Community Team - TT Staff

Morning,

 

Thanks for trying this and we can now focus on the wireless connection.

 

How far away is the router from the devices? Have you tried a few different wireless channels?

 

Thanks

 

bootgaz231080
Participant
The devices are close to the router. I currently have the wifi turned off as I am using a nova mesh system. Using the wifi speed test the Speeds just seem erratic. One mine it’s up at over 40mb and then 5 mins later in the same position down at 15 or even lower. I would just say I have over 25 devices connected. Could it be that the router can’t cope?
bootgaz231080
Participant

Having real issues this evening. Speed on wifi is currently at 1mb download. Any suggestions would be appreciated as I have never had these issues before with sky so very frustrated.