FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

5ghz WiFi problems with Huawei router

Supermansam
Popular Poster
Message 16 of 16

Hi,

 

I have recently joined TalkTalk from BT. The BT Smart hub was faultless and I could connect to the separated 2.4ghz and 5ghz bands at will the full coverage of my home, including a smartplug in the garage.

I now have a TalkTalk Huawei DG8041W router in the same location. The bands have been separated and I have used WifiAnalyzer to find the least congested channels. 2.4ghz seems fine, but doesn't reach the smart plug in the garage which my previous BT router could. My Win 10 desktop upstairs connects to 5ghz, but with less signal strength than the BT router. All closer devices connect fine on either band, except for my two gaming laptops.

The laptops are both Win 10 and from different manufacturers. They both use up to date Intel drivers from Intel's website. They both worked faultlessly on 5ghz with the BT router. However, they will not connect to the 5ghz of the TalkTalk router no matter what I do. I have tried changing the channels (band A 36-48 and also tried above) and I have tried changing the channel width from Auto 20/ 40/ 80 all the way down to 20 and in between. I have tried reboots, reinstalling drivers etc but no success. The laptops just won't connect to the 5ghz band. They connect fine on 2.4ghz, but being gaming laptops, I need the speed of the 5ghz band. There are no sources of interference in between (same room, no cordless phones, mirrors, walls etc) and as I stated, they worked perfectly with my old router (and still do when I tried again with the old router - but obviously with no internet).

Can anyone advise how to get the laptops to connect to this router? Do I have a faulty one? Is there a different model that works better on 5ghz?

Many thanks in advance for your time and advice.

 

0 Likes
15 REPLIES 15

Message 1 of 16

Hi Supermansam

 

I'm really sorry for the delay.

 

The WIFI optimisation has now been switched off, please let us know how the connection compares.

 

Thanks

 

Debbie

0 Likes

Message 2 of 16

Hi Karl,

 

Thanks for sending out a Sagemcom router. I split the SSID to 2.4ghz and 5ghz and can confirm that the laptops connected instantly to the 5ghz band.

 

The only issue I have now is that when I change the channels to the best ones for my setup, the channels change back to ones determined by the router sometime later (overnight?). I read that there is something you control on my account that overrides this (line optimisation?).

Could you turn this off for me so that I can take control of the channels? Many thanks.

One other thing, I did not receive a returns envelope for the faulty router.

0 Likes

Message 3 of 16

Hi

 

a router is on the way and a returns bag for the other router.

 

Thanks  

 

Karl. 

Check & Report l Our latest Blog l Set Your Preferences l Service Status l Help with your Service l Community Stars

Working From Home Tips


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


WEAR A MASK      -      WASH YOUR HANDS      -      SOCIAL DISTANCE

Message 4 of 16

They will get to you.  Save your money and wait.

 

Don't repost on your thread until an OCE get back to you. Otherwise it will move lower on the queue.

 

Cheers

 

0 Likes

Message 5 of 16

Hi Keith,

 

Did you get a chance to ask TalkTalk to replace my router?

Is it just a case of waiting until someone gets around to seeing this thread?

I'm thinking about buying a new router if it will be a long wait.

 

Many thanks for your time.

0 Likes

Supermansam
Popular Poster
Message 6 of 16

Hopefully won't be too long before an OCE has a look at this... Hoping to get this resolved on the weekend if possible 🤞

0 Likes

Message 7 of 16

Hi.

Looks like 5ghz is faulty

Will let the OCE's decide on course of action on Monday onwards.

 

0 Likes

Message 8 of 16

Hi

 

Thanks for your input, Paul.

Both the 2.4 and 5ghz bands are set at full speed.

Auth mode is set to WPA2, PreSharedKey and AES.

I have tried TKIP etc but with no success. My network adapters on the laptops support the router's settings and are both recent with up to date drivers. The settings were the same on my old BT router and on that both laptops worked fine on 5ghz.

I'm hoping that it is a problem with the router since once that is replaced it should work. If it doesn't then I'm stuck without a solution that I can think of, other than using my TalkTalk router as a modem and return to my old BT router.

0 Likes

Message 9 of 16

I have the DG8041 and have no issues with the 5Ghz band or it's strength

Logon to router via admin account.  pwd on rear of router.

Select the wifi settings and see if band 1 2Ghz is running at 450Mbps  and Band2  5Ghz at 1732Mbps.  If so it's ok so far.

Have a look at the WLAN menu

Have a look at Auth Mode, and it should be set to WPA2 PreSharedKey

WPA PreShared key should have same password that wifi systems use to connect with router.

You may want to try via the drop down menu under Auth mode to something other than what it is set to. Make sure the windows system is using the same Auth mode.

If it still does not connect on 5Ghz then router is the problem

 

0 Likes

Message 10 of 16

Hi

 

Thanks for looking over it. I'm familiar with networking to a degree but I couldn't find anything in the router settings or the network adapter settings to indicate a problem or incompatibility.

Please request a replacement router for me and I will give this is try.

Many thanks again for your input.

 

 

 

 

 

 

0 Likes

Message 11 of 16

Well, other than the fact you are not connected I can't see anything obvious. All I can suggest then is for me to ask TalkTalk if they will consider swapping your router out.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 12 of 16

Hi

 

Here are the details you requested:

 

netsh wlan show drivers

Interface name: WiFi

Driver : Intel(R) Wireless-AC 9560 160MHz
Vendor : Intel Corporation
Provider : Intel
Date : 30/11/2020
Version : 22.20.0.6
INF file : oem333.inf
Type : Native Wi-Fi Driver
Radio types supported : 802.11b 802.11g 802.11n 802.11a 802.11ac
FIPS 140-2 mode supported : Yes
802.11w Management Frame Protection supported : Yes
Hosted network supported : No
Authentication and cipher supported in infrastructure mode:
Open None
Open WEP-40bit
Open WEP-104bit
Open WEP
WPA-Enterprise TKIP
WPA-Enterprise CCMP
WPA-Personal TKIP
WPA-Personal CCMP
WPA2-Enterprise TKIP
WPA2-Enterprise CCMP
WPA2-Personal TKIP
WPA2-Personal CCMP
Open Vendor defined
WPA3-Personal CCMP
Vendor defined Vendor defined
WPA3-Enterprise GCMP-256
OWE CCMP
IHV service present : Yes
IHV adapter OUI : [00 00 00], type: [00]
IHV extensibility DLL path: C:\WINDOWS\system32\IntelIHVRouter08.dll
IHV UI extensibility ClSID: {00000000-0000-0000-0000-000000000000}
IHV diagnostics CLSID : {00000000-0000-0000-0000-000000000000}
Wireless Display Supported: Yes (Graphics Driver: Yes, Wi-Fi Driver: Yes)


netsh wlan show interface

There is 1 interface on the system:

Name : WiFi
Description : Intel(R) Wireless-AC 9560 160MHz
GUID : ee7e69b3-2a71-434e-9414-5fdae6b28dfd
Physical address : 98:af:65:3a:0e:67
State : disconnected
Radio status : Hardware On
Software On

Hosted network status : Not available

 

netsh wlan show networks mode=ssid

Interface name : WiFi
There are 12 networks currently visible.

SSID 1 : healyboy
Network type : Infrastructure
Authentication : WPA2-Personal
Encryption : CCMP

SSID 2 : SKYZN4GX_Ext
Network type : Infrastructure
Authentication : WPA2-Personal
Encryption : CCMP

SSID 3 :
Network type : Infrastructure
Authentication : WPA2-Personal
Encryption : CCMP

SSID 4 : SKY05B59
Network type : Infrastructure
Authentication : WPA2-Personal
Encryption : CCMP

SSID 5 : Speaker.o
Network type : Infrastructure
Authentication : Open
Encryption : None

SSID 6 : SKY0A497
Network type : Infrastructure
Authentication : WPA2-Personal
Encryption : CCMP

SSID 7 : EE-Hub-oD9M
Network type : Infrastructure
Authentication : WPA2-Personal
Encryption : CCMP

SSID 8 : PLUSNET-GP2S
Network type : Infrastructure
Authentication : WPA2-Personal
Encryption : CCMP

SSID 9 : BTWi-fi
Network type : Infrastructure
Authentication : Open
Encryption : None

SSID 10 : BT-3GAHWQ
Network type : Infrastructure
Authentication : WPA2-Personal
Encryption : CCMP

SSID 11 : TALKTALK9BBDDC24G
Network type : Infrastructure
Authentication : WPA2-Personal
Encryption : CCMP

SSID 12 : TALKTALK9BBDDC5G
Network type : Infrastructure
Authentication : WPA2-Personal
Encryption : CCMP

 

I'm the last 2 SSIDs.

 

Many thanks again for you time and input.

0 Likes

Message 13 of 16

Yes, you may not have PMs enabled if you are new.

 

If they are close to the problem areas, then the cause is not the router's WiFi.

 

Please open a command prompt window (assuming a Windows OS) by going to:-

 

Start > Accessories > Command Prompt

 

In Windows 10, click the Window Icon & type in the search box:-

 

cmd

 

in the search box next to it. This should find the "Command Prompt" from there.

 

Please enter these commands one at a time, pressing enter after each one and wait for the response. Then copy and paste the output from each into your reply.

 

netsh wlan show drivers
netsh wlan show interface
netsh wlan show networks mode=bssid

 

Note I will need to know the names of your wireless networks.

 

Thanks.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 14 of 16

Hi.

Thanks for the reply.

I can't PM you - I don't see an option for this. Maybe because I'm new?

I have attached some pictures to this post.

Thanks for your input. The laptops have a Qualcomm Atheros chip in one and an Intel AC 9560 chip in the other.

I hope there's an easy fix🤞

20210206_193535.jpg

20210206_193421.jpg

 

 

 

 

 

 

 

 

 

 

 

 

 

 

0 Likes

KeithFrench
Community Star
Message 15 of 16

Can you provide me with screenshots of all of the views from WiFi Analyser, close to the problem areas. You can PM them to me if you prefer, then I can see if I can detect a problem. Please make sure that when using the Insert Photos/Images button on the toolbar to do this, you set the size setting to large.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes