FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Asus DSL-AC88U setup help

Warfather
Popular Poster
Message 6 of 6

I just bought the Asus dsl-ac88u modem router today to replace my existing Huawei MT992 modem and separate router and combine into one unit.

 

The Asus DSL-AC88U modem/router is g.fast compatible so there shouldn't be any issues.... But here I am. 

 

I have attached images of my settings but I'm not sure where I am going wrong. My dsl connection is being detected but I have no connection.

 

It works as a router only when connected to the Huawei modem but that defeats the point of the upgrade. I've already updated to the latest firmware.

 

People have already confirmed on here they have had it working but I can't find specific settings. I've also reached out to Asus directly and am waiting for a response. 

 

Can someone advise?

 

https://i.imgur.com/WS38DQ0.jpg

https://i.imgur.com/2U6Or5B.jpg

https://i.imgur.com/qB09X0N.jpg

https://i.imgur.com/PvbLoo0.jpg 

0 Likes
5 REPLIES 5

ferguson
Community Star
Message 1 of 6

That's great to see and thanks for sharing.  🙂

Warfather
Popular Poster
Message 2 of 6

Fixed it. I deleted my PVC setting, restarted my router then created a new PVC setting with the exact same information and suddenly it connects straight away lol.

 

I have attached images of my working settings if anyone else comes across these problems in the future since the information available is pretty scarce. The settings for Talktalk prebuilt on the router did not work with g.fast using the 5C mastersocket to avoid the Huawei MT992 modem, I entered them all manually myself.

 

Please note, you have to manually select g.fast as shown in the images or you wont get anything show up at all. This has to be done after you get through the automatic setup wizard.

 

Spoiler
PVC Settings on WAN Settings pagePVC Settings on WAN Settings pageHow to access g.fast switch settingHow to access g.fast switch setting

Warfather
Popular Poster
Message 3 of 6

Another update, I asked for help elsewhere too and they pretty much just said it should be PPPoE not automatic IP.

 

The problem is if I put PPPoE then I need a username and password, which talktalk said there isn't one.

 

PXL_20210702_123834108.jpg

0 Likes

Warfather
Popular Poster
Message 4 of 6

Hi,

 

Thanks for the quick response. I switched to auto DNS and its still not working.

 

I tried the wizard that's built in too since I posted and used the inbuilt Talktalk settings (auto ip address version) and the wizard just stalls when trying to check the connection. The only other talktalk option is PPPoE but that one requires a username and password so I assume that's for regular broadband, not fibre. It won't let me go further with a blank username and password.

 

Edit: I was just greeted with this screen whilst testing it.

 

https://i.imgur.com/ZsnuvoN.jpg 

0 Likes

ferguson
Community Star
Message 5 of 6

OK, it looks like you're connected on the WAN side, so the modem is working. Try AUTO DNS on the router side and see if that gets you on to the internet, then you can try to adjust to servers of your choice from there.