FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Change IP Addressing Scheme

maharishi
Participant
Message 8 of 8

Hi Guys,

 

I'm trying to change the addressing scheme on my LAN. For this to work I need to be able to change the IP address of the router from the default of 192.168.1.1

 

I have gone into the router menu's (Sagem with firmware: SG4K10002808t) and changed the address of the router to 10.0.0.1 with a subnet mask of 255.255.255.0 and DHCP disabled as I have my own DHCP server.

 

However on the device info page the 'Local subnet mask' field is blank and I can't get out to the internet.

 

Anything I should be doing differently or any extra steps I need to take?

0 Likes
7 REPLIES 7

Message 1 of 8
Hi Keith,

Thanks for your help. The problem turned out to be a setting I had misconfigured when moving my pi-hole to the new subnet.
0 Likes

Message 2 of 8

I'd ignore what the router says about the subnet mask, check on the actual devices, have they been allocated:-

 

Valid IP address

Correct subnet mask

Correct Default Gateway

Correct DNS Server address

 

 

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 3 of 8

Just to clarify my settings i've taken some screenshots - https://imgur.com/a/FcIcqvF

 

As you can see on the network information the subnet mask is blank.

 

If i restore the default IP address of the router it shows the subnet mask of 255.255.255.0

If I enable DHCP then the subnet mask is also shown.

 

As soon as I change the IP and disable DHCP. No subnet mask is listed.

 

Not sure if this is expected behaviour or indeed the cause of my issues. But seems likely?

 

(The screenshots also show a different IP to the one I mentioned in my original comment of 10.0.0.1 - i've been trying a few different addresses.)

0 Likes

Message 4 of 8
Yup the DHCP server is configured correctly with the new ip of the router.
0 Likes

Message 5 of 8

Of course I remember now, you are using your own DHCP server. Have you configured the router's new IP address in there?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 6 of 8
Thanks for responding Keith.

To reply to your points:

1. There weren't any reserved DHCP addresses.
2. I'm guessing this is done in the DNS (Static DNS Server Configuration) tab? I can't currently enable this it's set to OFF.
0 Likes

KeithFrench
Community Star
Message 7 of 8

This is the best method to do this:-

 

  1. Remove any DHCP Reserved IP addresses

  2. Change the DNS address handed out by DHCP

  3. Change the router’s IP address & DHCP IPv4 Pool Start & End ranges to match.

Then disconnect & reconnect each device to force it to get a new IP address on network 10.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes