FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Connect a NAS drive to Talktalk Router

hazzafresh
First Timer
Message 24 of 24

Trying to connect a D-Link DIR-685 to my Talktalk Router but it doesn't seem to recognise that it is connected to it.

I tried connecting it to another EE router and it works with that.

I just want to have a drive on the same network as my router using FTP/SMB

 

The D-Link, it doesn't even acknowledge that it is connected to anything at all.

 

Any help would be appreciated

(I do know a bit about networking and have a degree in Computer Science, not that it's doing me any favours here 😂 )

0 Likes
23 REPLIES 23

KeithFrench
Community Star
Message 1 of 24

I have already suggested this @martswain, but thanks for your input anyway. 

 

@hazzafresh when you connect a router to a device a straight ethernet cable is what you need. A few years back if you try to connect either two devices together or two routers together, you needed a data cross over ethernet cable, otherwise, the Ethernet link will not come up. Most devices these days negotiate this on connection, making life so much easier. The Sagemcom supports it, but I have no idea about your D-Link, as it is pretty old.

 

If the ports on the Sagemcom are fine as you tell me & the cable is fine, then I am afraid it is over to you to prove that the Ethernet port on your router is fine and you may have to contact D-Link's support to find out about cable type negotiation & their router.

 

You would make your life a lot easier if you used a proper NAS.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

martswain
Philosopher
Message 2 of 24

Try setting the DLINK's IP address to 192.168.1.2 and then connecting them LAN to LAN.

 

The current IP address of 192.168.0.1 looks wrong to me, I am sure @KeithFrench will correct me if I am wrong.

 

You may have to disable DHCP on the DLINK too.

0 Likes

Message 3 of 24

Sorry but I'm not sure what cable type negotiation is.

 

It's just so annoying because it all worked the way I wanted it when trying it with that EE router. If you had to guess, what would cause it not to work anymore when plugging it into Talktalk?

0 Likes

KeithFrench
Community Star
Message 4 of 24

You have said that the ports on the Sagemcom are fine and that the cable is OK. So the balance of probability points towards the D-Link based on this.

 

Do the LAN ports on the D-Link support cable type negotiation, if not you might have to make up a data crossover ethernet cable. This all assumes of course that the LAN port on the D-Link is OK.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 5 of 24

This router can be used as an FTP Server. All I really want to use it for is a DLNA server for movies, so its not critical to be used outside my network anyway.

So what is the reason that the two routers aren't talking to each other?

0 Likes

KeithFrench
Community Star
Message 6 of 24

Then in that case you really need to consider if this is even worthwhile pursuing.

 

The SMB or SAMBA protocol is not routable which means it will work on your local LAN, but it cannot work over the internet. SAMBA V1 is very insecure & should never be used anymore, you should ideally use V3. Most devices such as Windows PCs do not have SAMBA V1 installed, due to its vulnerabilities. I suspect that due to the age of the D-Link, SAMBA V1 is all it supports. Can it even work as an FTP Server (which I would be very surprised if it did)?

 

What I would urge you to do is to share a hard drive in a Windows/Linux PC & forget all about this old D-Link router altogether, or even get yourself an actual NAS. 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 7 of 24

You got it, I've been calling the internal HDD of the D-Link a NAS.

0 Likes

KeithFrench
Community Star
Message 8 of 24

I said in my previous reply, all of this is done on your D-Link. Also please answer my question about the NAS how does this connect or are you just calling the internal HDD of the D-Link a NAS?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 9 of 24

Sorry for any confusion,

The DLink is a storage router which has a HDD built-in. This is connected via LAN ports to Talktalk via ethernet cable.

 

Knowing this, on what router am I setting up a default gateway address and DNS server?

0 Likes

KeithFrench
Community Star
Message 10 of 24

You are totally confusing me now, I thought that the D-Link was the NAS, not another router. How are these physically connected, by an Ethernet LAN IP cable? You now have the D-link & the Sagemcom on totally different IP networks.

 

If you want them on the same one, without knowledge of this particular router, I would change the router's LAN IP address on the D-Link to 192.168.1.2 (assuming that this IP address is not used elsewhere. Then you may need to set up a default gateway address in the router (this may not be available unless it is in bridged mode - is that possible) and a DNS server, all of which need to be set to 192.168.1.1. You must also disable the DHCP server on the D-Link.

 

Now to this NAS - how does this connect & to which router?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 11 of 24

I've reset the DLink. Below are the default network settings for it. (it is not in access point mode now. This is only viewable by connecting to it's own wifi; I want to end up with 1 wifi network ideally)

Screenshot 2022-05-10 at 3.20.55 pm.png

 

The Talktalk settings:

Screenshot 2022-05-10 at 3.16.08 pm.png

Screenshot 2022-05-10 at 3.16.18 pm.png

  

0 Likes

KeithFrench
Community Star
Message 12 of 24

What firmware is the Sagemcom running? My previous steps in post #9 were probably from V2816, whereas in V130 or V136 one of the tabs has been renamed. In this case please go to:-

 

Dashboard > See Wi-Fi Settings > Manage Advanced Settings > TalkTalk Wi-Fi hub > LAN IPv4

 

and:-

 

Dashboard > See Wi-Fi Settings > Manage Advanced Settings > TalkTalk Wi-Fi Hub > DNS

 

 

Yes, if you can do a factory reset on the NAS that would be helpful, especially if you have cut yourself off from any management of it.

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 13 of 24

Hopefully this picture helps. Yes the NAS is in Access Point mode

As for the settings for the NAS I have no idea. Do you think it would be easier to reset it and start from scratch?

Screenshot 2022-05-10 at 2.53.20 pm.png

0 Likes

KeithFrench
Community Star
Message 14 of 24

Those are the WAN IP config pages, not the LAN ones that I requested. Please can you get those as per my last post?

 

So the NAS has two network interfaces, does it? I assume that you using the one with the 192.168.1.2 address? If so, can you remember what you put in for the subnet mask, default gateway & DNS server addresses? When connected to the EE router was this NAS in access point mode? 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 15 of 24

I've redacted the public IP address, not sure if this will be an issue.

I can't access the NAS after putting it in access point mode (if I could, there wouldn't be an issue) but from the screen I can tell one IP is 192.168.1.2 and another says 0.0.0.0

Screenshot 2022-05-10 at 1.15.31 pm.jpg

Screenshot 2022-05-10 at 1.16.40 pm.png

0 Likes

KeithFrench
Community Star
Message 16 of 24

OK, thanks. Please can you get me a screenshot of the network configuration on the NAS, plus these screenshots from the router:-

 

Dashboard > See Wi-Fi Settings > Manage Advanced Settings > TalkTalk Wi-Fi hub > DHCP

 

and:-

 

Dashboard > See Wi-Fi Settings > Manage Advanced Settings > TalkTalk Wi-Fi Hub > DNS

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 17 of 24

All ports work, I have a Philips hue plugged in to Talktalk Router and everything was fully functional when connecting to the EE router via LAN ports (using the same cable).

Before I got it to work in the EE router, I changed the IP of the NAS to work with the subnet mask? I tried the same on Talktalk but nothing changed, even after a reboot.

0 Likes

KeithFrench
Community Star
Message 18 of 24

If there is no connection, then you obviously won't have an IP address. You say that you have tried other ports on the router, is there anything wrong with the Ethernet port on the NAS as far as you know - will it come up when connected to a LAN port on your EE router? Have you tried another cable?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 19 of 24

On the Talktalk Router admin page, it doesn't show that anything is connected to that port (I have tried other ports).

The D-Link has a screen built in, and it doesn't show that it is connected to anything either.

It also hasn't been assigned an IP address from the router

0 Likes

KeithFrench
Community Star
Message 20 of 24

OK, so I assume that the connection is showing as UP OK on the Ethernet? Has it been allocated an IP address by the router & can you ping that address from another device locally on your LAN/WiFi?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes