FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Connection well below guaranteed speed (and Wi-Fi Hub Firmware)

OrangeBucket
Conversation Starter
Message 46 of 46

An unexpected side effect of my opting out of the TalkTalkTV £4 thing is that I received an e-mail indicating a WiFi hub was on the way. As the 2.4GHz WiFi on my HG633 sucked beyond belief this was pleasing to see. I thought it might be a glitch but if so it was the nice sort of glitch as it arrived today. It has already given me a good laugh when it prompted me to type the WPA2 passphrase in teeny tiny boxes with the characters masked so I couldn't see what I was doing, even though once you've saved it the passphrase is displayed in full view in plaintext. So before I do anything else, may I ask if the firmware will automatically update (this may become self-evident) or if it needs a nudge, as I believe there must be a newer one to correct some of the deficiencies like the lack of IP reservations and making you click through 30+ pages of logs to see the latest entry.

Now the meat in my sandwich is that I am supposed to have a guaranteed 28Mb/s minimum speed and once upon a time I did indeed have that. Indeed on a wired connection I'd get 35Mb/s (the WiFi was relatively pathetic though). As time has passed this has crept lower and lower and now I max out somewhere around 20 to 22Mb/s and have done for a few months now. As even the 'My Connection' thingy in My Account now suggests this needs sorting, here I am.

Removing a wired in phone extension improved things very slightly for just a few hours, using a microfilter in the 'test' socket instead of the prefilter made no difference, and I can't say the phone line is noisy. I did wonder if constantly battling the router (one can't always be offline for twenty minutes) had made the line look like it was misbehaving and it just needs to start from scratch again.

I'm not really up to speed with the line stats. In fact the only one I've always felt seemed quite high was the interleaving. I remember an indignant poster on here complaining that his interleaving was about 8 or 9 as if that was disgraceful, and there I was with a figure of about 2700.

So if it could be looked at that would be great. My profile is already set up with the appropriate details.

Thanks,

Graham.

0 Likes
45 REPLIES 45

Message 41 of 46

Hi Graham

 

Thank you 🙂

 

Please can you post back on this thread on Monday morning and I can check the connection stats again.

 

Thanks

 

Debbie

0 Likes

Message 42 of 46

Thanks for the update, that should be a game changer in itself.

 

The router is now on the test socket so the disconnection at 10:45am-ish was me switching things over.

 

Graham

0 Likes

Message 43 of 46

Hi Graham

 

Thanks for your reply.

 

I've updated your router firmware version.

 

Please can you leave the router connected at the test socket over the weekend without rebooting. We then check the connection stats again on Monday.

 

Thanks

 

Debbie

0 Likes

Message 44 of 46

The old router (HG633) did have more than its fair share of abrupt reboots in the past because it regularly misbehaved so badly that switching the thing on and off was the only way to quickly restore sanity and waiting around for twenty minutes so it looked controlled wasn't an option. More recently (long after the speed drop) I developed the calmer approach of just toggling the 2.4GHz WiFi on and off instead as that was usually (but not exclusively) the problem. Indeed i largely gave up using my Windows 10 laptop on WiFi because it would last about two minutes before deciding there was no internet connection (even though the rest of the devices in the house disagreed) and a disconnect/reconnect cleared the issue.

 

The WiFi hub arrived yesterday and it did get unplugged from the line a few times as I was testing if it behaved any differently on the test socket and with or without phones connected. So yesterday would have been a bit frantic for disconnections.

Although I may have had the odd unexpected disconnection here or there they will have been so few and far between I can't place any significance on them. Generally speaking any disconnections have been caused by my moving my internal phone wiring around or rebooting the router because it was playing up so badly.

I would say the download speed probably dropped in two phases. Firstly from 35Mb/s-ish to 28Mb/s-ish, and then down to about 22Mb/s-ish.

 

What about my side issue of the WiFi hub firmware being out of date? That is driving me nuts.

 

G.

0 Likes

Debbie-TalkTalk
Support Team
Message 45 of 46

Hi Graham

 

I'm sorry to hear this.

 

I've completed a line test which hasn't detected any faults but I can see re connections on the line.

 

Is the connection dropping or has the router been rebooted?

 

Thanks

 

Debbie

0 Likes