FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Custom DNS / Split DNS

Quin452
Chatterbox
Message 6 of 6

Okay, so I mentioned in another post on here about Loopback/Hairpin/NAT Reflection.

 

Two solutions were given to me; either host a DNS server, or get a new router which supports Loopback (and they're expensive).

 

So, I am looking into hosting a DNS server for internal use.
However, I am having trouble with the router (Sagemcom FAST 5364).  Not only is the UI not intuitive, but the settings do not seem to take, at all.

 

On another post, one recommendation was a factory reset (which I've done) but that resolves nothing.

 

So, how can I set a custom DNS, rather than relying one provided by the router/TalkTalk?
I've tried it under "Internet Connectivity" and it defaults to Obtain DNS Automatically after saving.  If I do change it, breaks my internet connection.

 

I've also tried under Static DNS Server Configuration; nothing happens.

 

Sidenote: this router was supplied with my Business plan (which definately isn't up to snuff) and I've phoned and email Business Tech Support multiple times, and they haven't got a clue (their own words).

I run a web development company, and have several self-hosted servers.  Not being able to access these servers internally properly is a major inconvenience.

0 Likes
5 REPLIES 5

KeithFrench
Community Star
Message 1 of 6

OK, it was just a thought.

 

If TTB cannot supply you with a suitable router, then you will have to consider a 3rd party router. Just make sure that its inbuilt modem is fully compatible with the TTB network.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

Message 2 of 6

Hi Keith
That's not going to work.

I also work remotely, which where the external DNS comes into play and works well, and where loopback is the issue.

I use git, so switching that with a local IP to remote URL will be a nightmare when I just want to work.
I also host staging sites locally on a hypervisor, so I cannot really access a test site using the IP when it's meant to reflect a production site (i.e. using the URL).

0 Likes

KeithFrench
Community Star
Message 3 of 6

You don't need NAT loopback anyway. Just target the device from a device locally connected to your router via its 192.168.x.x IP address.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 4 of 6

When I spoke to support, they said that none of the routers will allow loopback because they're "generic" routers.
They don't even support bridge mode (and I have an LTE router which can do everything I need, just no DSL).

So a different router would maybe allow to change the DNS?

0 Likes

Karl-TalkTalk
Support Team
Message 5 of 6

 Hi

 

You could request that the business teams send a different model router to see if that will help.

 

Thanks  

 

Karl.

Check & Report l Our latest Blog l Set Your Preferences l Service Status l Help with your Service l Community Stars

Working From Home Tips


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


WEAR A MASK      -      WASH YOUR HANDS      -      SOCIAL DISTANCE

0 Likes