FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

DHCP failure on router

Amoeb
First Timer
Message 13 of 13

Hi,

I have a problem with my network setup and hopefully I can get some help here. I've already discussed with support team and their current solution is to have an engineer visit in 2 weeks. I still think the issue can be solved remotely and sooner, I just can't pinpoint the problem.

I had a stable setup for a couple of years with own modem + router. Suddenly Saturday everything stopped and my router cannot get an IP, being stuck in a lease renew loop.

I replaced the modem with the TalkTalk provided one (DG8041W), just set the IP address (192.168.1.1) and subnet mask, disabled DHCP (as that is active on my router) and problem remains the same. Router Asus RT-AC68U has the same message: "Your ISP's DHCP does not function properly". I have the latest firmware version on the router, tried factory reset and nothing. WAN connection type is set to "Automatic IP". I replaced even the router with another model, set it up with LAN IP (192.168.1.100) and automatic WAN IP and I get the same error, I cannot get a WAN IP on the router.
Everything seems to work if I use the TalkTalk as router also (DHCP server+WiFi). In this case of course, my own router remains out of the loop.
I have seen other users on the forum with similar problems. Some were solved with firmware update for router some with magic intervention from TalkTalk support. Unfortunately, after hours spent on chat and phone calls I haven't manage to get past the basic questions like "is the cable connected" and "everything is fine on our side" or "you are not using the TalkTalk router" answers.
Can someone help me with some guidance towards a solution?

 

Thank you!

0 Likes
12 REPLIES 12

Message 1 of 13

Hi Amoeb,

 

Glad to hear you managed to sort it out 

 

Chris

Message 2 of 13

Hi @Amoeb 

 

Glad you got it sorted.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

Message 3 of 13

Hi @Amoeb , glad you got it sorted.

 

Hope my input wasn't too confusing, as I said, the water was getting a bit deep for me.

 

 

Message 4 of 13

Well Martin, thanks. Your observation triggered me to re-evaluate my setup and I found that I had it all wrong but inexplicably functional for a long time. My modem was not set to bridge mode so I had 2 routers in my network. I reconfigured my modem and now everything works as expected.

That is my problem with networks, once it works I don't want to change anything but when it doesn't I need to read again the basics.

 

Thanks everyone for your inputs.

 

Message 5 of 13

@Amoeb , honestly, I am a bit of of my depth with this type of issue.

 

@KeithFrench , when he has time, can probably assess and advise as to how to configure your setup.

Message 6 of 13

You are right Martin, my mistake to use the TT as modem, I keep forgetting it cannot just replace my own modem, and keep everything else the same.

Just to confirm, I am back to my original setup, placed the TP-Link (TD-W9970) in modem mode, and connect LAN to WAN of the Asus router. With DHCP table .10 to .99 on the modem and .100 assigned for router, and router's DHCP disabled is there an error in my setup? I can connect manually to the router and I expect internet access.

Normally I would have modem's DHCP disabled and enabled on the router, all connections to router. But to minimize disturbance for all the connected devices (family) I use the modem as router also for now.

0 Likes

Message 7 of 13

Are you connecting your Asus solely to a standalone modem ?

 

That is the ONLY way it can work as a router.

 

If you are connecting it to the TT HUB, it will only work as an access point.

 

It must be connected LAN to LAN, with DHCP disabled on the Asus having given it a fixed IP address outwith the range of the HUB.

 

If you connect the HUB alone to the incoming line and get internet access, there is nothing wrong with the TT network.

 

 

 

 

Message 8 of 13

Thanks everyone for your answers. I missed the replies as I was checking only my email for notifications.

I did have an older firmware on the Asus router and updated to the latest one once the issue started. It did not make a difference.

 

And Debbie, I have powered down modem and router for more than 30 minutes now. No change. Asus router cannot get a WAN IP. All devices connected to TT modem have access to internet but none of the ones connected to the Asus router. 

 

 

 

0 Likes

Debbie-TalkTalk
Support Team
Message 9 of 13

Hi Amoeb

 

Apologies for the delay.

 

I've checked and your router has the latest firmware version.

 

I have also completed a radius re sync. Please can you power down the router for a full 30 minutes and then post back on this thread to let us know once the router has been switched back on again (following the 30 min power down)

 

Thanks

 

Debbie

Message 10 of 13

Is the internet link up & hence the virtual path to the internet? Sounds like you need TalkTalk to sort this. Please wait for an OCE hopefully tomorrow.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

FritzCT
Wise Owl
Message 11 of 13

Just a thought but try rolling back the firmware on the AC68U...I have a DSL-AC68U and the latest firmware for it plays havoc with my connection.

 

Fritz 

martswain
Philosopher
Message 12 of 13

The TT Router cannot be put into modem-only/bridge mode, so therefore disabling DHCP on that device will render it useless, as you have found.

 

There is no firmware update that allows those modes.

 

As you say it is working correctly on it's own, your issue must lie elsewhere.

 

@KeithFrench , any ideas ?