FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

DNS issues with SAGEMCOM 5364

LDeeJay
Popular Poster
Message 17 of 17

Lectori Salutem,

 

I'm having DNS issues with the Sagecom 5364 router. I've had these issues in the past with firmware SG4K10002816t. Changing the DNS to Google's 8.8.8.8 would solve the issue temporarily (10 mins tops) and swapping between several public DNS's and TalkTalk's kept the connection useable (if you can call it that). So I downgraded the firmware to SG4K10002600t and that kept the connection alive. Until the nightly automatic upgrade from TT and I could start swapping DNS's again. So I downgraded the firmware again and made sure the firmware could not be upgraded. That kept everything going perfectly without fail and without complaints.

Then my router died.  An engineer just swapped the router for an identical one (with firmware SG4K10002816t) and that was OK for about two weeks. Then the whole circus started again. So I thought I'd solve it by downgrading again to firmware SG4K10002600t. But to my amazement, this version now starts to have the same issues. I've left the upgrade possibility 'alive' but I'm now on the 'old' firmware for weeks and still have the same DNS issues.  Anyone with some insight and a proper solution? The callcenter couldn't help in the past so I'm not going to bother now

 

Cheers,

Leon

 

ps. I've read about the new firmware(SG4K100130) but is that the solution? And why does it have to take so long to provide customers with it and isn't this a standard solution within the FAQ'S? It could all be so much smoother and doesn't really improve the user experience, in fact it adds to the frustration massively.

 

16 REPLIES 16

Message 1 of 17

Hi LDeeJay,


Glad to hear everything is OK now 🙂

Chris

0 Likes

Skynet_TX
Community Star
Message 2 of 17

Yep, not sure what impact changing the details on the 'Internet Connectivity' screen now would have (if it lets you change it). In theory it should have no impact at all, as none of your devices should be using the router as a DNS server (i.e. if you had a Windows machine and looked at your network settings, you would see the DNS servers would be listed as the new IPs that you added on the Wi-Fi Hub screen, therefore that machine would be going to those IP's for DNS requests, and not using any DNS functionality within the router, and therefore making no use of the IP's on the 'Internet Connectivity' screen). But as you say, probably best not to play if things are working well now !

0 Likes

Message 3 of 17

Thanks for the clear explanation. It all makes (more) sense. What got me confused is that you can't change the DNS settings under Wifi-Hub once you've specified custom values under Internet Connectivity. You really need to set these to default to change the values under Wifi-Hub. So they are somewhat related. I thought that the DNS for the router itself was separate from the DNS for internal machines but when you want to specify the DNS for internal machines, the router's DNS must be set to the default. And when you specify the DNS for the router and keep the DNS for the internal machines default (the router) it apparently all stops.  I haven't tried to change the router's DNS back to custom and leave the other one as it is now (specified) to see what happens with the internal machines because there's no need at the moment and I'm not searching for issues or debugging it. If someone else wants to know )or knows) the answer, let me know.

 

Anyway, glad it's all solved.

 

Thanks again to all.

Skynet_TX
Community Star
Message 4 of 17

When a device connects to your router, that device needs to know what IP addresses it should send DNS requests to, the settings you have changed on the Wi-Fi Hub screen are these IP addresses. So when a device first connects to your router, the router will tell that device to use the IP addresses that you have specified on that screen whenever the device needs to do a DNS lookup, so initially when that screen was set to 192.168.1.1 (i.e. the routers address) that meant your devices asked your router to do DNS lookups. Now that you have changed that screen to some 'real' IP addresses your devices will hit those real addresses to do DNS lookups, so your devices are no longer asking your router to do DNS lookups. This is why it was important to reboot the devices or the router after you had changed that setting, as it is only when a device first connects to the router that the router passes the config details to the device to tell it what IP addresses to use for DNS lookups.

 

The other screen under 'Internet Connectivity' is the external IP addresses that your router will go to if the router is asked to do a DNS lookup by one of the devices that are connected to it. So prior to you making the change, all of your devices would have been asking your router to do DNS lookups, and when that happened your router would then go to the external IP addresses specified on the 'Internet Connectivity' screen to access an actual DNS service. Your devices will no longer be asking your router to do DNS lookups.

 

The fault with the firmware appears to be related to the DNS service itself within the router stalling. So changing the details on the 'Internet Connectivity' screen will not fix it, because with just that screen modified the router is still acting as a DNS server (just connecting to different external DNS services depending on what IP's you set). By changing the Wi-Fi Hub screen to some 'real' DNS server IP's you have told your devices to not use the router as a DNS server any more, and therefore they are now bypassing the routers stalled DNS service.

LDeeJay
Popular Poster
Message 5 of 17

No rush since the current solution is still working a treat. Even internal equipment (like the printer, scanner and cameras, mainly IP-based) are accessible so no complaints from me 😉

Still not sure which DNS-setting does what though...  I would have thought that the one under Internet Connectivity is for the router itself and the one under Wifi-Hub is for the local DHCP machines.  But why they have influence on one another is beyond me.  Oh well.... it's working now.

 

0 Likes

Message 6 of 17

Morning,

 

No timescales provided as yet for the firmware rollout to commence, however the router will be automatically updated.

 

Thanks

 

0 Likes

Skynet_TX
Community Star
Message 7 of 17

Hi,

 

Your router will automatically upgrade to the new version once the rollout is under way again. Not sure when the rollout will start again, but it should be coming soon (ish) !

LDeeJay
Popular Poster
Message 8 of 17

Debbie,

Thanks for the info. I'd like to try the new FW once available. If it doesn't work I can always downgrade again to the current version since it seems to hold up quite good.

 

Cheers,

Leon

 

 

0 Likes

Message 9 of 17

Hi LDeeJay

 

Thanks for your reply.

 

We do have new firmware that should resolve the DNS issue. The FW rollout has been paused at the moment but this should start again in the New Year.

 

Thanks

 

Debbie

0 Likes

LDeeJay
Popular Poster
Message 10 of 17

Hi @Debbie-TalkTalk,

 

So far the connection stays stable. I don't have to swap the DNS'ses anymore so all looks pretty well so far. It's still early days... the first time I got the router it took 2 weeks to start acting up. Not sure what causes it to start because it seems to come out of the blue (no config changes made on the router in these two weeks).

 

A note (to self): all machines with a fixed IP need to point to the external DNS as well since the router will not do that any more.

Message 11 of 17

Hi LDeeJay

 

How has the connection been since your last post?

 

Thanks

 

Debbie

0 Likes

Skynet_TX
Community Star
Message 12 of 17

Cool, for me that tweak seems to have been a permanent fix for the issue on SG4K10002816t, so lets hope it also resolves the problem for you. When the new 'fixed' firmware gets pushed out it may well revert this setting to the factory default anyway (but can't be sure), although for me, making this tweak has not caused any adverse affects, so I'm happy to stick with this config anyway.

LDeeJay
Popular Poster
Message 13 of 17

So I managed to apply settings as instructed. I've also reverted the firmware back to the most recent one (SG4K10002816t) just in case. At least we're then talking about the same thing. All is working as expected, the question now is... for how long. I'll keep an eye on it and will report back as soon as something pops up.

 

Thanks for your time and knowledge.

 

Skynet_TX
Community Star
Message 14 of 17

Ok, well below is the workaround that has worked for me, I had the same DNS issues with my Sagemcom, but with this tweak applied it has worked perfectly for many months now, my router is running firmware SG4K10002816t :

 

At present your router will be acting as the DNS server for all of your devices, so when the DNS stops working in your router all of your devices will lose internet access. However you could configure your router so that it just tells all of your devices to use the TalkTalk (or any other DNS provider of your choice) DNS servers directly, therefore your devices won't use the router as a DNS server, and so shouldn’t be affected if the routers DNS stops working.

 

If you wanted to try this you just need to follow the instructions for the 'Wi-Fi Hub' here (ensure you go to the screen described in this article, as there are two screens in the router where you can modify DNS settings, but you must change the settings on the specific screen described in this article for this potential fix to work). If it won't let you change the settings in this screen it may be because you have set specific DNS servers in the other screen where you can modify the DNS settings, if this is the case then go back and set that other screen back to Auto, that should then allow you to edit the details on this screen.

 

If you have never changed these settings before you will probably find that the primary DNS server is set to 192.168.1.1 (i.e. the router itself). You could change the settings as follows (or use any other DNS service of your choice) :

 

Primary : 79.79.79.79
Secondary : 79.79.79.80

 

These are the current preferred TalkTalk DNS servers (they are mentioned at the bottom of that webpage so you know they really are genuine TalkTalk DNS servers).

 

IMPORTANT : Having changed the settings you would need to make your devices disconnect and reconnect to the router (you could just reboot the devices or the router). When your devices have reconnected they will be configured to use those two addresses above as their DNS servers. So from that point on the devices will use the specified DNS servers directly rather than going via the routers DNS service.

 

Making this change may well resolve the issues for you, but if you do ever want to 'undo' this change all you need to do is put the old values back into that screen, or you could just factory reset the router by holding in the pinhole reset switch on the back for over 10 seconds, as that will return all settings back to their initial defaults.

LDeeJay
Popular Poster
Message 15 of 17

Hi @Skynet_TX ,

Thanks for the reply. 

The functionality to update your firmware is an option within the router, nothing obscure there.

I've swapped the firmware since TT couldn't help me. I know you're not supposed to and if things just work I wouldn't even bother. But the first time it occurred, I noticed that the problems started after TT updated to the new firmware so I googled the previous versions (pretty easy to find) and flashed the one that was in there originally. I know that blocking updates isn't the thing to do and takes a bit more effort and knowledge to get it done but it kept my connection alive and that was the main goal. Besides, these actions are not irreversible so as soon as TT would have come up with a proper solution, I could flag the router to receive updates again and everything would be as normal.

 

My setup is as simple as it comes. One router connects to the internet, everyone else internal connects to that one and only router (either Wifi or Wired). So I'm very curious as to what parameters I can tweak to resolve this issue. If it's the solution (I'm up for anything)  I don't need another router (unless they have suddenly come up with some pretty designs 😉 )

0 Likes

Skynet_TX
Community Star
Message 16 of 17

Hi @LDeeJay,

 

You say that you are downgrading the firmware, how are you doing this, customers are not meant to apply firmware updates themselves, firmware updates should only be pushed out by TalkTalk automatically.

 

There is a new version of firmware that fixes the DNS issues, but the rollout is currently paused whilst some other issues are being investigated.

 

The 'easy' fix is for TalkTalk to send you the Huawei hub to replace your Sagemcom Hub, as that is not affected by this issue.

 

There is a setting you can change on the Sagemcom that may well stop the issue from happening, but it is only a good idea to try this if you have a fairly simple home setup (i.e. just devices that need to access the internet), if you have devices that need to talk to each other and rely on your router to provide local DNS for the devices to find each other, then trying this workaround is probably not appropriate, as it may stop those devices from being able to see each other.

 

If you did want to try changing settings on your router then let me know and I'll post the details, you can easily undo the change if necessary.

 

The staff here will hopefully also be able to assist over the next few days, and may be able to offer a replacement Huawei router if that is something you wanted to try.

0 Likes