FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EchoLife DG8041W dropping Ethernet Connections

Stratosphere
Popular Poster
Message 11 of 11

EchoLife DG8041W, firmware 1.06t, Ethernet connections are dropping out, sometimes unplugging and plugging back in works, not always. 

 

Currently have Humax TV box, Playstation 5 (Won't connect via Ethernet at the moment) and a powerline adapter plugged into Ethernet. Had problems with the Humax a couple of weeks ago, swapping the cable to a different port on the router fixed it temporarily, now working OK.

 

Now the PS5 won't connect, swapping ports doesn't seem to fix it, very odd, any ideas welcome!!

0 Likes
10 REPLIES 10

Message 1 of 11

Hi Edward

 

That's great, thanks for letting us know.

 

Debbie

Message 2 of 11

All working thank you, old router is in the post coming back to you. Thank you once again.

Message 3 of 11

Hi Edward

 

Thanks for keeping us updated 🙂

 

Please let us know if you do experience any further issues.

 

Debbie

Message 4 of 11

New router arrived, seems we're back on a Sagemcom FAST5364 3.00 - version SG4K10001400t (I think that's what we had previously to the EchoLife DG8041W but I'm not entirely sure now). 

 

The important bit is that we're all back up and working on Ethernet (and WiFi) now so thank you so much for the outstanding support!

 

I'll monitor for a few days before sending the DG8041W back if that's OK, then mark the issue resolved of course.

 

Once again, thank you for the outstanding support!

 

Regards,

Edward Cunliffe

Message 5 of 11

Hi Edward

 

The replacement router is on its way, please allow 24-48hrs for this to arrive.

 

Let us know how the connection compares with this router.

 

Thanks

 

Debbie

Message 6 of 11

Yes please Debbie, that would be great thank you!

 

Regards,

Edward Cunliffe

Message 7 of 11

Hi Stratosphere

 

Sorry for the delay.

 

Would you like me to send a replacement router for testing?

 

Thanks

 

Debbie

Message 8 of 11

My thoughts too Keith, thank you for the input. 

0 Likes

KeithFrench
Community Star
Message 9 of 11

It could be a faulty router, I'll ask TalkTalk to investigate, but it won't be until Monday now.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

Stratosphere
Popular Poster
Message 10 of 11

P.S. Have tried hard reset of router, problem persists.

0 Likes