FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Extending wifi

Buzzy1
Popular Poster
Message 16 of 16

Hi iam trying to extend my wi fi coverage using a older TalkTalk dlink router All iam trying to do is connect the main router ( Sagemcom ) to the Dlink router using a cable so I can extend Wi-Fi range I have tried numerous settings as advised on YouTube etc but none will give me access to WiFi on Extended router can any body help with the settings I should use ,or does TalkTalk not allow you to do this.
sorry if this has been discussed before ,any help please.

buzzy

0 Likes
15 REPLIES 15

Message 1 of 16

I think we have got it fixed 🤔

did what you suggested by connecting laptop by cable to 1st router With wi-fi off.   I now couldn't  connect to the internet , swapped with another cable still no connection.😤as last resort switched 1st router Off for 10 min restarted router same connection as above I now could connect via laptop to 1st router with internet access😃 now connected cable between 1st Router and 2nd router ,With laptop connected also still working. Now disconnect laptop cable and now connected via wi-fi still working . I have no Idea how switching the router off seems to have sorted problem. Iam now using the settings you first posted on routers which now seem to be ok ,thanks for help and patience in trying to solve my problem.

Also if any body has the same problem of displaying photo on the post that are upside down it’s because you haven’t taken pic on iPad in the correct orientation even though they look ok on iPad , there is A comment about this problem on internet I believe it was to hold iPad with  home button on left hand side before taking pic...

Message 2 of 16

There is nothing obviously wrong there.

 

Just one last thing then. If you connect the laptop via ethernet to the Sagemcom, using the same LAN port that the second router (what model D-Link is it), can you access the internet then?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

Message 3 of 16

Now connected 1st Router with Ethernet cable to 2nd Router then connected laptop to 2nd router DHCP disabled on 2nd router. then done ipconfIg all see pic

 

2023743F-BB0B-466B-8E71-7B6C84A6886E.jpeg5053536B-E713-4B77-A148-4D672AA13581.jpeg

0 Likes

Message 4 of 16

When I asked for the ipconfig, I was assuming that the two routers were connected together & that the DHCP server in the 2nd router was disabled.

 

The previous ipconfig outputs were therefore meaningless as the two routers were not connected together, other than to possibly indicate that you have not disabled the 2nd router's DHCP server.

 

Please can redo this all connected & only the DHCP server on the main router enabled?

 

Thanks.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

Message 5 of 16

Ok this is what iam trying to achieve 

main router ( downstairs) connected with Ethernet cable to

2nd Router ( upstairs) so I can extend the WiFi coverage ,just using laptop as a access point to setup.the router.

 

when you asked for ipconfig readings All I connected was laptop to 2nd router via Ethernet cable to obtain these readings supplied nothing else was connected.

 

if I then connect main router to 2nd router via Ethernet cable with your settings ,then try to obtain a WiFi connection (which fails to get internet)

see attached screen pic.Sorry about pic upside down can’t find out why iam just copying them from my photo library on iPad .??

11

0 Likes

Message 6 of 16

Sorry, I am still not sure of your current setup, do you mean that the 2nd router is connected to the first router and that the laptop is connected to the second router via ethernet? If this is the case you are being allocated everything required by the DHCP server - this is on the first router only I assume?

 

What happens if you connect the laptop via Ethernet to the LAN port that is normally used for the second router?

 

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 7 of 16

My settings at present 
second router only connected to laptop via Ethernet cable .

Wi-Fi disconnected on laptop to access the readings Provided by ipconfig 

0 Likes

Message 8 of 16

So just to confirm, currently, the laptop was connected to the first router via Ethernet and the second router disconnected & you can't access the internet. There is no obvious reason why. Once you can confirm if I have understood your current setup I will try & help further.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 9 of 16
Apologise for pic upside down no idea why
0 Likes

Message 10 of 16

1A2DDD95-0EE3-4ADB-A7CA-115483F8E16E.jpeg705E3E30-C401-42E2-953E-1FDC985BBFEF.jpeg

0 Likes

Message 11 of 16

Thanks for info I disconnected Ethernet between prImary and secondary .applied config all on laptop took screen shot.of info .but now I can’t seem to attach pic for some reason ..?.

thanks graham 

0 Likes

Message 12 of 16

On your laptop (assuming Windows) go to the command prompt and issue the command:-

 

ipconfig /all

 

and press return.

 

Please include the output in your reply.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 13 of 16

Thanks for your speedy answers but unfortunately still not accessing WiFi.  All I have done this time is do a factory reset button on rear of second router . Connect laptop via Ethernet cable to router only .access again via 192.168.1.1 changed to .3 this time on channel 6 DHCP off .i have not changed anything on main router.

after disconnecting laptop from router then connecting cable from main to secondary still no access if I click on the taskbar icon it says connected .?.But no internet . Any other ideas.

0 Likes

Message 14 of 16

Hi @martswain @Buzzy1 

 

Yes, Martin that about it, other than to only use channels 1,6 or 11 in the 2.4GHz band. However, I would always recommend you check channel congestion via a WiFi analyser first, otherwise, it may not work as hoped. I can always help with that if you require it.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

martswain
Philosopher
Message 15 of 16

Sagemcom IP 192.168.1.1 (This is the usual, no need to change)

 

Sagemcom DHCP Range 192.168.1.10 to 255

 

Give the slave router a fixed IP of 192.168.1.2

 

Disable DHCP on the slave router.

 

Connect both devices LAN to LAN socket .

 

Make sure the WiFi channels are not the same, they'll interfere with each other.

 

@KeithFrench , did I get it right ? )