FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

FAST5364 firmware SG4K10002816t not sending IPv4 DNS to DHCP devices

bawdrip
Whizz Kid
Message 8 of 8

Whichever DNS option I set ('Obtain DNS Automatically' or 'Manually Specify DNS') in... 

Dashboard > See internet settings > Manage advanced settings > Internet connectivity

...I cannot get any device that connects to the router using DHCP to get usable internet without having to manually set each device's DNS to a static value (such as 1.1.1.1 or 79.79.79.79 or even the local address of the router which for me is 192.168.53.1).

 

If I set DNS on a Windows 7 pc in IPv4 properties to 'Obtain DNS address automatically' (i.e. if I don't set a static DSN on the computer itself so am relying on one coming from the router) then ipconfig /all shows no IPv4 DNS, it only shows 3 values which perhaps are IPv6 addresses... 

DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1

...whereas if I set the Windows button for 'Use the following DNS server addresses' and one of the addresses 1.1.1.1 or 192.168.53.1 etc then browsing works and ipconfig says...

DNS Servers . . . . . . . . . . . : 192.168.53.1

(or 1.1.1.1 or whatever I set, in the IPv4 network properties via Windows Control Panel)

 

In the past I used to set a static DNS address for the router to send out, in...

See internet settings -> Manage advanced settings -> TalkTalk Wi-fi Hub -> DNS -> Enabled ON

...but that option now seems to be greyed out and unchangeable (I've seen in other incidents that it is considered inefficient, although now I realise I would want the router to work as if I'd put 192.168.53.1 there, which surely ought to be the same behaviour one would expect with Enabled OFF

 

How do I get the router to actually tell Windows7 (& all the other DHCP devices) a valid IPv4 DNS address (either it's own or the one specified in Internet connectivity) ?

0 Likes
7 REPLIES 7

palani
First Timer
Message 1 of 8

Hello there,

 

I have been trying to use a Custom DNS server instead of TalkTalk's DNS server due to the numerous issues we have been facing with simple UK sites like learningjournals.com.

I have a TalkTalk Wifi-Hub running SG4K10002816t and am just not able to set the DNS server at all. While the Ethernet settings have been set to the DNS server I wish to use, I notice that the main hub uses the TalkTalk DNS which is the one that is given to the DHCP clients. 

palani_0-1617539918263.png

 

palani_1-1617539942457.png

palani_2-1617540039633.png

Kindly advise how to  get past this - I have provided screenshots of the IPv4 configuration as well as the output of the ipconfig /all on the client Windows PC.

 

Thank you.

 

0 Likes

Message 2 of 8

Hi

 

A Huawei Hub is on the way to you.

 

Thanks  

 

Karl. 

Check & Report l Our latest Blog l Set Your Preferences l Service Status l Help with your Service l Community Stars

Working From Home Tips


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


WEAR A MASK      -      WASH YOUR HANDS      -      SOCIAL DISTANCE

0 Likes

bawdrip
Whizz Kid
Message 3 of 8

Yes please.

Using the DNS server on the Sagemcom FAST router seems to have gone slow again today, had to change pc to static DNS whereas another pc already with 1.1.1.1 to avoid router's DNS was still fine.  For now will change router to dish out 1.1.1.1 to DHCP devices rather than it's own address (still have original problem where static Enabled OFF would result in connected devices having no IPv4 DNS thus no usable internet).

(also re this forum: I lost all I typed earlier because it asked me to login again - I'd left the page showing msgs so far, then clicked Reply, typed a lot, hit post and it said I needed to be logged on and threw my typing away - please fix, eg disallow clicking Reply if not logged on something).

0 Likes

Michelle-TalkTalk
Support Team
Message 4 of 8

Hi bawdrip,

 

Would you like us to send a Huawei Wifi hub instead to see how this one compares? We can also send a router returns bag too so that one of the routers can be returned.

 

Thanks

 

0 Likes

bawdrip
Whizz Kid
Message 5 of 8

And today I am again able to change the 'Static DNS Server Configuration', it is not greyed out!

I've worked out what's happening - you can only change the static config (ON/OFF & the 2 addresses) at...
See internet settings -> Manage advanced settings -> TalkTalk Wi-fi Hub -> DNS

...if this other setting at... 
Dashboard > See internet settings > Manage advanced settings > Internet connectivity
...is set to 'Obtain DNS Automatically' !

 

But why? They're shouldn't be related, one is what to send to DHCP clients and the other is what the router will use to accumulate entries in its DSN server, which independently may or may not be what the DHCP clients are told to use.  So there should be no reason to greyout one of them depending on the setting of the other.  Madness!!  What are the people who maintain the firmware thinking of? 

But anyway, you can circumvent the restriction by setting the Static ON/OFF etc before setting 'Manually Specify DNS' if that's what you want (only really matters if you want the router to obtain its own requests from non-talktalk dns since the 'Manually' address would only effect those, unless you'd had to set the ON to force the router to tell DHCP clients its own IPv4 address, which it didn't seem to do otherwise, see original problem description).

 

I see there's a later router now, the 'Black' one.  I wonder if the firmware & gui in that is better - Sagecom's FAST5364 has seemed a bit quirky ever since the trial, too many levels of menu and too much having to go back to the top dashboard - only just useable compared to the older DLink devices which always kept the main menu visible at the left.

0 Likes

bawdrip
Whizz Kid
Message 6 of 8

Today I seem to be able to set Enabled ON, so the router sends out a specific DNS server address like it used to months ago (I've set it to the router's) which makes DHCP connections  work properly, whereas yesterday I could not do that, it was greyed out. 

See internet settings -> Manage advanced settings -> TalkTalk Wi-fi Hub -> DNS -> Enabled ON
Primary DNS Server 192.168.53.1


The underlying problem, no usable DNS is received by DHCP devices if Enabled is OFF, still exists.

 
What changed?? (the firmware level didn't) 

0 Likes

bawdrip
Whizz Kid
Message 7 of 8

BTW, the reason I used to set a static external DNS address such as 8.8.4.4 (or more recently 1.1.1.1) for the router to send out to DHCP devices, was that I found the DNS server within the router to be unreliable - after a few days or weeks it would stop working, as if some internal table or cache had overflowed or become corrupted (possibly in the way that used to happen due to virus attacks on some older routers).  Bearing this in mind it seems the greying-out of that option makes the Sagecom FAST router less robust - they have removed the failsafe option for bypassing the builtin DNS server.  Not good.

0 Likes