FIbre Support

Get expert support with your Fibre connection.

Showing results for 
Show  only  | Search instead for 
Did you mean: 


Message 10 of 10



I have a SagemCom Fast 5364 router (version SG4K10002816t) and I am experiencing what is a common problem of being unable to create new connections to websites, video chat etc. Anything that is already open/connected works fine until refreshed/reloaded. Any new connections fail giving a DNS server error.


The issue can be resolved by going in to the router settings and switching the DNS between 'Obtain DNS Automatically' and 'Manually Specify DNS'.


There are no issues with the line or setup as the same setup has been used for 10 years, albeit with a Netgear router before changing to the Sagemcom. This issue has only appeared since upgraded to Fibre and using the Sagemcom.


It can be many days between these DNS problems or several can happen in the same day with minutes or hours between each setting change.


Reading the other related threads, it seems that there are two resolutions, either roll back to the previous firmware or swap the router with the Huawei.


Any thoughts/resolutions would be greatly appreciated.


Many thanks




Message 1 of 10

Hi David


Unfortunately we have no further information/dates to share at the moment. Apologies for this.




Message 2 of 10

Hi Michelle

Do you have any feedback from the Product Manager regarding a release date for the Sagemcom firmware update?


Thanks, David


Message 3 of 10



I'm sorry for the delay. We have a meeting with the Product Manager tomorrow so hopefully we will know more about when the new firmware for the Sagemcom router will be available.




Message 4 of 10

typo error  the primary should be    and not as i stated



Community Star
Message 5 of 10

What i suggest. And it works for me.

Change your ip4 DNS to point at     and

Fr ordinary dns.  Change  also to above

This works perfect for 2816t firmware.  Also cures the odd dns error under the latest firmware that i am testing.  Try it.




Message 6 of 10

Thanks for that, makes sense as the DHCP server is now pushing the absolute DNS server addresses, rather than directing to a central point.


I've made the change in the config and will reboot the router tonight once the usage is less or if the issue comes up again.


Unfortunately I won't be able to report back to say if it's worked or not as the issue is so intermittent (although typically it's happened 5 times today) I won't know if it's actually fixed or just hasn't happened yet.


I'd still like to hear back from the TalkTalk staff tomorrow to see if there is an ETA on the updated firmware.


Thanks again Skynet_TX



Community Star
Message 7 of 10

It may depend on your home LAN setup as to whether these changes would be appropriate for you, but the changes described below can often help in this situation. You would probably need to change the setting you have been adjusting back to Automatic DNS, otherwise it may not allow you to make these changes.


At present your router will be acting as the DNS server for all of your devices, so when the DNS stops working in your router all of your devices will lose internet access. However you could configure your router so that it just tells all of your devices to use the TalkTalk DNS servers directly, therefore your devices won't use the router as a DNS server, and so shouldn’t be affected if the routers DNS stops working.


If you wanted to try this you just need to follow the instructions for the 'Wi-Fi Hub' here (ensure you go to the screen described in this article, as there are two screens in the router where you can modify DNS settings, but you must change the settings on the specific screen described in this article for this potential fix to work).


If you have never changed these settings before you will probably find that the primary DNS server is set to (i.e. the router itself). You could change the settings as follows :


Primary :
Secondary :


These are the current preferred TalkTalk DNS servers (they are mentioned at the bottom of that webpage so you know they really are genuine TalkTalk DNS servers).


IMPORTANT : Having changed the settings you would need to make your devices disconnect and reconnect to the router (you could just reboot the devices or the router). When your devices have reconnected they will be configured to use those two addresses above as their DNS servers. So from that point on the devices will use the TalkTalk DNS servers directly rather than going via the routers DNS service.


Making this change may well resolve the issues for you, but if you do ever want to 'undo' this change all you need to do is put the old values back into that screen, or you could just factory reset the router by holding in the pinhole reset switch on the back for over 10 seconds, as that will return all settings back to their initial defaults.


If you didn't want to make these changes, or if they would cause issues with your home LAN setup, then it would be best to let the staff here pick this post up tomorrow, they may well be able to send you a replacement Huawei router, that router is not affected by these DNS issues.

Message 8 of 10

Hi Skynet_TX


Thanks for your reply and confirming that it is indeed a known issue.


Very comfortable with changing settings within the router (have setup my own Port Forwarding and custom Firewall rules), so if you have a workaround that can help, I would appreciate the information.


If this proves to be a long term workaround, then I would be happy to wait for a new firmware update too, rather than changing hardware and creating unnecessary waste.


Many thanks




Community Star
Message 9 of 10

Hi @bigdave25,


You are probably experiencing a known issue that affects the DNS service of the router. TalkTalk are currently working on a new version of the firmware that will fix the issue, but they have not confirmed when this will be released.


If you are comfortable with logging into the router and changing some settings then I could give you details of something you could do that might work around the issue and stop it from causing this problem. If you would rather not do this then the staff here will be able to offer further help, they may be able to provide a replacement router of a different type for you, they will hopefully be able to respond to this post tomorrow.